[PATCH] gnu: Add emacs-sxiv.

  • Done
  • quality assurance status badge
Details
3 participants
  • Clément Lassieur
  • Felix Lechner
  • pinoaffe
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 25 Jul 2023 14:01
96920daec8e1aae71705447dcedf97f01197b555.1690319724.git.pinoaffe@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-sxiv): New variable.
---
gnu/packages/emacs-xyz.scm | 33 ++++++++++++++++++++++++++++++++-
1 file changed, 32 insertions(+), 1 deletion(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d7e45fffc6..cc350e4116 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020, 2022 pinoaffe <pinoaffe@gmail.com>
+;;; Copyright © 2020, 2022, 2023 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -207,6 +207,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages llvm)
#:use-module (gnu packages image)
+ #:use-module (gnu packages image-viewers)
#:use-module (gnu packages linux)
#:use-module (gnu packages libevent)
#:use-module (gnu packages lisp)
@@ -26431,6 +26432,36 @@ (define-public emacs-picpocket
@end itemize")
(license license:gpl3+))))
+(define-public emacs-sxiv
+ (package
+ (name "emacs-sxiv")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://tildegit.org/contrapunctus/sxiv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gimq172pp143jckfhhyw319n3vpjvlkadm0vhypycas9i89mcg0"))))
+ (propagated-inputs (list sxiv emacs-dash))
+ (arguments
+ `( #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-sxiv-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-sexps "sxiv.el"
+ (":command
+ (append"
+ `(list ,(string-append (assoc-ref inputs "sxiv")
+ "/bin/sxiv")))))))))
+ (build-system emacs-build-system)
+ (home-page "https://tildegit.org/contrapunctus/sxiv")
+ (synopsis "Launch sxiv from Emacs with Dired integration")
+ (description "")
+ (license license:unlicense)))
+
(define-public emacs-mu4e-conversation
(let ((commit "98110bb9c300fc9866dee8e0023355f9f79c9b96")
(revision "5"))

base-commit: 005912c595bf7a3329f8aa51a4ccb1d91b6ecd9e
--
2.41.0
P
P
pinoaffe wrote on 23 Aug 2023 19:19
[PATCH v2] gnu: Add emacs-sxiv.
(address . 64864@debbugs.gnu.org)
3c1682f0213524f95c9e4b1cc1af70f3efeeeee6.1692811071.git.pinoaffe@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-sxiv): New variable.
---
gnu/packages/emacs-xyz.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d7e45fffc6..18bd15dcc4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -70,7 +70,7 @@
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2020, 2022 pinoaffe <pinoaffe@gmail.com>
+;;; Copyright © 2020, 2022, 2023 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
@@ -207,6 +207,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages llvm)
#:use-module (gnu packages image)
+ #:use-module (gnu packages image-viewers)
#:use-module (gnu packages linux)
#:use-module (gnu packages libevent)
#:use-module (gnu packages lisp)
@@ -26431,6 +26432,39 @@ (define-public emacs-picpocket
@end itemize")
(license license:gpl3+))))
+(define-public emacs-sxiv
+ (package
+ (name "emacs-sxiv")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://tildegit.org/contrapunctus/sxiv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gimq172pp143jckfhhyw319n3vpjvlkadm0vhypycas9i89mcg0"))))
+ (inputs (list sxiv))
+ (propagated-inputs (list emacs-dash))
+ (arguments
+ `( #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-sxiv-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-sexps "sxiv.el"
+ (":command
+ (append"
+ `(list ,(string-append (assoc-ref inputs "sxiv")
+ "/bin/sxiv")))))))))
+ (build-system emacs-build-system)
+ (home-page "https://tildegit.org/contrapunctus/sxiv")
+ (synopsis "Launch sxiv from Emacs with Dired integration")
+ (description "This package integrates sxiv into Dired. It adds a command
+to start sxiv from a Dired buffer, allowing you to mark or unmark image files
+in said buffer using sxiv.")
+ (license license:unlicense)))
+
(define-public emacs-mu4e-conversation
(let ((commit "98110bb9c300fc9866dee8e0023355f9f79c9b96")
(revision "5"))

base-commit: 005912c595bf7a3329f8aa51a4ccb1d91b6ecd9e
--
2.41.0
C
C
Clément Lassieur wrote on 20 Oct 2023 18:21
(name . pinoaffe)(address . pinoaffe@gmail.com)(address . 64864-done@debbugs.gnu.org)
87r0lptgbn.fsf@lassieur.org
Hey,

Pushed with a small indentation change:

I ran `indent-region` and removed a space before "#:phases".

Thanks!
Closed
F
F
Felix Lechner wrote on 29 Nov 2023 18:38
(no subject)
(address . control@debbugs.gnu.org)
87jzq0lasi.fsf@lease-up.com
unarchive 64864
reassign 64864 guix-patches
archive 64864
thanks
?