[PATCH] gnu: Add emacs-lexic.

  • Done
  • quality assurance status badge
Details
3 participants
  • Clément Lassieur
  • Felix Lechner
  • pinoaffe
Owner
unassigned
Submitted by
pinoaffe
Severity
normal
P
P
pinoaffe wrote on 25 Jul 2023 23:06
a73d7f98c735cdc7fc6c0fb8b1bdb7135ae13c0d.1690319305.git.pinoaffe@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-lexic): New variable.
---
gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d7e45fffc6..10b8923ada 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36508,6 +36508,42 @@ (define-public emacs-multitran
to the @url{https://multitran.com} online dictionary.")
(license license:gpl3+)))
+(define-public emacs-lexic
+ (let ((release "0")
+ (revision "0")
+ (commit "f9b3de4d9c2dd1ce5022383e1a504b87bf7d1b09"))
+ (package
+ (name "emacs-lexic")
+ (version (git-version release revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.tecosaur.net/tec/lexic")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02iz8dh18gb1q97v8ghcd3lavkf28sqbrk0bx6jzzryp69ickk4h"))))
+ (build-system emacs-build-system)
+ (inputs (list sdcv))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-sdcv-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (emacs-substitute-variables "lexic.el"
+ ("lexic-program-path"
+ (string-append (assoc-ref inputs "sdcv")
+ "/bin/sdcv"))))))))
+ (propagated-inputs (list sdcv))
+ (home-page "https://git.tecosaur.net/tec/lexic")
+ (synopsis "Find out more about words using Stardict dictionaries")
+ (description "This provides a major mode to view the output of
+dictionary tools, and utilities that perform searches and nicely format the
+results. Currently tied to sdcv, but this is intended to be changed in the
+future.")
+ (license license:gpl2+))))
+
(define-public emacs-blacken
(package
(name "emacs-blacken")

base-commit: 005912c595bf7a3329f8aa51a4ccb1d91b6ecd9e
--
2.41.0
C
C
Clément Lassieur wrote on 20 Oct 2023 18:19
(name . pinoaffe)(address . pinoaffe@gmail.com)(address . 64863-done@debbugs.gnu.org)
87ttqltgfu.fsf@lassieur.org
LGTM, pushed with a few modifications:

- removing the "release" local binding. The reason for the "revision"
local binding is, I believe, to make sure people increment it upon
modifying the package. But there is no need to increment the
"release" number if it's not incremented upstream.

- removed sdcv as propagated input. It's only an input, I don't think
it needs to be installed since the full path is written within the .el
file.

- changed the license to gpl3+

Thanks and sorry for the huge delay.
Clément


pinoaffe <pinoaffe@gmail.com> writes:

Toggle quote (54 lines)
> * gnu/packages/emacs-xyz.scm (emacs-lexic): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index d7e45fffc6..10b8923ada 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -36508,6 +36508,42 @@ (define-public emacs-multitran
> to the @url{https://multitran.com} online dictionary.")
> (license license:gpl3+)))
>
> +(define-public emacs-lexic
> + (let ((release "0")
> + (revision "0")
> + (commit "f9b3de4d9c2dd1ce5022383e1a504b87bf7d1b09"))
> + (package
> + (name "emacs-lexic")
> + (version (git-version release revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.tecosaur.net/tec/lexic")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "02iz8dh18gb1q97v8ghcd3lavkf28sqbrk0bx6jzzryp69ickk4h"))))
> + (build-system emacs-build-system)
> + (inputs (list sdcv))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'set-sdcv-path
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (emacs-substitute-variables "lexic.el"
> + ("lexic-program-path"
> + (string-append (assoc-ref inputs "sdcv")
> + "/bin/sdcv"))))))))
> + (propagated-inputs (list sdcv))
> + (home-page "https://git.tecosaur.net/tec/lexic")
> + (synopsis "Find out more about words using Stardict dictionaries")
> + (description "This provides a major mode to view the output of
> +dictionary tools, and utilities that perform searches and nicely format the
> +results. Currently tied to sdcv, but this is intended to be changed in the
> +future.")
> + (license license:gpl2+))))
> +
> (define-public emacs-blacken
> (package
> (name "emacs-blacken")
>
> base-commit: 005912c595bf7a3329f8aa51a4ccb1d91b6ecd9e
Closed
F
F
Felix Lechner wrote on 29 Nov 2023 18:59
(no subject)
(address . control@debbugs.gnu.org)
878r6gl9tc.fsf@lease-up.com
unarchive 64863
reassign 64863 guix-patches
archive 64863
thanks
?