(address . guix-patches@gnu.org)(name . Wamm K. D)(address . jaft.r@outlook.com)
* gnu/packages/python-xyz.scm (python-manimpango): New variable.
---
gnu/packages/python-xyz.scm | 22 +++++++++++++++++++++-
1 file changed, 21 insertions(+), 1 deletion(-)
Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db3e69fb45..14cb375a8a 100644
Right now, the tests are failing with "No module named 'manimpango.cmanimpango'";
it's clearly trying to import the package so it can use it for testing but the
test files are failing to find it (it looks like the "cmanimpango" file is a C
file (along with .pxd and .pyx files) so maybe it's Cython related?).
Is there a way we usually handle this for Python/Cython packages?
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,7 +119,7 @@
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
-;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -9292,6 +9292,26 @@ (define-public python-xcffib
support for Python 3 and PyPy. It is based on cffi.")
(license license:expat)))
+(define-public python-manimpango
+ (package
+ (name "python-manimpango")
+ (version "0.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ManimPango" version))
+ (sha256 (base32
+ "00x1l55wy0k6v3b6l2g5603zk5d5dab59fwkxq6jq4ncifwiqbvk"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list pkg-config python-cython python-pytest))
+ (inputs (list pango))
+ (home-page "https://pypi.org/project/ManimPango/")
+ (synopsis "Bindings for Pango for using with Manim.")
+ (description "Python bindings for ManimPango which is a C binding for Pango,
+using Cython.
+
+ManimPango is internally used in Manim to render (non-LaTeX) text.")
+ (license license:expat)))
+
(define-public python-cairocffi
(package
(name "python-cairocffi")
--
2.41.0