Requires myMPD v11.0.0.
* gnu/packages/mpd.scm (mympd)[arguments]: Enable tests.
---
gnu/packages/mpd.scm | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3c00528a97..85b9277a40 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -629,8 +629,16 @@ (define-public mympd
(arguments
(list
#:configure-flags
- #~(list "-DMYMPD_STRIP_BINARY=OFF") ; handled by 'strip phase
- #:tests? #f)) ; no test target
+ #~(list "-DMYMPD_BUILD_TESTING=ON"
+ ;; Handled by 'strip' phase.
+ "-DMYMPD_STRIP_BINARY=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The following test requires network connectivity.
+ (invoke "ctest" "--exclude-regex" "test_http_client")))))))
(native-inputs (list jq perl pkg-config))
(inputs (list flac libid3tag lua openssl pcre2))
(home-page "https://jcorporation.github.io/")
--
2.40.1