Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioinformatics.scm (python-decoupler-py): Update to (git-version 1.5.0 revision commit).
---
gnu/packages/bioinformatics.scm | 49 +++++++++++++++++----------------
1 file changed, 25 insertions(+), 24 deletions(-)
Toggle diff (74 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a0ae298a2c..d39a47d694 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1680,11 +1680,11 @@ (define-public python-cmseq
(define-public python-decoupler-py
;; This latest commit fixes a bug in test_omnip.py.
- (let ((commit "b84c524ec4a9280a56c0db963e2c7b010316ce8f")
+ (let ((commit "459b235348ddd9135217a3722d9dd1caa9a14ace")
(revision "1"))
(package
(name "python-decoupler-py")
- (version (git-version "1.3.1" revision commit))
+ (version (git-version "1.5.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1693,30 +1693,31 @@ (define-public python-decoupler-py
(file-name (git-file-name name version))
(sha256
(base32
- "0d74yr5jqc52vcxaca84kxqw7m5rbazpmvnrcp2y4xxrj6yr1sfc"))))
+ "1c0xk006iilyffdaqar2d05qdhik22fbkny387zx0bndkgqifxhl"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:test-flags
- '(list "-k"
- ;; These tests require internet access
- (string-append "not test_get_resource"
- " and not test_show_resources"
- " and not test_get_dorothea"
- " and not test_get_progeny"
- ;; XXX This one fails because the "texts" list
- ;; is empty, so there are no texts to adjust.
- ;; It is not clear whether this a compatibility
- ;; problem with our adjusttext package.
- " and not test_plot_volcano"))
- #:phases
- '(modify-phases %standard-phases
- (add-before 'check 'set-home
- ;; Some tests require a home directory to be set.
- (lambda _ (setenv "HOME" "/tmp")))
- ;; Numba needs a writable dir to cache functions.
- (add-before 'build 'set-numba-cache-dir
- (lambda _ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (list #:test-flags '(list "-k"
+ ;; These tests require internet access
+ (string-append "not test_get_resource"
+ " and not test_show_resources"
+ " and not test_get_dorothea"
+ " and not test_get_progeny"
+ " and not test_get_collectri"
+ " and not test_get_ksn_omnipath"
+ ;; XXX This one fails because the "texts" list
+ ;; is empty, so there are no texts to adjust.
+ ;; It is not clear whether this a compatibility
+ ;; problem with our adjusttext package.
+ " and not test_plot_volcano"))
+ #:phases '(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ ;; Some tests require a home directory to be set.
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
(propagated-inputs (list python-adjusttext
python-anndata
python-ipython
--
2.34.1