[PATCH core-updates] gnu: coreutils: Skip tests which are broken on btrfs

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Ryan Sundberg
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal
R
R
Ryan Sundberg wrote on 22 Jul 2023 02:55
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20230722005515.32202-1-ryan@arctype.co
When building coreutils on a BTRFS filesystem, this test case
consistently fails.

* gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
---
gnu/packages/base.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1fdfaf8a57..a9dab0b30f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -464,7 +464,11 @@ (define-public coreutils
;; there might be some environmental factor
;; here
((" test-tls\\$\\(EXEEXT\\) ") " ")))
- '())
+ '((substitute*
+ ;; This test fails on BTRFS
+ '("tests/cp/reflink-auto.sh")
+ (("^#!.*" all)
+ (string-append all "exit 77;\n")))))
(substitute* "Makefile.in"
;; fails on filesystems where inotify cannot be used,
;; more info in #47935
--
2.37.2
M
M
Maxim Cournoyer wrote on 22 Jul 2023 03:55
(name . Ryan Sundberg)(address . ryan@arctype.co)(address . 64779@debbugs.gnu.org)
87pm4khfqy.fsf@gmail.com
Hello,

Ryan Sundberg <ryan@arctype.co> writes:

Toggle quote (23 lines)
> When building coreutils on a BTRFS filesystem, this test case
> consistently fails.
>
> * gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
> ---
> gnu/packages/base.scm | 6 +++++-
> 1 file changed, 5 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
> index 1fdfaf8a57..a9dab0b30f 100644
> --- a/gnu/packages/base.scm
> +++ b/gnu/packages/base.scm
> @@ -464,7 +464,11 @@ (define-public coreutils
> ;; there might be some environmental factor
> ;; here
> ((" test-tls\\$\\(EXEEXT\\) ") " ")))
> - '())
> + '((substitute*
> + ;; This test fails on BTRFS
> + '("tests/cp/reflink-auto.sh")
> + (("^#!.*" all)
> + (string-append all "exit 77;\n")))))

Could you please report the issue to upstream, and add a comment with a
reference to the open issue?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Jan 03:47 +0100
(name . Ryan Sundberg)(address . ryan@arctype.co)
87wms3bdxs.fsf_-_@gmail.com
tags 64779 + unreproducible
quit

Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (30 lines)
> Hello,
>
> Ryan Sundberg <ryan@arctype.co> writes:
>
>> When building coreutils on a BTRFS filesystem, this test case
>> consistently fails.
>>
>> * gnu/packages/base.scm (coreutils): Skip tests/cp/reflink-auto.sh
>> ---
>> gnu/packages/base.scm | 6 +++++-
>> 1 file changed, 5 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
>> index 1fdfaf8a57..a9dab0b30f 100644
>> --- a/gnu/packages/base.scm
>> +++ b/gnu/packages/base.scm
>> @@ -464,7 +464,11 @@ (define-public coreutils
>> ;; there might be some environmental factor
>> ;; here
>> ((" test-tls\\$\\(EXEEXT\\) ") " ")))
>> - '())
>> + '((substitute*
>> + ;; This test fails on BTRFS
>> + '("tests/cp/reflink-auto.sh")
>> + (("^#!.*" all)
>> + (string-append all "exit 77;\n")))))
>
> Could you please report the issue to upstream, and add a comment with a
> reference to the open issue?

I've searched the upstream issue tracker, and found none about this.
I've built coreutils 9.1 and latest master from source on my Btrfs
machine, which ran the test suite fine. I've also rebuilt the current
Guix coreutils package with success on the same machine.

I don't think the problem is with Btrfs, or at least it's not easy to
reproduce.

Closing for now.

--
Thanks,
Maxim
?