[PATCH 00/12] Add and update a bunch of Emacs packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1689948587.git.a.r.draidi@redscript.org
Hello Guix,

A bunch of additions and updates to Emacs packages, bundled together for review convenience.

Second patch restyles 'emacs-idle-highlight' because we changed the parentheses level.

Keep up the good work!

Ahmad Draidi (12):
gnu: emacs-idle-highlight: Update to 1.1.4-0.f9091c9.
gnu: emacs-idle-highlight: Restyle format.
gnu: Add emacs-nerd-icons.
gnu: Add emacs-nerd-icons-completion.
gnu: Add emacs-nerd-icons-dired.
gnu: Add emacs-nerd-icons-ibuffer.
gnu: Add emacs-nerd-icons-ivy-rich.
gnu: Add emacs-treemacs-nerd-icons.
gnu: Add emacs-rebecca-theme.
gnu: emacs-base16-theme: Update to 3.1.
gnu: Add emacs-chocolate-theme.
gnu: Add emacs-dired-preview.

gnu/packages/emacs-xyz.scm | 278 ++++++++++++++++++++++++++++++++++---
1 file changed, 256 insertions(+), 22 deletions(-)


base-commit: 6bda806416b8e6032ef1047c5feed776b6cc0493
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 01/12] gnu: emacs-idle-highlight: Update to 1.1.4-0.f9091c9.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
57651b67c37167b194ba113a09e8c3121ac3cba7.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-idle-highlight): Update to
1.1.4-0.f9091c9.
[version, source]: Switch to commit.
[url, home-page]: Use new maintainer's URL.
---
gnu/packages/emacs-xyz.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 550e5d2a65..6fcee172bb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17179,27 +17179,31 @@ (define-public emacs-lin
(license (list license:gpl3+
license:fdl1.3+)))) ; GFDLv1.3+ for the manual
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
(define-public emacs-idle-highlight
+ (let ((commit "f9091c907d41e7b12d99d108a194229b8dbfc5ae")
+ (revision "0"))
(package
(name "emacs-idle-highlight")
- (version "1.1.3")
+ (version (git-version "1.1.4" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/nonsequitur/idle-highlight-mode")
- (commit version)))
+ (url "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0x4w1ksrw7dicl84zpf4d4scg672dyan9g95jkn6zvri0lr8xciv"))))
+ (base32 "0757x4iy7q0mj1rshlxr00hbc78g5hzijgzyqs36nrw6bn65fb93"))))
(build-system emacs-build-system)
- (home-page "https://www.emacswiki.org/emacs/IdleHighlight")
+ (home-page "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
(synopsis "Highlights all occurrences of the word the point is on")
(description
"This Emacs package provides @code{idle-highlight-mode} that sets
an idle timer to highlight all occurrences in the buffer of the word under
the point.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-ox-twbs
(package
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 02/12] gnu: emacs-idle-highlight: Restyle format.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
e190a4be91ccb9390e0c7cf9587f676c66e9c7b8.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-idle-highlight): Restyle format.
---
gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++------------------
1 file changed, 19 insertions(+), 18 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6fcee172bb..8d3c069609 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17184,26 +17184,27 @@ (define-public emacs-lin
(define-public emacs-idle-highlight
(let ((commit "f9091c907d41e7b12d99d108a194229b8dbfc5ae")
(revision "0"))
- (package
- (name "emacs-idle-highlight")
- (version (git-version "1.1.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0757x4iy7q0mj1rshlxr00hbc78g5hzijgzyqs36nrw6bn65fb93"))))
- (build-system emacs-build-system)
- (home-page "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
- (synopsis "Highlights all occurrences of the word the point is on")
- (description
- "This Emacs package provides @code{idle-highlight-mode} that sets
+ (package
+ (name "emacs-idle-highlight")
+ (version (git-version "1.1.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0757x4iy7q0mj1rshlxr00hbc78g5hzijgzyqs36nrw6bn65fb93"))))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/ideasman42/emacs-idle-highlight-mode")
+ (synopsis "Highlights all occurrences of the word the point is on")
+ (description
+ "This Emacs package provides @code{idle-highlight-mode} that sets
an idle timer to highlight all occurrences in the buffer of the word under
the point.")
- (license license:gpl3+))))
+ (license license:gpl3+))))
(define-public emacs-ox-twbs
(package
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 03/12] gnu: Add emacs-nerd-icons.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
e2c2010e874654be4581b5cb367d0a7302a718a9.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d3c069609..5d481f50d7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9984,6 +9984,34 @@ (define-public emacs-purescript-mode
(description "This package provides an Emacs major mode for writing Purescript.")
(license license:gpl3+))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-nerd-icons
+ (let ((commit "a83d47f6dc4db0ae2f38c0c534de58f02285cea6")
+ (revision "0"))
+ (package
+ (name "emacs-nerd-icons")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rainstormstudio/nerd-icons.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l9657dg1c2bj25a7qnmshzmsmfl1m4mhx1x0b3v9k6r4gqp68qa"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:include #~(cons "^data\\/[^/]*\\.el$" %default-include)))
+ (home-page "https://github.com/rainstormstudio/nerd-icons.el")
+ (synopsis "Emacs Nerd Font icons library")
+ (description
+ "This package provides a library for easily using @code{Nerd Font}
+icons inside Emacs, an alternative to @code{all-the-icons}. It works on both
+GUI and terminal. You only need a @code{Nerd Font} installed on your system.")
+ (license license:gpl3+))))
+
(define-public emacs-new-purescript-mode
(let ((commit "9f7bb73e26340fcd2ea1946dbad165f0406eb3e1")
(revision "0"))
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 04/12] gnu: Add emacs-nerd-icons-completion.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
f537d6ff7bec97cf54204d4ca89cfed483385ab5.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons-completion): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5d481f50d7..98e5488f3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10012,6 +10012,33 @@ (define-public emacs-nerd-icons
GUI and terminal. You only need a @code{Nerd Font} installed on your system.")
(license license:gpl3+))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-nerd-icons-completion
+ (let ((commit "c2db8557a3c1a9588d111f8c8e91cae96ee85010")
+ (revision "0"))
+ (package
+ (name "emacs-nerd-icons-completion")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/rainstormstudio/nerd-icons-completion")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10ll0dj6ym5prrkv6smj0ac2ail4b3rqcrh1lyr61y3cj422vn9z"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons))
+ (home-page "https://github.com/rainstormstudio/nerd-icons-completion")
+ (synopsis "Add icons from nerd-icons to completion candidates")
+ (description
+ "This package adds icons from @code{nerd-icons} to the candidates in
+completion UIs (e.g. @code{vertico}) in Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-new-purescript-mode
(let ((commit "9f7bb73e26340fcd2ea1946dbad165f0406eb3e1")
(revision "0"))
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 05/12] gnu: Add emacs-nerd-icons-dired.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
0dd5dbb4a218ed9726d34a5b720a56dc2b66c004.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons-dired): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 98e5488f3d..a2dfe1d657 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10039,6 +10039,33 @@ (define-public emacs-nerd-icons-completion
completion UIs (e.g. @code{vertico}) in Emacs.")
(license license:gpl3+))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-nerd-icons-dired
+ (let ((commit "39c9ec722ab356fdf3eaa6ab39618b717e060efb")
+ (revision "0"))
+ (package
+ (name "emacs-nerd-icons-dired")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/rainstormstudio/nerd-icons-dired")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "117296wlh20wjbjhpgxz3bb1nxbzrs395ai7wlml3mg9wsfqb5cz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons))
+ (home-page "https://github.com/rainstormstudio/nerd-icons-dired")
+ (synopsis "Show icons from nerd-icons for each file in dired mode")
+ (description
+ "This package adds icons from @code{nerd-icons} to @code{dired}
+buffers in Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-new-purescript-mode
(let ((commit "9f7bb73e26340fcd2ea1946dbad165f0406eb3e1")
(revision "0"))
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 06/12] gnu: Add emacs-nerd-icons-ibuffer.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
93129c8ab3d8806f1c1f0186649a531cd5ace65d.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons-ibuffer): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a2dfe1d657..146a0f6cdb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10066,6 +10066,28 @@ (define-public emacs-nerd-icons-dired
buffers in Emacs.")
(license license:gpl3+))))
+(define-public emacs-nerd-icons-ibuffer
+ (package
+ (name "emacs-nerd-icons-ibuffer")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seagle0128/nerd-icons-ibuffer")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wj6kcgvh700maj9i5pmgzc48lbj0dbxx849a8w519m4anr7b23s"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons))
+ (home-page "https://github.com/seagle0128/nerd-icons-ibuffer")
+ (synopsis "Show icons from nerd-icons in ibuffer mode")
+ (description
+ "This package adds icons from @code{nerd-icons} to @code{ibuffer-mode}
+in Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-new-purescript-mode
(let ((commit "9f7bb73e26340fcd2ea1946dbad165f0406eb3e1")
(revision "0"))
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 10/12] gnu: emacs-base16-theme: Update to 3.1.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
f525100a99019453f44136bb0a6451651d0c74a4.1689948588.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-base16-theme): Update to 3.1.
[url, home-page]: Use new upstream URL.
---
gnu/packages/emacs-xyz.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6e0d0053b2..1126907f8b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11110,16 +11110,16 @@ (define-public emacs-4clojure
(define-public emacs-base16-theme
(package
(name "emacs-base16-theme")
- (version "3.0")
+ (version "3.1")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/belak/base16-emacs")
+ (url "https://github.com/tinted-theming/base16-emacs")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0qp71j77zg8gippcn277s0j5a9n6dbwv3kdp2nya6li4b412vgba"))))
+ (base32 "1yq9afvybrgkmn17h22ha9231am7hlh3wccxw7g2ks3g0k5vvds0"))))
(build-system emacs-build-system)
(arguments
(list #:include #~(cons "^build\\/.*\\.el$" %default-include)
@@ -11139,7 +11139,7 @@ (define-public emacs-base16-theme
'pre 'post)))
(find-files theme-dir "\\.el$"))
(delete-file-recursively theme-dir)))))))
- (home-page "https://github.com/belak/base16-emacs")
+ (home-page "https://github.com/tinted-theming/base16-emacs")
(synopsis "Base16 color themes for Emacs")
(description
"Base16 provides carefully chosen syntax highlighting and a default set
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 07/12] gnu: Add emacs-nerd-icons-ivy-rich.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
183edec7070008ec83f54638b02c4e0b29a0f65f.1689948587.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-nerd-icons-ivy-rich): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 146a0f6cdb..e31f9157ed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10088,6 +10088,28 @@ (define-public emacs-nerd-icons-ibuffer
in Emacs.")
(license license:gpl3+)))
+(define-public emacs-nerd-icons-ivy-rich
+ (package
+ (name "emacs-nerd-icons-ivy-rich")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seagle0128/nerd-icons-ivy-rich")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0psfjjqxrfkk7qaj44d20rrks31cik318vq2im5jff83bw1hgcbn"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons emacs-ivy-rich))
+ (home-page "https://github.com/seagle0128/nerd-icons-ivy-rich")
+ (synopsis "Use icons from nerd-icons for ivy-rich transformers")
+ (description
+ "This package enables Emacs to use icons from @code{nerd-icons} in
+@code{ivy-rich} transformers for @code{ivy}.")
+ (license license:gpl3+)))
+
(define-public emacs-new-purescript-mode
(let ((commit "9f7bb73e26340fcd2ea1946dbad165f0406eb3e1")
(revision "0"))
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 11/12] gnu: Add emacs-chocolate-theme.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
6359f33c1ca197f309c9c03cc46099f9e488056b.1689948588.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-chocolate-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1126907f8b..13fb414be0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4174,6 +4174,31 @@ (define-public emacs-caps-lock
Lock key.")
(license license:gpl3+)))
+(define-public emacs-chocolate-theme
+ (let ((commit "ccc05f7ad96d3d1332727689bf6250443adc7ec0")
+ (revision "0"))
+ (package
+ (name "emacs-chocolate-theme")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d8a9jwv9y0sncw24k840c8yyrig30f2d6q2zqlc09f05yzq9p9p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-autothemer))
+ (home-page "https://github.com/SavchenkoValeriy/emacs-chocolate-theme")
+ (synopsis "Dark chocolatey theme for Emacs")
+ (description
+ "Chocolate theme is a dark, chocolatey, vibrant and subtle theme for
+Emacs.")
+ (license license:gpl3))))
+
(define-public emacs-chronometrist
(package
(name "emacs-chronometrist")
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 08/12] gnu: Add emacs-treemacs-nerd-icons.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
51596fe7c3c209dcca65f383cf550a2e490d97c3.1689948588.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-treemacs-nerd-icons): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e31f9157ed..9cbfae7c86 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29599,6 +29599,33 @@ (define-public emacs-treemacs-extra
emacs-perspective
mu)))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-treemacs-nerd-icons
+ (let ((commit "8ddd94661ab9f3c9094dd4b5632bcdd57bdf871d")
+ (revision "0"))
+ (package
+ (name "emacs-treemacs-nerd-icons")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/rainstormstudio/treemacs-nerd-icons")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dlp1wqjapcn7d6s2c6c43fap2sw5kb1qbvm28jq22k1h8k77632"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nerd-icons emacs-treemacs))
+ (home-page "https://github.com/rainstormstudio/treemacs-nerd-icons")
+ (synopsis "Treemacs nerd-icons icon theme")
+ (description
+ "This package provides an icon theme for @code{treemacs} using
+@code{nerd-icons}.")
+ (license license:gpl3+))))
+
(define-public emacs-libyaml
;; Upstream made no release so far.
(let ((version "0.1")
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 12/12] gnu: Add emacs-dired-preview.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
c30bf53f55a448e732bc9eefbe7894d31b07e93d.1689948588.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-dired-preview): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13fb414be0..175452d49a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27168,6 +27168,30 @@ (define-public emacs-dired-du
buffer displays recursive dir sizes.")
(license license:gpl3+)))
+(define-public emacs-dired-preview
+ (package
+ (name "emacs-dired-preview")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/dired-preview")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d485812k1rv0qrw4xvzv4z3qf370apsajnf4q3pjk3q0r1fpm8b"))))
+ (build-system emacs-build-system)
+ (home-page "https://protesilaos.com/emacs/dired-preview")
+ (synopsis "Automatically preview file at point in Dired")
+ (description
+ "This is a simple package to automatically preview in a side window the
+file at point in Dired buffers. Preview windows are closed when they are no
+longer relevant, while preview buffers are killed if they have not been used
+for other purposes beside previewing. The package provides several
+customisation options to control its behaviour.")
+ (license license:gpl3+)))
+
(define-public emacs-dired-rsync
(package
(name "emacs-dired-rsync")
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH 09/12] gnu: Add emacs-rebecca-theme.
(address . 64771@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
c37e18059ca502f3cd0a26a8851bcebef83a0649.1689948588.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-rebecca-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9cbfae7c86..6e0d0053b2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3465,6 +3465,33 @@ (define-public emacs-read-only-cfg
directories or regex patterns.")
(license license:gpl3+))))
+;; Use latest commit since there are no tags anymore for several versions
+(define-public emacs-rebecca-theme
+ (let ((commit "4b8b5aae9099185e07c2b4cac4943c7f66a3f003")
+ (revision "0"))
+ (package
+ (name "emacs-rebecca-theme")
+ (version (git-version "1.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vic/rebecca-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y2kcs6zgi3dijagyz6lxbv6gi2mih8m943fhjrzkj35wfvjmhsz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/vic/rebecca-theme")
+ (synopsis "Dark Emacs theme with purple/violet colors")
+ (description
+ "Rebecca Emacs theme is a dark theme with purple/violet colors, based on
+the @code{Dracula} theme for Emacs and the @code{Gloom} theme for Atom.
+
+The author recommends @url{https://www.tumblr.com/liamwong, Liam Wong's}
+photos as background with this theme.")
+ (license license:expat))))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")
--
2.41.0
Liliana Marie Prikler wrote 2 years ago
Re: [bug#64771] [PATCH 03/12] gnu: Add emacs-nerd-icons.
(name . Andrew Tropin)(address . andrew@trop.in)
b8fe53046e6dc7f0f4923cf9e6a8e8208b82cf0f.camel@gmail.com
Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
Toggle quote (49 lines)
> * gnu/packages/emacs-xyz.scm (emacs-nerd-icons): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 8d3c069609..5d481f50d7 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -9984,6 +9984,34 @@ (define-public emacs-purescript-mode
>        (description "This package provides an Emacs major mode for
> writing Purescript.")
>        (license license:gpl3+))))
>  
> +;; Package has no releases or tags.  Version is extracted from
> "Version:"
> +;; keyword in main file.
> +(define-public emacs-nerd-icons
> +  (let ((commit "a83d47f6dc4db0ae2f38c0c534de58f02285cea6")
> +        (revision "0"))
> +    (package
> +      (name "emacs-nerd-icons")
> +      (version (git-version "0.0.1" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url
> "https://github.com/rainstormstudio/nerd-icons.el")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "0l9657dg1c2bj25a7qnmshzmsmfl1m4mhx1x0b3v9k6r4gqp68qa"))))
> +      (build-system emacs-build-system)
> +      (arguments
> +       (list #:include #~(cons "^data\\/[^/]*\\.el$" %default-
> include)))
> +      (home-page "https://github.com/rainstormstudio/nerd-icons.el")
> +      (synopsis "Emacs Nerd Font icons library")
> +      (description
> +       "This package provides a library for easily using @code{Nerd
> Font}
> +icons inside Emacs, an alternative to @code{all-the-icons}.  It
> works on both
> +GUI and terminal.  You only need a @code{Nerd Font} installed on
> your system.")
> +      (license license:gpl3+))))
> +
Since nerd font is a big nope on licensing terms, I don't think having
any related Emacs packages does us any good.

Cheers
Ahmad Draidi wrote 2 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87o7k4gqwh.fsf@redscript.org
Hello,
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
Toggle quote (59 lines)
> Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
>> * gnu/packages/emacs-xyz.scm (emacs-nerd-icons): New variable.
>> ---
>>  gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
>>  1 file changed, 28 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm
>> b/gnu/packages/emacs-xyz.scm
>> index 8d3c069609..5d481f50d7 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -9984,6 +9984,34 @@ (define-public emacs-purescript-mode
>>        (description "This package provides an Emacs major mode
>> for
>> writing Purescript.")
>>        (license license:gpl3+))))
>>  
>> +;; Package has no releases or tags.  Version is extracted from
>> "Version:"
>> +;; keyword in main file.
>> +(define-public emacs-nerd-icons
>> +  (let ((commit "a83d47f6dc4db0ae2f38c0c534de58f02285cea6")
>> +        (revision "0"))
>> +    (package
>> +      (name "emacs-nerd-icons")
>> +      (version (git-version "0.0.1" revision commit))
>> +      (source (origin
>> +                (method git-fetch)
>> +                (uri (git-reference
>> +                      (url
>> "https://github.com/rainstormstudio/nerd-icons.el")
>> +                      (commit commit)))
>> +                (file-name (git-file-name name version))
>> +                (sha256
>> +                 (base32
>> +                 
>> "0l9657dg1c2bj25a7qnmshzmsmfl1m4mhx1x0b3v9k6r4gqp68qa"))))
>> +      (build-system emacs-build-system)
>> +      (arguments
>> +       (list #:include #~(cons "^data\\/[^/]*\\.el$" %default-
>> include)))
>> +      (home-page
>> "https://github.com/rainstormstudio/nerd-icons.el")
>> +      (synopsis "Emacs Nerd Font icons library")
>> +      (description
>> +       "This package provides a library for easily using
>> @code{Nerd
>> Font}
>> +icons inside Emacs, an alternative to @code{all-the-icons}. 
>> It
>> works on both
>> +GUI and terminal.  You only need a @code{Nerd Font} installed
>> on
>> your system.")
>> +      (license license:gpl3+))))
>> +
> Since nerd font is a big nope on licensing terms, I don't think
> having
> any related Emacs packages does us any good.
These packages are mainly concerned with the "Symbols Nerd Font
Mono" font. I'll try to dig into that later. Feel free to drop the
'*nerd-icons*' patches. I'll send them separately if I get the
licenses thing sorted out.
Toggle quote (2 lines)
>
> Cheers
Thanks
Liliana Marie Prikler wrote 2 years ago
Re: [bug#64771] [PATCH 09/12] gnu: Add emacs-rebecca-theme.
(name . Andrew Tropin)(address . andrew@trop.in)
6deb4a2695e69438c9a12dcb16b880463db2c65f.camel@gmail.com
Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
Toggle quote (43 lines)
> * gnu/packages/emacs-xyz.scm (emacs-rebecca-theme): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 9cbfae7c86..6e0d0053b2 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -3465,6 +3465,33 @@ (define-public emacs-read-only-cfg
>  directories or regex patterns.")
>        (license license:gpl3+))))
>  
> +;; Use latest commit since there are no tags anymore for several
> versions
> +(define-public emacs-rebecca-theme
> +  (let ((commit "4b8b5aae9099185e07c2b4cac4943c7f66a3f003")
> +        (revision "0"))
> +    (package
> +      (name "emacs-rebecca-theme")
> +      (version (git-version "1.3.2" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/vic/rebecca-theme")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "0y2kcs6zgi3dijagyz6lxbv6gi2mih8m943fhjrzkj35wfvjmhsz"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://github.com/vic/rebecca-theme")
> +      (synopsis "Dark Emacs theme with purple/violet colors")
> +      (description
> +       "Rebecca Emacs theme is a dark theme with purple/violet
> colors, based on
> +the @code{Dracula} theme for Emacs and the @code{Gloom} theme for
> Atom.
> +
> +The author recommends @url{https://www.tumblr.com/liamwong, Liam
> Wong's}
> +photos as background with this theme.")
Removed the ad to some person's Tumblr. Pushed along with the rest of
the series.

Cheers
Closed
Ahmad Draidi wrote 2 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
878raxlv36.fsf@redscript.org
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (15 lines)
> Am Freitag, dem 21.07.2023 um 18:44 +0400 schrieb Ahmad Draidi:
>> +      (description
>> +       "Rebecca Emacs theme is a dark theme with purple/violet
>> colors, based on
>> +the @code{Dracula} theme for Emacs and the @code{Gloom} theme
>> for
>> Atom.
>> +
>> +The author recommends @url{https://www.tumblr.com/liamwong,
>> Liam
>> Wong's}
>> +photos as background with this theme.")
> Removed the ad to some person's Tumblr. Pushed along with the
> rest of
> the series.
Thanks for the merge. Just want to clarify the rationale behind
adding the wallpapers link (Tumblr). A theme is essentially
aesthetics, and the wallpapers are part of that, basically.
I trust your decision as a maintainer, of course.

For future packages, would it be acceptable to add something like
"Visit the theme's homepage for recommended wallpapers" or
something along those lines to highlight the recommendations
existence to the user?

Toggle quote (3 lines)
>
> Cheers

Thanks
Closed
Liliana Marie Prikler wrote 2 years ago
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
f36575bdd6a4417ed2cf846fa29d96b55ec53a17.camel@gmail.com
Hi Ahmad,

Am Sonntag, dem 30.07.2023 um 11:09 +0400 schrieb Ahmad Draidi:
Toggle quote (4 lines)
> Thanks for the merge. Just want to clarify the rationale behind
> adding the wallpapers link (Tumblr). A theme is essentially
> aesthetics, and the wallpapers are part of that, basically.
> I trust your decision as a maintainer, of course.
Aesthetics are highly subjective and while recommending wallpapers on
your own website is quite fine, doing so in the context of a free
software package manager (especially directing people to non-free
platforms) is a very different thing. I'm not even sure whether those
wallpapers would be CC licensed because Tumblr failed to load for me
when I checked, which for me is reason enough to drop the
recommendation.

Cheers
Closed
Ahmad Draidi wrote 2 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87leexo7f3.fsf@redscript.org
Thanks a lot for the explanation and your patience.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64771@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64771
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help