[PATCH 0/5] Update libcamera and pipewire

  • Done
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 21 Jul 2023 14:12
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
cover.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

Hello, this update libcamera and pipewire, and enable
libcamera support in pipewire to fix issue #64736.

Sou Bunnbu (???) (5):
gnu: libcamera: Update to 0.1.0.
gnu: libcamera: Split off gst and tools outputs.
gnu: pipewire: Update to 0.3.75.
gnu: pipewire: Enable libcamera support.
gnu: libcamera: Rewrite package argument to G-expression.

gnu/packages/linux.scm | 5 ++--
gnu/packages/networking.scm | 58 ++++++++++++++++++-------------------
2 files changed, 31 insertions(+), 32 deletions(-)


base-commit: 182be30fb1a8b847c30492462ec22c08ec7a9849
--
2.41.0
I
I
iyzsong wrote on 21 Jul 2023 14:14
[PATCH 1/5] gnu: libcamera: Update to 0.1.0.
(address . 64767@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
13e25362a5baf029573ab09c362b5c0a77c50230.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/networking.scm (libcamera): Update to 0.1.0.
[native-inputs]: Add googletest.
[arguments]: Add "-Dtest=true" to configure-flags. Remove
disable-failing-tests phase.
---
gnu/packages/networking.scm | 20 +++++++-------------
1 file changed, 7 insertions(+), 13 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 18d5c26ce0..52178785d3 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -350,37 +350,30 @@ (define-public lcsync
(define-public libcamera
(package
(name "libcamera")
- (version "0.0.0-1")
+ (version "0.1.0")
(source
(origin
(method git-fetch)
(uri
(git-reference
- (url "git://linuxtv.org/libcamera.git")
- (commit "10be87fa7c3bfb097b21ca3d469c67e40c333f7e")))
+ (url "https://git.libcamera.org/libcamera/libcamera.git")
+ (commit (string-append "v" version))))
(file-name
(git-file-name name version))
(sha256
- (base32 "0qgirhlalmk9f9v6piwz50dr2asb64rvbb9zb1vix7y9zh7m11by"))))
+ (base32 "06dj3dpfbayj61015n5kffin2g3hyys11ra0px2g4hmrznvdkhc9"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:configure-flags
(list
+ "-Dtest=true"
"-Dv4l2=true"
;; XXX: Requires bundled pybind11.
"-Dpycamera=disabled")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "test/meson.build"
- (("\\['list-cameras', 'list-cameras.cpp'\\],")
- "")
- ;; TODO: Why do the gstreamer tests fail.
- (("^subdir\\('gstreamer'\\)")
- ""))))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -390,7 +383,8 @@ (define-public libcamera
(string-append out "/share/doc")
(string-append doc "/share/doc"))))))))
(native-inputs
- (list graphviz ;for 'dot'
+ (list googletest
+ graphviz ;for 'dot'
doxygen
pkg-config
python-wrapper
--
2.41.0
I
I
iyzsong wrote on 21 Jul 2023 14:14
[PATCH 2/5] gnu: libcamera: Split off gst and tools outputs.
(address . 64767@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
e948ae55f873847d98debffbd76cf9684c5f8594.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/networking.scm (libcamera)[outputs]: Add gst and tools.
[arguments]: Pass "-Dbindir" to configure-flags. Adjust 'move-doc phase
to 'move-doc-and-gst.
---
gnu/packages/networking.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 52178785d3..84091274f0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -363,25 +363,31 @@ (define-public libcamera
(sha256
(base32 "06dj3dpfbayj61015n5kffin2g3hyys11ra0px2g4hmrznvdkhc9"))))
(build-system meson-build-system)
- (outputs '("out" "doc"))
+ (outputs '("out" "doc" "gst" "tools"))
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:configure-flags
(list
+ (string-append "-Dbindir=" (assoc-ref %outputs "tools") "/bin")
"-Dtest=true"
"-Dv4l2=true"
;; XXX: Requires bundled pybind11.
"-Dpycamera=disabled")
#:phases
(modify-phases %standard-phases
- (add-after 'install 'move-doc
+ (add-after 'install 'move-doc-and-gst
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
+ (doc (assoc-ref outputs "doc"))
+ (gst (assoc-ref outputs "gst")))
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/doc")
- (string-append doc "/share/doc"))))))))
+ (string-append doc "/share/doc"))
+ (mkdir-p (string-append gst "/lib"))
+ (rename-file
+ (string-append out "/lib/gstreamer-1.0")
+ (string-append gst "/lib/gstreamer-1.0"))))))))
(native-inputs
(list googletest
graphviz ;for 'dot'
--
2.41.0
I
I
iyzsong wrote on 21 Jul 2023 14:14
[PATCH 3/5] gnu: pipewire: Update to 0.3.75.
(address . 64767@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
a1be6acf0801b127d2935af3d2a0ff9e245e1352.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/linux.scm (pipewire): Update to 0.3.75.
---
gnu/packages/linux.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67128524ff..9821707754 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9287,7 +9287,7 @@ (define-public inputattach
(define-public pipewire
(package
(name "pipewire")
- (version "0.3.70")
+ (version "0.3.75")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -9296,7 +9296,7 @@ (define-public pipewire
(file-name (git-file-name name version))
(sha256
(base32
- "1n74rrbwymm89ri4daa4v092f4b81wrak4vg685xfz2wl89p64n6"))))
+ "0dmhsdvhlg6cav6cmxkm178j377yqbbz21lx0axgz2w935nxhans"))))
(build-system meson-build-system)
(arguments
(list
--
2.41.0
I
I
iyzsong wrote on 21 Jul 2023 14:14
[PATCH 4/5] gnu: pipewire: Enable libcamera support.
(address . 64767@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
8af70de3e5d6ef44ec1b03bb1191539b129dc58c.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>


* gnu/packages/linux.scm (pipewire)[inputs]: Add libcamera.
---
gnu/packages/linux.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9821707754..91b2bd3571 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9321,6 +9321,7 @@ (define-public pipewire
gstreamer
jack-2
ldacbt
+ libcamera
libfdk
libfreeaptx
libsndfile
--
2.41.0
I
I
iyzsong wrote on 21 Jul 2023 14:14
[PATCH 5/5] gnu: libcamera: Rewrite package argument to G-expression.
(address . 64767@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
5460f849b23668aa75f76c7794365abf56bc8c47.1689941427.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/networking.scm (libcamera)[arguments]: Use G-expression.
---
gnu/packages/networking.scm | 44 ++++++++++++++++++-------------------
1 file changed, 21 insertions(+), 23 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 84091274f0..ac11855ac8 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -365,29 +365,27 @@ (define-public libcamera
(build-system meson-build-system)
(outputs '("out" "doc" "gst" "tools"))
(arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- #:configure-flags
- (list
- (string-append "-Dbindir=" (assoc-ref %outputs "tools") "/bin")
- "-Dtest=true"
- "-Dv4l2=true"
- ;; XXX: Requires bundled pybind11.
- "-Dpycamera=disabled")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-doc-and-gst
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (gst (assoc-ref outputs "gst")))
- (mkdir-p (string-append doc "/share"))
- (rename-file
- (string-append out "/share/doc")
- (string-append doc "/share/doc"))
- (mkdir-p (string-append gst "/lib"))
- (rename-file
- (string-append out "/lib/gstreamer-1.0")
- (string-append gst "/lib/gstreamer-1.0"))))))))
+ (list #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ #~(list (string-append "-Dbindir="
+ (assoc-ref %outputs "tools") "/bin")
+ "-Dtest=true" "-Dv4l2=true"
+ ;; XXX: Requires bundled pybind11.
+ "-Dpycamera=disabled")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'move-doc-and-gst
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc"))
+ (gst (assoc-ref outputs "gst")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ (mkdir-p (string-append gst "/lib"))
+ (rename-file
+ (string-append out "/lib/gstreamer-1.0")
+ (string-append gst "/lib/gstreamer-1.0"))))))))
(native-inputs
(list googletest
graphviz ;for 'dot'
--
2.41.0
?
Re: bug#64767: [PATCH 0/5] Update libcamera and pipewire
(address . 64767-done@debbugs.gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
87pm3r8j13.fsf@envs.net
iyzsong@envs.net writes:

Toggle quote (7 lines)
> gnu: libcamera: Update to 0.1.0.
> gnu: libcamera: Split off gst and tools outputs.
> gnu: pipewire: Update to 0.3.75.
> gnu: pipewire: Enable libcamera support.
> gnu: libcamera: Rewrite package argument to G-expression.
>

Pushed to master, with pipewire update to 0.3.77.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64767@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64767
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch