[PATCH] gnu: odamex: Update to 10.3.0.

  • Open
  • quality assurance status badge
Details
3 participants
  • David Pflug
  • 宋文武
  • Christopher Baines
Owner
unassigned
Submitted by
David Pflug
Severity
normal
D
D
David Pflug wrote on 21 Jul 02:41 +0200
(address . guix-patches@gnu.org)
CAB3eSakD5p+Gr5bBmr_--bu3Qh=Pfx4th24MAFKzJBKnYejLLg@mail.gmail.com
* gnu/packages/games.scm (odamex): Update to 10.3.0
---
gnu/packages/games.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ec084553da..6a34693a0c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,7 +60,7 @@
;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021, 2023 David Pflug <david@pflug.io>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
@@ -7879,19 +7879,20 @@ (define-public gzdoom
(define-public odamex
(package
(name "odamex")
- (version "0.9.5")
+ (version "10.3.0")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://sourceforge/odamex/Odamex/" version "/"
- "odamex-src-" version ".tar.bz2"))
+ "odamex-src-" version ".tar.zstd"))
(sha256
- (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
+ (base32 "1wws74hrc816raj9wbwmhi7q1arzjv0fxssdgbyppy0zh7zg5abh"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; no tests
(native-inputs
- (list deutex))
+ (list deutex
+ zstd))
(inputs
`(("sdl" ,sdl2)
("sdl-mixer" ,sdl2-mixer)
--
2.41.0
D
D
David Pflug wrote on 12 Aug 13:35 +0200
[PATCH v2] gnu: odamex: Update to 10.4.0.
(address . 64761@debbugs.gnu.org)(name . David Pflug)(address . david@pflug.io)
20230812113604.3268-1-david@pflug.io
* gnu/packages/games.scm (odamex): Update to 10.4.0.
---
gnu/packages/games.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bf5c680042..8c086d6a39 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,7 +60,7 @@
;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021, 2023 David Pflug <david@pflug.io>
;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
@@ -7878,15 +7878,15 @@ (define-public gzdoom
(define-public odamex
(package
(name "odamex")
- (version "0.9.5")
+ (version "10.4.0")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://sourceforge/odamex/Odamex/" version "/"
- "odamex-src-" version ".tar.bz2"))
+ "odamex-src-" version ".tar.gz"))
(sha256
- (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
+ (base32 "1i5dz96dfjqnm6fh5ri77phln4l6l3d03wy7gyr717p35hs4yj1m"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; no tests
(native-inputs

base-commit: a38ebae09cd7cbaeaafdaaf9a1cef73752a891c8
--
2.41.0
宋文武 wrote on 13 Aug 08:55 +0200
Re: bug#64761: [PATCH] gnu: odamex: Update to 10.3.0.
(name . David Pflug)(address . david@pflug.io)(address . 64761@debbugs.gnu.org)
87leefa0t0.fsf_-_@envs.net
David Pflug <david@pflug.io> writes:

Toggle quote (2 lines)
> * gnu/packages/games.scm (odamex): Update to 10.4.0.

Hello, it seems to me that this package built with bundled fltk,
jsoncpp, protobuf and miniupnp. Any chance to unbundle them?

Thanks.
D
D
David Pflug wrote on 13 Aug 15:17 +0200
(name . 宋文武)(address . iyzsong@envs.net)(address . 64761@debbugs.gnu.org)
CAB3eSamjqJKdvFmVkWhAQgYObfU_g+PTTKwM7TBZKJ71FCOa7w@mail.gmail.com
I'll see what I can do when I get some time.

On Sun, Aug 13, 2023, 2:55 AM 宋文武 <iyzsong@envs.net> wrote:

Toggle quote (9 lines)
> David Pflug <david@pflug.io> writes:
>
> > * gnu/packages/games.scm (odamex): Update to 10.4.0.
>
> Hello, it seems to me that this package built with bundled fltk,
> jsoncpp, protobuf and miniupnp. Any chance to unbundle them?
>
> Thanks.
>
Attachment: file
C
C
Christopher Baines wrote on 27 Aug 19:53 +0200
tag 64761 moreinfo
(address . control@debbugs.gnu.org)
87bkes8j8e.fsf@cbaines.net
tags 64761 + moreinfo
quit
?