Recursive hackage import fails

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • Saku Laesvuori
Owner
unassigned
Submitted by
Saku Laesvuori
Severity
normal
S
S
Saku Laesvuori wrote on 19 Jul 2023 22:12
(address . bug-guix@gnu.org)
20230719201203.kg55b7mao4iwwy4o@X-kone
Importing hackage packages recursively fails with similar error to this:

```
$ guix import hackage linear-generics --recursive
Backtrace:
11 (primitive-load "/home/saku/.config/guix/current/bin/gu…")
In guix/ui.scm:
2309:7 10 (run-guix . _)
2272:10 9 (run-guix-command _ . _)
In guix/scripts/import.scm:
90:11 8 (guix-import . _)
In guix/scripts/import/hackage.scm:
129:26 7 (guix-import-hackage . _)
In guix/import/utils.scm:
651:3 6 (recursive-import _ #:repo->guix-package _ #:guix-name . #)
613:31 5 (topological-sort _ #<procedure 7f8f515f4720 at guix/i…> …)
655:29 4 (_ _)
In unknown file:
3 (remove #<procedure 7f8f51610ce0 at guix/import/utils.…> …)
In guix/import/utils.scm:
635:39 2 (exists? #<<upstream-input> name: "th-abstraction" dow…> …)
In guix/import/hackage.scm:
128:6 1 (hackage-name->package-name #<<upstream-input> name: "t…>)
In unknown file:
0 (string-prefix? "ghc-" #<<upstream-input> name: "th-ab…> …)

ERROR: In procedure string-prefix?:
In procedure string-prefix?: Wrong type argument in position 2 (expecting string): #<<upstream-input> name: "th-abstraction" downstream-name: "ghc-th-abstraction" type: regular min-version: any max-version: any>

```

I tried to find out what passes the `upstream-input` to
`hackage-name->package-name`, but only found out with `pk` that it seems
to only happen with the recursed dependencies and not with the root
package. I also tried to make `hackage-name->package-name` accept
`upstream-input` records but that a new error, so I assume the issue is
that something in the importer is returning `upstream-input` records
when it should return package names.

I could try to debug this further but I don't feel like I know enough
about debugging with guile nor about debugging scheme.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmS4Q5MACgkQJX0oSiod
OjKIgQ//Xaa8ejoZ9I2nkDs0/0I4/3U4yCWTxoNxsKGoZCC2e4DqmUriJiBPexvf
tE0vfcwEnoW1uZjcB+0/f9ZSwnfX6TEhs7Z1iHyuOw5ccpawMHJnQApHQ5rNFbzX
fqa5Ihu8UwNewFiHWbOFwJCOsNX3jCE79jZG7jyYlanCT9qaLhh8/3MVsr1jOL7Q
Kt2Eh5cfgGGGtOEmUeW2qj28UPFoUcABJNtdUfEd6/45HL31VOxJCL6i2RUOhjAP
cBgr0ypYlatrzFxNEbLBlx+TNYnhwTCavh/3p/a3lWkoEUOykGsQim/pQtJWc6KR
RmLchV6NY/xrggScvLtHNHhNXiSS52t9mqTtuDDYRGEy7mjeCz8tMm9ZBYRygvPM
slhCzgeUD4n48+XG/3dj/KrVUbIcV78Xo2xd0vc2A5hpmRn1gntg4A5e3ORtx+aX
9yKQHmDGeBLCy4ZKe/Ct58zQps4nIzVxEAiMUMWwYTi0UsfMNZfOniunca28Rjr9
hubixCX28O1lJE3+SqGm2eW0Uhy4o+dAQETbp74MDQDhzHyOxUDxwkFiKB0sIAFD
Op7JaNfNc0flHmAhXsjYE2zNRb9ozsPbIWK8V7wPLTPBT6YqGyDKwuE/Dz5b2Jih
Vy70lbbMmWPN+k8/iZUJUdSHrgSLzk5yYDM/q98RBLRxg3Z25y4=
=22ce
-----END PGP SIGNATURE-----


L
L
Lars-Dominik Braun wrote on 25 May 09:38 +0200
(name . Saku Laesvuori)(address . saku@laesvuori.fi)(address . 64734@debbugs.gnu.org)
ZlGViZzDwfzdnaO5@noor.fritz.box
Hi,

Toggle quote (2 lines)
> $ guix import hackage linear-generics --recursive

have you ever figured out what caused this? I cannot reproduce it
currently – probably because ghc-th-abstraction is part of Guix already
and no recursion actually happens.

Lars
S
S
Saku Laesvuori wrote on 27 May 08:12 +0200
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 64734@debbugs.gnu.org)
kmwjbqvaudyc754ecrnqvdrjb3tnsgt3wlpxahjnz5lb3wjjbj@nfjuek7gpmdm
Toggle quote (6 lines)
> Hi,
>
> > $ guix import hackage linear-generics --recursive
>
> have you ever figured out what caused this?

Yes, I fixed it in https://issues.guix.gnu.org/67564so this issue can
now be closed.

- Saku
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmZUJF0ACgkQJX0oSiod
OjIbJg//dlnwnPhajeaaBbRRGcgPckLnGBTkzDeauRLTFhj90YIQSG1LseQWR/Ax
pUfQD3MP4OX+0riyCh/pr+mQl1zUHqoGJtgfEdKp0yLim5Hg2ca9Nv6DBJHdA+um
RUX7bg9dAFOfRvFRVO2VvCdWnfiAg/cQpGQfrm1BTlNvXH4rx5qf5GBaXs8tn0ut
qLraLEbJvDF0MbsMvZObJUqC9DLBDZw1Q2Lp5jN8cokF4Y9ydKPWKDqPlCDsLJfa
x+u+1khh6Go8pNAdnOPULJkVzudJAp6FizepxYz5t7tzxy8+d/2B5XfV267HewJt
7u1QEX5viU1On9JEhYblyvf5HH4KudKTjBiVPEfsO+NSzMYN/jCBycGZ26ezJQrr
omBnjGKyyqSgbbHNYl9M9QmKnD7rx6MUidr4I4WK6slu2luAfVUojRy/COTMbvQA
red2CzKmUIDLaNu0NTGISCTn+HhRblS7tzUK+J3iKQVY/yp+xWumSDCjkXX0XewJ
mmMaeZuPFuwu/UIu/4C8tarMY+qgp+A2aOmffqM7eeNiQ5XxyW1HoiPExhorwUdz
lCqqpOp85SDcrkb1JW+M6wGh7JyIs2WZHgqVNwlpEK8CN8iJ50J6XX2jZfkwieoP
qvMDaMAgWOCHcS22966Ji1Qyx5dUTPukzKdLFZHy8tNKzusDCgE=
=vund
-----END PGP SIGNATURE-----


S
S
Saku Laesvuori wrote on 27 May 08:16 +0200
(address . control@debbugs.gnu.org)
bjq7hl4sxhcjexyra7smtxcbn4ly4pltvlvpqbvmmscoj5ezgc@noe3i2abk4kd
close 64734
thanks
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmZUJUQACgkQJX0oSiod
OjKGQw/+L3AEbag+z7hYxrXXauVFmE7hZimf5QhzZcGSzgJDkD248HIokrFTdYYa
ebdYerVLxeLmjinbtECO7SLtDexevIcxaFNlmZsT4cASHW4LnP7Y5wTSIXBt+yjS
tTVN9hiSq2xqORa6zVVVmDRRn9f7WgckcSVA/Jaglmt7stL7BBo6bHU/1ZQDZoE9
h8cLxvEWGe+muKkYq3wkv8vA9Yni27B0HWm6XPzoo2NZYmavboqjqXujUxK6TSxo
F5Dxa7jIk/w5ll79IBVsOB+oXiU+l94RUNUUG3FXPQz1SxBD1FHADgDiHFcd2jrA
ayAaWJBWV5D8KgXSLt1Zfs/0jisFAB9WiBlYXGH+ir/TJRAPLLH5KOG0GlqJhiKM
aU3roj5ax0vL8FLg3lKj0f4o97UuKcRHG3A6TsmJXZu+BTS8XzYpCkG0SFpv/82v
OFx2QcI51WpxXo0DinzcnJiPJt6zx2bgNRsnmaW2AJPnBuWPRXDCAbzKD+BeJfka
8YDiABAqWgiK+w5+zCdB6LKnXS68tjSaUvzN7S1+MbabyeKJZ+k1Ww576wsmiisG
SpzUkWGdgMC0Z2bbLXnn5LXoRgKZo94NZBLbTM5TQuFY+SjpeGjhexMNyYOaPMHU
CZf6AxInGWdR0xTSeyg6s3S0JhQrP4VP1rtT2Q8Q14ATZvRL7qU=
=5IOL
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 64734@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64734
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch