Recursive hackage import fails

  • Open
  • quality assurance status badge
Details
One participant
  • Saku Laesvuori
Owner
unassigned
Submitted by
Saku Laesvuori
Severity
normal
S
S
Saku Laesvuori wrote on 19 Jul 2023 22:12
(address . bug-guix@gnu.org)
20230719201203.kg55b7mao4iwwy4o@X-kone
Importing hackage packages recursively fails with similar error to this:

```
$ guix import hackage linear-generics --recursive
Backtrace:
11 (primitive-load "/home/saku/.config/guix/current/bin/gu…")
In guix/ui.scm:
2309:7 10 (run-guix . _)
2272:10 9 (run-guix-command _ . _)
In guix/scripts/import.scm:
90:11 8 (guix-import . _)
In guix/scripts/import/hackage.scm:
129:26 7 (guix-import-hackage . _)
In guix/import/utils.scm:
651:3 6 (recursive-import _ #:repo->guix-package _ #:guix-name . #)
613:31 5 (topological-sort _ #<procedure 7f8f515f4720 at guix/i…> …)
655:29 4 (_ _)
In unknown file:
3 (remove #<procedure 7f8f51610ce0 at guix/import/utils.…> …)
In guix/import/utils.scm:
635:39 2 (exists? #<<upstream-input> name: "th-abstraction" dow…> …)
In guix/import/hackage.scm:
128:6 1 (hackage-name->package-name #<<upstream-input> name: "t…>)
In unknown file:
0 (string-prefix? "ghc-" #<<upstream-input> name: "th-ab…> …)

ERROR: In procedure string-prefix?:
In procedure string-prefix?: Wrong type argument in position 2 (expecting string): #<<upstream-input> name: "th-abstraction" downstream-name: "ghc-th-abstraction" type: regular min-version: any max-version: any>

```

I tried to find out what passes the `upstream-input` to
`hackage-name->package-name`, but only found out with `pk` that it seems
to only happen with the recursed dependencies and not with the root
package. I also tried to make `hackage-name->package-name` accept
`upstream-input` records but that a new error, so I assume the issue is
that something in the importer is returning `upstream-input` records
when it should return package names.

I could try to debug this further but I don't feel like I know enough
about debugging with guile nor about debugging scheme.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoMkZR3NPB29fCOn/JX0oSiodOjIFAmS4Q5MACgkQJX0oSiod
OjKIgQ//Xaa8ejoZ9I2nkDs0/0I4/3U4yCWTxoNxsKGoZCC2e4DqmUriJiBPexvf
tE0vfcwEnoW1uZjcB+0/f9ZSwnfX6TEhs7Z1iHyuOw5ccpawMHJnQApHQ5rNFbzX
fqa5Ihu8UwNewFiHWbOFwJCOsNX3jCE79jZG7jyYlanCT9qaLhh8/3MVsr1jOL7Q
Kt2Eh5cfgGGGtOEmUeW2qj28UPFoUcABJNtdUfEd6/45HL31VOxJCL6i2RUOhjAP
cBgr0ypYlatrzFxNEbLBlx+TNYnhwTCavh/3p/a3lWkoEUOykGsQim/pQtJWc6KR
RmLchV6NY/xrggScvLtHNHhNXiSS52t9mqTtuDDYRGEy7mjeCz8tMm9ZBYRygvPM
slhCzgeUD4n48+XG/3dj/KrVUbIcV78Xo2xd0vc2A5hpmRn1gntg4A5e3ORtx+aX
9yKQHmDGeBLCy4ZKe/Ct58zQps4nIzVxEAiMUMWwYTi0UsfMNZfOniunca28Rjr9
hubixCX28O1lJE3+SqGm2eW0Uhy4o+dAQETbp74MDQDhzHyOxUDxwkFiKB0sIAFD
Op7JaNfNc0flHmAhXsjYE2zNRb9ozsPbIWK8V7wPLTPBT6YqGyDKwuE/Dz5b2Jih
Vy70lbbMmWPN+k8/iZUJUdSHrgSLzk5yYDM/q98RBLRxg3Z25y4=
=22ce
-----END PGP SIGNATURE-----


?