[PATCH] gnu: spdlog: Update to 1.12.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 18 Jul 2023 19:46
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
20230718174621.8030-1-code@greghogan.com
* gnu/packages/logging.scm (spdlog): Update to 1.12.0.
[native-inputs]: Add catch2-3.3.
---
gnu/packages/logging.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 61b3d6ccc5..abeb3fdd5c 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -37,6 +37,7 @@ (define-module (gnu packages logging)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
#:use-module (gnu packages c)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -212,7 +213,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
- (version "1.11.0")
+ (version "1.12.0")
(source
(origin
(method git-fetch)
@@ -221,7 +222,7 @@ (define-public spdlog
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
+ (base32 "0yyncv6wjs5rqm76rkqyxpfbsingk1dq5zfcqhy1a7fpw8xdl53k"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle
@@ -230,6 +231,7 @@ (define-public spdlog
(list "-DSPDLOG_BUILD_BENCH=OFF"
"-DSPDLOG_BUILD_SHARED=ON"
"-DSPDLOG_BUILD_TESTS=ON")))
+ (native-inputs (list catch2-3.3))
(home-page "https://github.com/gabime/spdlog")
(synopsis "Fast C++ logging library")
(description "Spdlog is a very fast header-only/compiled C++ logging
--
2.41.0
L
L
Ludovic Courtès wrote on 17 Sep 2023 15:09
(name . Greg Hogan)(address . code@greghogan.com)(address . 64715-done@debbugs.gnu.org)
87r0mxx7xu.fsf@gnu.org
Greg Hogan <code@greghogan.com> skribis:

Toggle quote (3 lines)
> * gnu/packages/logging.scm (spdlog): Update to 1.12.0.
> [native-inputs]: Add catch2-3.3.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64715@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64715
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch