[PATCH 0/3] fix quickjs building on riscv64-linux, use gexp, honor #:tests? flags .

  • Done
  • quality assurance status badge
Details
2 participants
  • Zheng Junjie
  • ???
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 17 Jul 2023 06:07
(address . guix-patches@gnu.org)
tencent_E19468D49E6D7EA50667C5FD4DEB0494BB0A@qq.com
*** BLURB HERE ***

Zheng Junjie (3):
gnu: quickjs: Fix building on riscv64-linux.
gnu: quickjs: Use G-expressions.
gnu: quickjs: Honor the #:tests? flag.

gnu/packages/javascript.scm | 20 +++++++++++---------
1 file changed, 11 insertions(+), 9 deletions(-)


base-commit: 3755941f038ec66fba568fa88d6b2d295e196723
--
2.41.0
Z
Z
Zheng Junjie wrote on 17 Jul 2023 06:10
[PATCH 1/3] gnu: quickjs: Fix building on riscv64-linux.
(address . 64673@debbugs.gnu.org)
tencent_3E7945C94C2DC3E65CAA6D96DBDF918E4306@qq.com
* gnu/packages/javascript.scm (quickjs)[arguments]: Adjust
make-flags when building for riscv64-linux to link with '-latomic'.
---
gnu/packages/javascript.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index e70aa7d7e1..ca467bee65 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Frank Pursel <frank.pursel@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -822,7 +823,8 @@ (define-public quickjs
(arguments
`(#:make-flags
(list "prefix="
- (string-append "DESTDIR=" %output))
+ (string-append "DESTDIR=" %output)
+ ,@(if (target-riscv64?) '("LDFLAGS=-latomic") '()))
#:phases
(modify-phases %standard-phases
(delete 'configure)
--
2.41.0
Z
Z
Zheng Junjie wrote on 17 Jul 2023 06:10
[PATCH 2/3] gnu: quickjs: Use G-expressions.
(address . 64673@debbugs.gnu.org)
tencent_AFDCA4A4ABF663D324F5306BE04F55E7B405@qq.com
* gnu/packages/javascript.scm (quickjs)[arguments]:
Rewrite as G-expressions.
---
gnu/packages/javascript.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index ca467bee65..b9ee5a93b3 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -821,16 +821,15 @@ (define-public quickjs
"06pywwpmfwjz225h59wf90q96a2fd66qfcw5xa6m6y9k9k7glnx4"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (list "prefix="
- (string-append "DESTDIR=" %output)
- ,@(if (target-riscv64?) '("LDFLAGS=-latomic") '()))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda _
- (invoke "make" "microbench"))))))
+ (list #:make-flags
+ #~(list "prefix="
+ (string-append "DESTDIR=" #$output)
+ #$@(if (target-riscv64?) '("LDFLAGS=-latomic") '()))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda _
+ (invoke "make" "microbench"))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
(description "QuickJS supports the ES2020 specification including modules,
--
2.41.0
Z
Z
Zheng Junjie wrote on 17 Jul 2023 06:10
[PATCH 3/3] gnu: quickjs: Honor the #:tests? flag.
(address . 64673@debbugs.gnu.org)
tencent_FD05E53E258FB56A9B8BA95859DD7FC73A08@qq.com
* gnu/packages/javascript.scm (quickjs)[arguments]: Adjust custom
'check phase to honor the #:tests? flag.
---
gnu/packages/javascript.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index b9ee5a93b3..1c37f73d75 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -828,8 +828,9 @@ (define-public quickjs
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'check
- (lambda _
- (invoke "make" "microbench"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "microbench")))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
(description "QuickJS supports the ES2020 specification including modules,
--
2.41.0
?
Re: [bug#64673] [PATCH 0/3] fix quickjs building on riscv64-linux, use gexp, honor #:tests? flags .
(name . Zheng Junjie)(address . 873216071@qq.com)(address . 64673-done@debbugs.gnu.org)
87h6h2jwub.fsf@envs.net
Zheng Junjie <873216071@qq.com> writes:

Toggle quote (13 lines)
> *** BLURB HERE ***
>
> Zheng Junjie (3):
> gnu: quickjs: Fix building on riscv64-linux.
> gnu: quickjs: Use G-expressions.
> gnu: quickjs: Honor the #:tests? flag.
>
> gnu/packages/javascript.scm | 20 +++++++++++---------
> 1 file changed, 11 insertions(+), 9 deletions(-)
>
>
> base-commit: 3755941f038ec66fba568fa88d6b2d295e196723

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64673@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64673
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch