[PATCH] gnu: Add emacs-consult-flycheck.

  • Done
  • quality assurance status badge
Details
One participant
  • Ahmad Draidi
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
926e2a0d9f8ba01e3e280bb7ba8d04340170aafe.1689491798.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-consult-flycheck): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..2d49e8f298 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11310,6 +11310,31 @@ (define-public emacs-consult-eglot
call.")
(license license:gpl3+)))
+(define-public emacs-consult-flycheck
+ ;; This particular commit introduces bug fixes above latest release.
+ (let ((commit "3f2a7c17cc2fe64e0c07e3bf90e33c885c0d7062")
+ (revision "0"))
+ (package
+ (name "emacs-consult-flycheck")
+ (version (git-version "0.9" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/consult-flycheck")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cvxl6ynbns3wlpzilhg4ldakb91ikpibbr9wpb2wkzbgi5c766c"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult emacs-flycheck))
+ (home-page "https://github.com/minad/consult-flycheck")
+ (synopsis "Consult integration for Flycheck")
+ (description
+ "This package provides the @code{consult-flycheck} command for Emacs,
+ which integrates @code{Consult} with @code{Flycheck}.")
+ (license license:gpl3+))))
+
(define-public emacs-eglot-tempel
(let ((commit "e08b203d6a7c495d4b91ed4537506b5f1ea8a84f")
(revision "0"))

base-commit: d08bd19de0b06d5da7f2c06fb733e245b566dd54
--
2.41.0
Ahmad Draidi wrote 2 years ago
merged
(address . control@debbugs.gnu.org)
87cz0aklse.fsf@redscript.org
close 64661
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64661@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64661
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help