[PATCH] gnu: Add emacs-mu4e-dashboard.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ahmad Draidi
  • A
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
1bedba277c7928d314064110627f5beb32f72069.1689487826.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..39e16da4cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
maps the thread tree.")
(license license:gpl3+))))
+;; Package has no releases or tags. Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-mu4e-dashboard
+ (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
+ (revision "0"))
+ (package
+ (name "emacs-mu4e-dashboard")
+ (version (git-version "0.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/rougier/mu4e-dashboard")
+ (commit commit)))
+ (sha256
+ (base32
+ "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list mu))
+ (home-page "https://github.com/rougier/mu4e-dashboard")
+ (synopsis "Build your own dashboard for mu4e using org-mode")
+ (description
+ "This package provides an @code{org-mode} link type that allows
+execution of various @code{mu4e} queries when clicked. Such links can be
+organized into a dashboard, by simply writing an org file.")
+ (license license:gpl3+))))
+
(define-public emacs-pinentry
(let ((commit "dcc9ba03252ee5d39e03bba31b420e0708c3ba0c")
(revision "1"))

base-commit: d08bd19de0b06d5da7f2c06fb733e245b566dd54
--
2.41.0
Liliana Marie Prikler wrote 2 years ago
(name . Andrew Tropin)(address . andrew@trop.in)
169e28d5e650335a531061c6c0fd19f63a4ae61e.camel@gmail.com
Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
Toggle quote (33 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 480096fb50..39e16da4cc 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
>  maps the thread tree.")
>        (license license:gpl3+))))
>  
> +;; Package has no releases or tags.  Version is extracted from
> "Version:"
> +;; keyword in main file.
> +(define-public emacs-mu4e-dashboard
> +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
> +        (revision "0"))
> +    (package
> +      (name "emacs-mu4e-dashboard")
> +      (version (git-version "0.1.1" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (file-name (git-file-name name version))
> +                (uri (git-reference
> +                      (url
> "https://github.com/rougier/mu4e-dashboard")
> +                      (commit commit)))
> +                (sha256
> +                 (base32
> +                 
> "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
Please put the file-name below the uri next time. Also, I see you
submitting quite a number of patches for emacs packages; if possible,
try to make topical series so that they can be reviewed in one go.

Cheers
Liliana Marie Prikler wrote 2 years ago
(name . Andrew Tropin)(address . andrew@trop.in)
647d0bf96c571d4decc0f127cfd2a8f0cbfe9fc1.camel@gmail.com
Am Sonntag, dem 16.07.2023 um 12:56 +0400 schrieb A:
Toggle quote (48 lines)
> Hello,
>
> On 7/16/23 11:37, Liliana Marie Prikler wrote:
> > Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
> > > * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New
> > > variable.
> > > ---
> > >   gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
> > >   1 file changed, 27 insertions(+)
> > >
> > > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > > xyz.scm
> > > index 480096fb50..39e16da4cc 100644
> > > --- a/gnu/packages/emacs-xyz.scm
> > > +++ b/gnu/packages/emacs-xyz.scm
> > > @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
> > >   maps the thread tree.")
> > >         (license license:gpl3+))))
> > >  
> > > +;; Package has no releases or tags.  Version is extracted from
> > > "Version:"
> > > +;; keyword in main file.
> > > +(define-public emacs-mu4e-dashboard
> > > +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
> > > +        (revision "0"))
> > > +    (package
> > > +      (name "emacs-mu4e-dashboard")
> > > +      (version (git-version "0.1.1" revision commit))
> > > +      (source (origin
> > > +                (method git-fetch)
> > > +                (file-name (git-file-name name version))
> > > +                (uri (git-reference
> > > +                      (url
> > > "https://github.com/rougier/mu4e-dashboard")
> > > +                      (commit commit)))
> > > +                (sha256
> > > +                 (base32
> > > +
> > > "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
> > Please put the file-name below the uri next time.  Also, I see you
> > submitting quite a number of patches for emacs packages; if
> > possible,
> > try to make topical series so that they can be reviewed in one go.
>
> Noted.
>
> Should I resend this and a couple of other patches I submitted with
> the file-name position change?
I already fixed them locally, they should go live next Sunday.

Cheers
A wrote 2 years ago
(name . Andrew Tropin)(address . andrew@trop.in)
7dac15b9-aad3-3175-bffe-e0a3dce4d392@redscript.org
Hello,

On 7/16/23 11:37, Liliana Marie Prikler wrote:
Toggle quote (38 lines)
> Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
>> * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
>> ---
>>  gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
>>  1 file changed, 27 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 480096fb50..39e16da4cc 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
>>  maps the thread tree.")
>>        (license license:gpl3+))))
>>
>> +;; Package has no releases or tags.  Version is extracted from
>> "Version:"
>> +;; keyword in main file.
>> +(define-public emacs-mu4e-dashboard
>> +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
>> +        (revision "0"))
>> +    (package
>> +      (name "emacs-mu4e-dashboard")
>> +      (version (git-version "0.1.1" revision commit))
>> +      (source (origin
>> +                (method git-fetch)
>> +                (file-name (git-file-name name version))
>> +                (uri (git-reference
>> +                      (url
>> "https://github.com/rougier/mu4e-dashboard")
>> +                      (commit commit)))
>> +                (sha256
>> +                 (base32
>> +
>> "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
> Please put the file-name below the uri next time. Also, I see you
> submitting quite a number of patches for emacs packages; if possible,
> try to make topical series so that they can be reviewed in one go.

Noted.

Should I resend this and a couple of other patches I submitted with the
file-name position change?

Toggle quote (2 lines)
>
> Cheers
Liliana Marie Prikler wrote 2 years ago
Re: Processed: Your Emacs patches
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
a78ebab99dd7530ec864529c9119a9866e28c023.camel@gmail.com
Am Sonntag, dem 23.07.2023 um 04:01 -0400 schrieb GNU bug tracker automated control server:
Toggle quote (1 lines)
> bug marked as fixed in version 64560 ...
Welp, that didn't work as expected
close 64560 
close 64582
close 64585
close 64614
close 64624
close 64626
close 64627
close 64628
close 64657
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64657@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64657
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help