(address . guix-patches@gnu.org)(name . Wojtek Kosior)(address . koszko@koszko.org)
* gnu/packages/matrix.scm (pantalaimon)[arguments]: Patch incorrect function
invokation that made downloads of attachments impossible
---
gnu/packages/matrix.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (23 lines)
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 6107dfc979..60c5543e5f 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -259,6 +259,14 @@ (define-public pantalaimon
;; Upgrading python-appdirs requires rebuilting 3000+ packages,
;; when 1.4.4 is a simple maintenance fix from 1.4.3.
(("appdirs >= 1.4.4") "appdirs >= 1.4.3"))))
+ (add-after 'downgrade-appdirs-requirement 'bugfixes
+ (lambda _
+ (substitute* "pantalaimon/daemon.py"
+ ;; FIXME: Remove this once a pantalaimon version with this fix
+ ;; is officially released.
+ ;; https://github.com/matrix-org/pantalaimon/pull/152/commits/d71770ca94981afde8c9be6aaaca951f0685b64e
+ (("client.download\\(server_name, media_id, file_name\\)")
+ "client.download(server_name=server_name, media_id=media_id, filename=file_name)"))))
(add-after 'install 'install-doc
(lambda _
(with-directory-excursion "docs/man"
base-commit: 00ed2901f5171e4f9435641a91678217cae38030
--
2.41.0