[PATCH] gnu: ghc-8.10: Fix build on i686-linux.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars-Dominik Braun
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
083e20c72d24a3ed0bc00959ae2053784b03bada.1689413970.git.mail@cbaines.net
As one profiling test fails very repeatedly on the bordeaux build farm, but
ghc did seem to build successfully on other machines.

* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Don't run the T11627a
profiling test on i686-linux.
---
gnu/packages/haskell.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b2c86fec4..62815efbb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1271,8 +1271,11 @@ (define-public ghc-8.10
;; next rebuild. Note that they are required for GHC 8.10 and 9.2.
#$@(if (string-prefix? "i686" (or (%current-target-system)
(%current-system)))
- #~((add-after 'skip-failing-tests-i686 'skip-failing-tests-i686-cuirass
+ #~((add-after 'skip-failing-tests-i686 'skip-more-failing-tests-i686
(lambda _
+ (substitute* '("testsuite/tests/profiling/should_run/all.T")
+ (("test\\('T11627a', \\[ ")
+ "test('T11627a', [ when(arch('i386'), skip), "))
(substitute* '("testsuite/driver/testlib.py")
((".*changes being made to the file will invalidate the code signature.*")
"")

base-commit: b5a5e4d712d0a1998995be62bb41b03955b7dcf1
prerequisite-patch-id: 3297b62c093009d94f43908e88dfc50a53ccbeac
--
2.41.0
Lars-Dominik Braun wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 64643@debbugs.gnu.org)
ZLOqU-dssEYwLh4n@noor.fritz.box
Hi Christopher,

Toggle quote (3 lines)
> As one profiling test fails very repeatedly on the bordeaux build farm, but
> ghc did seem to build successfully on other machines.

do you have a log file showing the failure? It’s also a pretty big
rebuild (almost 1800 packages), so maybe we can apply this change on
i386 only for now?

Cheers,
Lars
Christopher Baines wrote 2 years ago
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 64643@debbugs.gnu.org)
87v8ekxn5c.fsf@cbaines.net
Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (9 lines)
> Hi Christopher,
>
>> As one profiling test fails very repeatedly on the bordeaux build farm, but
>> ghc did seem to build successfully on other machines.
>
> do you have a log file showing the failure? It’s also a pretty big
> rebuild (almost 1800 packages), so maybe we can apply this change on
> i386 only for now?

Yep, you can click the "View build on https://bordeaux.guix.gnu.org"
links from this page [1] to find the build logs for all the failing
builds.


And yes, this patch only affects i686-linux as confirmed by [2].

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmSzrY9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfOyA//aMm3phiDaiaFH2lGzPEDVpmLYu4X22VL
c+Je+WkFmWm1aNMHRTYgF6zPnXsZg3JllNqNNHnAXQ6OZr6k54372x+gJuRiRnwV
LByIi8mB525P3pMCR1nykD62Spuf15pYEs/Df/cR7mS6U1BehoGPCwFo6ZsQ2eNQ
CQ8fWP3Eieelii3C2mbI++lzoMV8CRwmvTzv+G3Yw1Gri3Ho+t9aM0qIcTXWBNPN
aMHzTtZWKYw4ni2N0VFS2Yjo/o1gWcqv/hSvevEL1X/gkLJ0eWTbQe+6HaQudkJQ
VWTzo/jJVNubUKkRm6Tnj948IIInCU5Yz3QaLcqrPDL4okXQqoeeDk+fHPJet5aA
oXW+Jt1KvBXB+t6jus3Pym1IIl9OyyB+HxyjBNv96Shvo/voiCuTsJ/XA58saVBU
y5F2YIPm/SfhH4GTJjBNSZ1H69W+5r7yJhEsIgpE7uYLN0mk38Cv+JYvi29kuZ6F
2xGn49JGXB4VOC8Y4aY9JtTuMAZlXiz0XEH1peKvVRR3yag6OXxxUrQhnf8Keafl
XZkvViGRgjtmox3QN+Wq33p+o+QRszO20lO8Pxl6TC68h8D5JtnNQ/RtM+nC/mxk
qGc5kEnwlJtZJ/8PpbmwmuH76EGqnT2vmZ20cfeff+lX4qcB3pQxW/V0YaADCEbf
AVdlO2djVXE=
=XNVx
-----END PGP SIGNATURE-----

Lars-Dominik Braun wrote 2 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 64643@debbugs.gnu.org)
ZLOydxjDGpotMhL2@noor.fritz.box
Hi,

Toggle quote (6 lines)
> Yep, you can click the "View build on https://bordeaux.guix.gnu.org"
> links from this page [1] to find the build logs for all the failing
> builds.
>
> 1: https://data.qa.guix.gnu.org/gnu/store/sp4csvzxjzzjhmyp7sfdxg3ypqpysh2a-ghc-8.10.7.drv

huh, a segfault. Weird. Perhaps it’s running out of address space.

Toggle quote (2 lines)
> And yes, this patch only affects i686-linux as confirmed by [2].

Ah, you’re right. I missed this patch context:

Toggle quote (3 lines)
> #$@(if (string-prefix? "i686" (or (%current-target-system)
> (%current-system)))

Looks good to me then!

Cheers,
Lars
Christopher Baines wrote 2 years ago
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 64643-done@debbugs.gnu.org)
87r0p6y9pc.fsf@cbaines.net
Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (19 lines)
> Hi,
>
>> Yep, you can click the "View build on https://bordeaux.guix.gnu.org"
>> links from this page [1] to find the build logs for all the failing
>> builds.
>>
>> 1: https://data.qa.guix.gnu.org/gnu/store/sp4csvzxjzzjhmyp7sfdxg3ypqpysh2a-ghc-8.10.7.drv
>
> huh, a segfault. Weird. Perhaps it’s running out of address space.
>
>> And yes, this patch only affects i686-linux as confirmed by [2].
>
> Ah, you’re right. I missed this patch context:
>
>> #$@(if (string-prefix? "i686" (or (%current-target-system)
>> (%current-system)))
>
> Looks good to me then!

Great, I've pushed this to master as
ad08f9331fee7a8e71e94b02f86f54ab3e1001a8.

There's ~2000 affected packages, but I think this is OK since at least
for the bordeaux build farm, these packages are being unblocked rather
than rebuilt, and for ci, it'll take no time at all to catch up.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmS1O19fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfCtg//S/zO15/DtKbxL/6sraTZkt2Dlk/RMQbt
J/1rISlGFelF5+4u2GLHhaYfWfS4b1ksxUcltsElTz5HYqc6dyDswvDM06a5bFfq
uX0OMiuocARHUodm6VNgoOVzb5MchoUSpF6HCMKEQCbN4U3uHOIYk2EjZSFQkmQ3
G8HWGxpAG//Mtx9gX0o253SoPRymdENcc9sAQz1s7Y0/unCtWZZ6hx6kjK6/zj1l
7ULDCV6xoPUbvaZw75VjOmy/EfJylUgNN5sywgQ/R9bkXbPtJhUcc8biafYwyxAb
QwuzcVpBZRNFUdeSE0g20N1PwBR1OLEnlawD4+Cd+4G9j0xMbdeGVpCJhacmRcI5
OTraYh5nPPvfWXX1HSU9ib7F5gP5cK5d5gbNOBvL0QQPN+0YfT+dIx3162Lkh98k
oDHPTKatSt/DhjX7rZo1Xbh6+HZaxYjLRfyp9P6qtfqwijiY8iRz/VTRGrF/JRAr
7sFdcnVZkf1hdguhahKIhSL8TqGKuwcnA8KnrLJL3TMdOWFpayLuAv3xS+XG5vXr
XU90max58DT7IgE+nGjjXU4KitIQJsYdeV3mDh3VpDrlj/vr8/i/LMyzgOyQ5Nu8
eMrrz7D7LgXumRdutVfTSzVu2wyL7K9jR275HV2qHvPNflkYNNp9io4K8+s9BS07
N9Mx0sorYHo=
=racn
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64643@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64643
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help