Christopher Baines wrote 2 years ago
(address . guix-patches@gnu.org)
As one profiling test fails very repeatedly on the bordeaux build farm, but
ghc did seem to build successfully on other machines.
* gnu/packages/haskell.scm (ghc-8.10)[arguments]: Don't run the T11627a
profiling test on i686-linux.
---
gnu/packages/haskell.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b2c86fec4..62815efbb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1271,8 +1271,11 @@ (define-public ghc-8.10
;; next rebuild. Note that they are required for GHC 8.10 and 9.2.
#$@(if (string-prefix? "i686" (or (%current-target-system)
(%current-system)))
- #~((add-after 'skip-failing-tests-i686 'skip-failing-tests-i686-cuirass
+ #~((add-after 'skip-failing-tests-i686 'skip-more-failing-tests-i686
(lambda _
+ (substitute* '("testsuite/tests/profiling/should_run/all.T")
+ (("test\\('T11627a', \\[ ")
+ "test('T11627a', [ when(arch('i386'), skip), "))
(substitute* '("testsuite/driver/testlib.py")
((".*changes being made to the file will invalidate the code signature.*")
"")
base-commit: b5a5e4d712d0a1998995be62bb41b03955b7dcf1
prerequisite-patch-id: 3297b62c093009d94f43908e88dfc50a53ccbeac
--
2.41.0