[PATCH] gnu: Add wdisplays.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
4e8847021ede6d8eac1bcfb8bb64583d61346a80.1689387515.git.kiasoc5@disroot.org
* gnu/packages/wm.scm (wdisplays): New variable.
---
gnu/packages/wm.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b9909de219..56a0b72236 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2022,6 +2022,28 @@ (define-public kanshi
Wayland compositors supporting the wlr-output-management protocol.")
(license license:expat))) ; MIT license
+(define-public wdisplays
+ (package
+ (name "wdisplays")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artizirk/wdisplays.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06ydcmfdics2qqjb14p767xs8khd86nancdd9z8j11h2gpvwznvn"))))
+ (build-system meson-build-system)
+ (inputs (list gtk+ libepoxy wayland))
+ (native-inputs (list `(,glib "bin") pkg-config))
+ (home-page "https://github.com/artizirk/wdisplays")
+ (synopsis "Graphical application for configuring displays in Wayland compositors")
+ (description "wdisplays is a graphical application for configuring displays in
+Wayland compositors that implements the wlr-output-management-unstable-v1 protocol.")
+ (license license:gpl3+)))
+
(define-public stumpwm
(package
(name "stumpwm")

base-commit: 917a299831361f253ea664f009176b4bbe06900a
--
2.41.0
宋文武 wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 64633-done@debbugs.gnu.org)
87jzuuon04.fsf@envs.net
Hello kiasoc5, this is a good patch and QA passed, so I applied it with
synopsis and description adjusted:

- (synopsis "Graphical application for configuring displays in Wayland compositors")
- (description "wdisplays is a graphical application for configuring displays in
-Wayland compositors that implements the wlr-output-management-unstable-v1 protocol.")
+ (synopsis "Configuring displays in Wayland compositors")
+ (description "@command{wdisplays} is a graphical application for
+configuring displays in Wayland compositors that implements the

Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64633@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64633
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help