[PATCH] gnu: python-pyusb: Update to 1.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 2 years ago
(address . guix-patches@gnu.org)
89ccedb34b5d1cd4a286e465280f7d69423f5ec1.1689363756.git.simon@simonsouth.net
* gnu/packages/libusb.scm (python-pyusb): Update to 1.2.1.
[native-inputs]: Add python-setuptools-scm.
---
Tested on AArch64 and x86-64 and all appears well. All dependencies build
without issue since commit 917a299831.

gnu/packages/libusb.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index d0837c8a91..13090d30ab 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -274,14 +274,14 @@ (define-public python-libusb1
(define-public python-pyusb
(package
(name "python-pyusb")
- (version "1.0.2")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyusb" version))
(sha256
(base32
- "0qkk2jn270jwwl1x26hmdhb14m9kkbrzzwzizdjcl1a29b6756sf"))))
+ "1fg7knfzybzija2b01pzrzhzsj989scl12sb2ra4f503l8279k54"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -302,6 +302,9 @@ (define-public python-pyusb
"^libusb-.*\\.so\\..*"))
"\"")))
#t)))))
+
+ (native-inputs
+ (list python-setuptools-scm))
(inputs
(list libusb))
(home-page "https://pyusb.github.io/pyusb/")

base-commit: 917a299831361f253ea664f009176b4bbe06900a
--
2.40.1
宋文武 wrote 2 years ago
(name . Simon South)(address . simon@simonsouth.net)(address . 64629-done@debbugs.gnu.org)
87h6pyomj2.fsf@envs.net
Simon South <simon@simonsouth.net> writes:

Toggle quote (6 lines)
> * gnu/packages/libusb.scm (python-pyusb): Update to 1.2.1.
> [native-inputs]: Add python-setuptools-scm.
> ---
> Tested on AArch64 and x86-64 and all appears well. All dependencies build
> without issue since commit 917a299831.

QA status is unknown (seems unreleated to me), but I got dependent
packages (stcgal python-capablerobot-usbhub rfcat yubikey-oath-dmenu)
built too. So I applied it now, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64629@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64629
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help