[PATCH] gnu: Add emacs-project-mode-line-tag.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
21aedf8ebb93f95c6dfe486bb07175b2f5bfa154.1689355991.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-project-mode-line-tag): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..cbe88a2ad5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1261,6 +1261,31 @@ (define-public emacs-project
some utility functions, and commands using that infrastructure.")
(license license:gpl3+)))
+;; Package has no release. Version is extracted from "Version:" keyword in
+;; main file.
+(define-public emacs-project-mode-line-tag
+ (let ((commit "a8809cc1a50cfdedaf7bed2810249ae262884716")
+ (revision "0"))
+ (package
+ (name "emacs-project-mode-line-tag")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/fritzgrabo/project-mode-line-tag")
+ (commit commit)))
+ (sha256
+ (base32
+ "0bmx9a1g199axj9ypqisvfyf1517czw23zg96x1wdzqrpw3cb7cx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/fritzgrabo/project-mode-line-tag")
+ (synopsis "Display a buffer's project in its mode line")
+ (description
+ "Display information about a buffer's project (a \"project tag\") in
+its mode line.")
+ (license license:gpl3+))))
+
(define-public git-modes
(package
(name "emacs-git-modes")

base-commit: 917a299831361f253ea664f009176b4bbe06900a
--
2.41.0
Ahmad Draidi wrote 2 years ago
[PATCH v2] gnu: Add emacs-project-mode-line-tag.
(address . 64626@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
2a56609b0d1b1bc9230c2bf3c9197df89d519fbf.1689359992.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-project-mode-line-tag): New variable.
---

Second version adds '(file-name (git-file-name name version))'.
It seems to be recommended in the docs, and 'guix import' doesn't add it.

Sorry for the noise.

gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..1c61068f6c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1261,6 +1261,32 @@ (define-public emacs-project
some utility functions, and commands using that infrastructure.")
(license license:gpl3+)))
+;; Package has no release. Version is extracted from "Version:" keyword in
+;; main file.
+(define-public emacs-project-mode-line-tag
+ (let ((commit "a8809cc1a50cfdedaf7bed2810249ae262884716")
+ (revision "0"))
+ (package
+ (name "emacs-project-mode-line-tag")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url
+ "https://github.com/fritzgrabo/project-mode-line-tag")
+ (commit commit)))
+ (sha256
+ (base32
+ "0bmx9a1g199axj9ypqisvfyf1517czw23zg96x1wdzqrpw3cb7cx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/fritzgrabo/project-mode-line-tag")
+ (synopsis "Display a buffer's project in its mode line")
+ (description
+ "Display information about a buffer's project (a \"project tag\") in
+its mode line.")
+ (license license:gpl3+))))
+
(define-public git-modes
(package
(name "emacs-git-modes")

base-commit: 917a299831361f253ea664f009176b4bbe06900a
--
2.41.0
Liliana Marie Prikler wrote 2 years ago
Re: Processed: Your Emacs patches
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
a78ebab99dd7530ec864529c9119a9866e28c023.camel@gmail.com
Am Sonntag, dem 23.07.2023 um 04:01 -0400 schrieb GNU bug tracker automated control server:
Toggle quote (1 lines)
> bug marked as fixed in version 64560 ...
Welp, that didn't work as expected
close 64560 
close 64582
close 64585
close 64614
close 64624
close 64626
close 64627
close 64628
close 64657
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64626@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64626
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help