(address . bug-guix@gnu.org)
Hi,
I am experiencing a test failure on a Guix build from the git in the
tests/store-roots.scm test file. Excerpt (whole log file attached):
test-name: gc-roots, initial
location: /home/wolf/devel/guix/tests/store-roots.scm:33
source:
+ (test-equal
+ "gc-roots, initial"
+ (list (string-append %state-directory "/profiles"))
+ (begin
+ (delete-file-recursively
+ (string-append %state-directory "/profiles"))
+ (gc-roots)))
expected-value: ("/home/wolf/devel/guix/test-tmp/var/15530/profiles")
actual-value: #f
actual-error:
+ (system-error
+ "lstat"
+ "~A: ~S"
+ ("No such file or directory"
+ "/home/wolf/devel/guix/test-tmp/var/15530/profiles")
+ (2))
result: FAIL
Commit: 3b524cde7115a6e89a438c1fd230093e6f30442f
Build was done inside guix shell -D guix --pure.
W.
--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
test-name: gc-roots, initial
location: /home/wolf/devel/guix/tests/store-roots.scm:33
source:
+ (test-equal
+ "gc-roots, initial"
+ (list (string-append %state-directory "/profiles"))
+ (begin
+ (delete-file-recursively
+ (string-append %state-directory "/profiles"))
+ (gc-roots)))
expected-value: ("/home/wolf/devel/guix/test-tmp/var/15530/profiles")
actual-value: #f
actual-error:
+ (system-error
+ "lstat"
+ "~A: ~S"
+ ("No such file or directory"
+ "/home/wolf/devel/guix/test-tmp/var/15530/profiles")
+ (2))
result: FAIL
test-name: gc-roots, regular root
location: /home/wolf/devel/guix/tests/store-roots.scm:44
source:
+ (test-assert
+ "gc-roots, regular root"
+ (let* ((item (add-text-to-store
+ %store
+ "something"
+ (random-text)))
+ (root (string-append
+ %gc-roots-directory
+ "/test-gc-root")))
+ (symlink item root)
+ (let ((result (member root (gc-roots))))
+ (delete-file root)
+ result)))
actual-value: ("/home/wolf/devel/guix/test-tmp/var/15530/gcroots/test-gc-root")
result: PASS
test-name: gc-roots, indirect root
location: /home/wolf/devel/guix/tests/store-roots.scm:53
source:
+ (test-assert
+ "gc-roots, indirect root"
+ (call-with-temporary-directory
+ (lambda (directory)
+ (let* ((item (add-text-to-store
+ %store
+ "something"
+ (random-text)))
+ (root (string-append directory "/gc-root")))
+ (symlink item root)
+ (add-indirect-root %store root)
+ (let ((result (member root (gc-roots))))
+ (delete-file root)
+ result)))))
actual-value: ("/tmp/guix-directory.YyukEN/gc-root" "/home/wolf/devel/guix/test-tmp/var/15530/profiles")
result: PASS
random seed for tests: 1689185210
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmSwGD0ACgkQL7/ufbZ/
wam65w//QCd8ao8EX30AbZgiGI7R5xP4hnJgtreIf+DQlQKDr0AlhTpOz73NM6Bj
byBpdFBdwUkeVjHvmtoceFruVffNurkIOMQXwEXi05xtBlm8E9mejrBxMEdTHmJ0
Ie3N+TCCDDeRHX9E5ABrMJefCyU30B790f7RJKdm/SxAiQak+8Q3j+q/t1LDwD6K
FeJMC34JB5G1J5epfS23HGsNymXlJZ0Vb9mkzVu2YgOZbSvp69k01z4c4uDGCx+g
WIn9hwAxsvSjlDUdQOVB8CQXdrv566/J07ItZFeogcVRqOljtoj9q/Hhqlz6AFwV
bd4kw15YlUk+b2l+gXeRS8xiqXYNGP33o7Y0a9Shfr/tiIVW02G8e/x00w/d1SfV
m9XIHYe5um51stalu5Br1Mh4/abBVacdboAnuUB5c4Z+oeHhHG+MK6A7fVW/YZtL
a/r+ZQRhW13yV6r5k3wfOKCPOCxyddNzstkUH+Y+Oa2ictvMxcMoDFxivAN9w7n/
Yv4+/SOFG9T4EKO9v4b1n0vy1JQXWwUYtAKBs0370MJi3O74FgpUDiZXuAfsk0wr
RuYNQ9OPu6PE05lglCz9xBQcE2NRRUpMXkgYc4+j3NkBuWnCil6tCvIgPqwDyLoA
IbPNtN6NXrBeEShXkMMN7pg6beyjR+jxlZzdcls8edOJc8LrOpE=
=XTIm
-----END PGP SIGNATURE-----