Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
* gnu/packages/emacs-xyz.scm (emacs-which-key-posframe): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..77c15ece7e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19243,6 +19243,34 @@ (define-public emacs-which-key
settings).")
(license license:gpl3+)))
+;; Tagged release upstream is from before the package was orphaned.
+;; The base version is extracted from the "Version" keyword in the main file
+;; with "-git" suffix removed.
+(define-public emacs-which-key-posframe
+ (let ((commit "e4a9ce9a1b20de550fca51f14d055821980d534a")
+ (revision "0"))
+ (package
+ (name "emacs-which-key-posframe")
+ (version (git-version "0.2.0.50" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/emacsorphanage/which-key-posframe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kgc29pb5k6cb2m13cz1yhys1k8l4dpx6wjjgldpdlg9qw2i1b53"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-posframe emacs-which-key))
+ (home-page "https://github.com/emacsorphanage/which-key-posframe")
+ (synopsis "Display which-key popup in a posframe (a child frame)")
+ (description
+ "This package is a @code{which-key} extension, which uses posframe
+(a child frame) to show @code{which-key} popups.")
+ (license license:gpl3+))))
+
(define-public emacs-display-wttr
(package
(name "emacs-display-wttr")
base-commit: 3b524cde7115a6e89a438c1fd230093e6f30442f
--
2.41.0