[PATCH] gnu: Add emacs-transient-posframe.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
4e8fe6f21c9984d798effe43287d02b325eaeee6.1689179098.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-transient-posframe): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..a76cab1cd2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37422,6 +37422,32 @@ (define-public emacs-vertico-posframe
a vertical completion UI.")
(license license:gpl3+)))
+;; No tagged release upstream
+(define-public emacs-transient-posframe
+ (let ((commit "dcd898d1d35183a7d4f2c8f0ebcb43b4f8e70ebe")
+ (revision "0"))
+ (package
+ (name "emacs-transient-posframe")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yanghaoxie/transient-posframe")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1aq1vbkww55xplyaa3xagz9z4kdlsxk13x054asnk0dqps4bcgbf"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-posframe emacs-transient))
+ (home-page "https://github.com/yanghaoxie/transient-posframe")
+ (synopsis "Pop up a posframe (a child frame) to show Transients")
+ (description
+ "This package is a @code{transient} extension, which uses @code{posframe}
+(a child frame) to show @code{transient} popups in Emacs. It was developed with
+@code{transient} popups of @code{magit} in mind.")
+ (license license:gpl3+))))
+
(define-public emacs-tintin-mode
(let ((commit "82e71e1db92ee3d94c7d0208bafc5de337193de8")
(revision "1"))

base-commit: 3b524cde7115a6e89a438c1fd230093e6f30442f
--
2.41.0
Liliana Marie Prikler wrote 2 years ago
Re: Processed: Your Emacs patches
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
a78ebab99dd7530ec864529c9119a9866e28c023.camel@gmail.com
Am Sonntag, dem 23.07.2023 um 04:01 -0400 schrieb GNU bug tracker automated control server:
Toggle quote (1 lines)
> bug marked as fixed in version 64560 ...
Welp, that didn't work as expected
close 64560 
close 64582
close 64585
close 64614
close 64624
close 64626
close 64627
close 64628
close 64657
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64582@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64582
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help