[PATCH 0/3] gnu: Add glnemo2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1689032023.git.sharlatanus@gmail.com
Hi Guix!

2 more astro packages for this week, passed lint and build on x86_64 and
aarch64 systems:

Toggle quote (7 lines)
> ./pre-inst-env guix build glnemo2 ccfits --system=aarch64-linux
> /gnu/store/rna5r8sw8wlzvf6xbv2k1kbw37m7jk3q-ccfits-2.6
> /gnu/store/4xh1yjaxhxlc87pdmv1ljlcyhz1vb18k-glnemo2-1.21.0
> ./pre-inst-env guix build glnemo2 ccfits
> /gnu/store/fwfwd0yz8zv36pcammcc1zanks5nzj8w-ccfits-2.6
> /gnu/store/w4k64walqdwy9zdz0pqdxk38bk5c48qd-glnemo2-1.21.0

Sharlatan Hellseher (3):
gnu: cfitsio: Download source over HTTPS.
gnu: Add ccfits.
gnu: Add glnemo2.

gnu/packages/astronomy.scm | 91 +++++++++++++++++++++++++++++++++++++-
1 file changed, 90 insertions(+), 1 deletion(-)


base-commit: 67e22584faaa558c2a5834a5013d77660ec45e85
--
2.40.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 1/3] gnu: cfitsio: Download source over HTTPS.
(address . 64566@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
8b250468497c2c6af0253ebf4a2e4bb72493e017.1689032023.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (cfitsio)[source]: Use HTTPS.
---
gnu/packages/astronomy.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d3f3711bd1..f402b13537 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -428,7 +428,7 @@ (define-public cfitsio
(origin
(method url-fetch)
(uri (string-append
- "http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/"
+ "https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/"
"cfitsio-" version ".tar.gz"))
(sha256
(base32 "128qsv2q0f0g714ahlsixiikvvbwxi9bg9q9pcr5cd3f7wdkv9gb"))))
--
2.40.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 2/3] gnu: Add ccfits.
(address . 64566@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
d81cee57cd845512e3b2ad003fcef519eaaa1d8b.1689032023.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (ccfits): New variable.
---
gnu/packages/astronomy.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f402b13537..5d261370b8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -420,6 +420,30 @@ (define-public casacore
@url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
(license license:gpl2+)))
+(define-public ccfits
+ (package
+ (name "ccfits")
+ (version "2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/"
+ "CCfits-" version ".tar.gz"))
+ (sha256
+ (base32 "04l6na8vr5xadz3rbx62as79x1ch4994vbb625kx0dz5czdkkd1b"))))
+ (build-system cmake-build-system)
+ (inputs (list cfitsio))
+ (home-page "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/")
+ (synopsis "C++ interface to the CFITSIO")
+ (description
+ "CCfits is an object oriented interface to the cfitsio library. It is
+designed to make the capabilities of cfitsio available to programmers working in
+C++. It is written in ANSI C++ and implemented using the C++ Standard Library
+with namespaces, exception handling, and member template functions.")
+ (license (license:non-copyleft "file://License.txt"
+ "See License.txt in the distribution."))))
+
(define-public cfitsio
(package
(name "cfitsio")
--
2.40.1
Sharlatan Hellseher wrote 2 years ago
[PATCH 3/3] gnu: Add glnemo2.
(address . 64566@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
848bcee921835526c39b09f2cb6effd83a78a64b.1689032023.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (glnemo2): New variable.
---
gnu/packages/astronomy.scm | 65 ++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (85 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5d261370b8..3d27f1a60e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -60,6 +60,7 @@ (define-module (gnu packages astronomy)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages perl)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
@@ -757,6 +758,70 @@ (define-public weightwatcher
astronomical image-processing packages like Drizzle, Swarp or SExtractor.")
(license license:gpl3+)))
+(define-public glnemo2
+ (package
+ (name "glnemo2")
+ (version "1.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.lam.fr/jclamber/glnemo2")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jmmxszh8d2jmfghig36nhykff345mqnpssfa64d0r7l9cnfp3cn"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ; No test target
+ #:configure-flags #~(list "CPPFLAGS=-fcommon")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-libraries-paths
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ ;; There is some not straightforward logic on how to set
+ ;; installation prefix for the project, inherit it from the
+ ;; build-system default flags.
+ (("CMAKE_INSTALL_PREFIX \"/usr\"")
+ (string-append "CMAKE_INSTALL_PREFIX"))
+ (("/usr/include/CCfits")
+ (string-append
+ #$(this-package-input "ccfits") "/include/CCfits"))
+ (("/usr/include/tirpc")
+ (string-append
+ #$(this-package-input "libtirpc") "/include/tirpc"))
+ ;; It tries to detect library in 2 "predictable" paths,
+ ;; required during link phase.
+ (("/usr/lib64/libtirpc.so")
+ (string-append
+ #$(this-package-input "libtirpc") "/lib/libtirpc.so"))))))))
+ (inputs
+ (list ccfits
+ cfitsio
+ glm
+ glu
+ hdf5
+ libtirpc
+ qtbase-5
+ zlib))
+ (home-page "https://projets.lam.fr/projects/unsio/wiki")
+ (synopsis "3D interactive visualization program for nbody like particles")
+ (description
+ "GLNEMO2 is an interactive 3D visualization program which displays
+particles positions of the different components (gas, stars, disk, dark mater
+halo, bulge) of an N-body snapshot. It's a very useful tool for everybody
+running N-body simulations from isolated galaxies to cosmological simulations.
+It can show quickly a lot of information about data by revealing shapes, dense
+areas, formation of structures such as spirals arms, bars, peanuts or clumps
+of galaxies. Glnemo2 has been designed to meet the requirements of the user,
+with simplicity in mind, easy to install, easy to use with an interactive and
+responsive graphical user interface (based on QT 5.X API), powerful with a
+fast 3D engine (OPenGL and GLSL), and generic with the possibility to load
+different kinds of input files.")
+ (license license:cecill)))
+
(define-public gnuastro
(package
(name "gnuastro")
--
2.40.1
Andreas Enge wrote 2 years ago
Re: [bug#64566] [PATCH 0/3] gnu: Add glnemo2.
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
ZMElGItYXzgb2_1x@jurong
Hello,

Am Tue, Jul 11, 2023 at 12:37:04AM +0100 schrieb Sharlatan Hellseher:
Toggle quote (3 lines)
> 2 more astro packages for this week, passed lint and build on x86_64 and
> aarch64 systems:

all pushed and closing the bug, thanks!

For glnemo2, I made the description more neutral.
There was a string-append without effect, which I have changed like this:
(substitute* "CMakeLists.txt"
;; There is some not straightforward logic on how to set
;; the installation prefix for the project; inherit it
;; from the build-system default flags.
(("CMAKE_INSTALL_PREFIX \"/usr\"")
- (string-append "CMAKE_INSTALL_PREFIX"))
+ "CMAKE_INSTALL_PREFIX")

Hopefully this works, or was there anything missing to append?

In any case, it builds and I can start it.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64566@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64566
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help