(address . guix-patches@gnu.org)(name . David Elsing)(address . david.elsing@posteo.net)
* gnu/packages/chemistry.scm (freesasa)[arguments]: Add
"CFLAGS=-fno-builtin-malloc" to #:configure-flags.
---
gnu/packages/chemistry.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
Toggle diff (19 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..431b845989 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -703,7 +703,11 @@ (define-public freesasa
#~(list "--enable-check"
"--enable-parser-generator"
"CXXFLAGS=-std=c++17"
- "--enable-doxygen")
+ "--enable-doxygen"
+ ;; Some tests rely on replacing malloc with a wrapper which
+ ;; fails in a controlled way, but this does not work if the call
+ ;; is replaced.
+ "CFLAGS=-fno-builtin-malloc")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-libc++-linking
--
2.40.1