[PATCH] gnu: freesasa: Fix memerr tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Elsing
  • Bruno Victal
Owner
unassigned
Submitted by
David Elsing
Severity
normal

Debbugs page

David Elsing wrote 2 years ago
(address . guix-patches@gnu.org)(name . David Elsing)(address . david.elsing@posteo.net)
c1869dfdd6a083ccb174e66b46cd53b65b76e966.1689012297.git.david.elsing@posteo.net
* gnu/packages/chemistry.scm (freesasa)[arguments]: Add
"CFLAGS=-fno-builtin-malloc" to #:configure-flags.
---
gnu/packages/chemistry.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..431b845989 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -703,7 +703,11 @@ (define-public freesasa
#~(list "--enable-check"
"--enable-parser-generator"
"CXXFLAGS=-std=c++17"
- "--enable-doxygen")
+ "--enable-doxygen"
+ ;; Some tests rely on replacing malloc with a wrapper which
+ ;; fails in a controlled way, but this does not work if the call
+ ;; is replaced.
+ "CFLAGS=-fno-builtin-malloc")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'remove-libc++-linking
--
2.40.1
Bruno Victal wrote 2 years ago
(name . David Elsing)(address . david.elsing@posteo.net)
8771e9cf-a653-1156-cc01-e6e737a1658c@makinata.eu
Hi David,

On 2023-07-10 19:06, David Elsing wrote:
Toggle quote (5 lines)
> + ;; Some tests rely on replacing malloc with a wrapper which
> + ;; fails in a controlled way, but this does not work if the call
> + ;; is replaced.
> + "CFLAGS=-fno-builtin-malloc")

Have you filed an issue with upstream regarding this?
It looks to me that this is something that should be figured out by the
build system or the unit tests.


--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
David Elsing wrote 2 years ago
(name . Bruno Victal)(address . mirai@makinata.eu)
861qhajdwl.fsf@posteo.net
Bruno Victal <mirai@makinata.eu> writes:

Hello Bruno,

Toggle quote (3 lines)
> Have you filed an issue with upstream regarding this?
> It looks to me that this is something that should be figured out by the
> build system or the unit tests.
that's true, I just filed an issue: https://github.com/mittinatten/freesasa/issues/94.

Cheers,
David
David Elsing wrote 1 years ago
(address . 64559@debbugs.gnu.org)
86a5o2n98s.fsf@posteo.net
David Elsing <david.elsing@posteo.net> writes:

Toggle quote (2 lines)
> that's true, I just filed an issue: https://github.com/mittinatten/freesasa/issues/94.

I included this patch in another patch series for rdkit, which was now
applied in commit cc772e7f3172a8014e32c7ea3f6626963d4e9e16. The issue
was also fixed upstream.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64559@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64559
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help