[PATCH] gnu: Add dhex.

  • Open
  • quality assurance status badge
Details
2 participants
  • flabbergasted
  • Maxim Cournoyer
Owner
unassigned
Submitted by
flabbergasted
Severity
normal
F
F
flabbergasted wrote on 10 Jul 2023 11:24
(address . guix-patches@gnu.org)
29a2c5263ac72f950491f627b6055ecb675f0068.1688931860.git.flabbergasted@nofog.net
* gnu/packages/hexedit.scm (dhex): New variable.
---
gnu/packages/hexedit.scm | 46 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 79c14a2..002f6d0 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -29,6 +29,8 @@ (define-module (gnu packages hexedit)
#:use-module (gnu packages ncurses)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu))
(define-public hexedit
@@ -69,6 +71,50 @@ (define-public hexedit
(home-page "http://rigaux.org/hexedit.html")
(license license:gpl2+)))
+(define-public dhex
+ (package
+ (name "dhex")
+ (version "0.69")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.dettus.net/dhex/" name "_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests provided
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install ;multiple issues with provided 'make install'
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (man1 (string-append #$output
+ "/share/man/man1"))
+ (man5 (string-append #$output
+ "/share/man/man5")))
+ (mkdir-p bin)
+ (install-file "dhex" bin)
+ (mkdir-p man1)
+ (install-file "dhex.1" man1)
+ (mkdir-p man5)
+ (install-file "dhexrc.5" man5)
+ (install-file "dhex_markers.5" man5)
+ (install-file "dhex_searchlog.5" man5)))))))
+ (inputs (list ncurses))
+ (home-page "https://www.dettus.net/dhex/")
+ (synopsis "View, edit, and diff files in hexadecimal")
+ (description
+ "Dhex is hex editor which includes a diff mode, which can be used to
+easily and conveniently compare two binary files. It is based on ncurses
+and is themeable.")
+ (license license:gpl2)))
+
(define-public ht
(package
(name "ht")

base-commit: f0ca6346a46c605a590bfd77b84e143a8c759a3b
--
2.40.1
M
M
Maxim Cournoyer wrote on 5 Sep 2023 16:59
(name . flabbergasted)(address . flabbergasted@nofog.net)(address . 64552@debbugs.gnu.org)
87v8cois3f.fsf@gmail.com
Hello,

flabbergasted <flabbergasted@nofog.net> writes:

Toggle quote (58 lines)
> * gnu/packages/hexedit.scm (dhex): New variable.
> ---
> gnu/packages/hexedit.scm | 46 ++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 46 insertions(+)
>
> diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
> index 79c14a2..002f6d0 100644
> --- a/gnu/packages/hexedit.scm
> +++ b/gnu/packages/hexedit.scm
> @@ -29,6 +29,8 @@ (define-module (gnu packages hexedit)
> #:use-module (gnu packages ncurses)
> #:use-module (guix download)
> #:use-module (guix git-download)
> + #:use-module (guix gexp)
> + #:use-module (guix utils)
> #:use-module (guix build-system gnu))
>
> (define-public hexedit
> @@ -69,6 +71,50 @@ (define-public hexedit
> (home-page "http://rigaux.org/hexedit.html")
> (license license:gpl2+)))
>
> +(define-public dhex
> + (package
> + (name "dhex")
> + (version "0.69")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://www.dettus.net/dhex/" name "_"
> + version ".tar.gz"))
> + (sha256
> + (base32
> + "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list
> + #:tests? #f ;no tests provided
> + #:make-flags
> + #~(list (string-append "CC=" #$(cc-for-target)))
> + #:phases
> + #~(modify-phases %standard-phases
> + (delete 'configure) ;no configure script
> + (replace 'install ;multiple issues with provided 'make install'
> + (lambda _
> + (let ((bin (string-append #$output "/bin"))
> + (man1 (string-append #$output
> + "/share/man/man1"))
> + (man5 (string-append #$output
> + "/share/man/man5")))
> + (mkdir-p bin)
> + (install-file "dhex" bin)
> + (mkdir-p man1)
> + (install-file "dhex.1" man1)
> + (mkdir-p man5)
> + (install-file "dhexrc.5" man5)
> + (install-file "dhex_markers.5" man5)
> + (install-file "dhex_searchlog.5" man5)))))))

install-file takes care of calling 'mkdir' for you, so you can simplify
the above.

Toggle quote (9 lines)
> + (inputs (list ncurses))
> + (home-page "https://www.dettus.net/dhex/")
> + (synopsis "View, edit, and diff files in hexadecimal")
> + (description
> + "Dhex is hex editor which includes a diff mode, which can be used to
> +easily and conveniently compare two binary files. It is based on ncurses
> +and is themeable.")
> + (license license:gpl2)))

This should be gpl2+, given the text reads:

Toggle snippet (6 lines)
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

Could you please send a v2 with the above corrections?

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 5 Sep 2023 16:59
control message for bug #64552
(address . control@debbugs.gnu.org)
87tts8is3c.fsf@gmail.com
tags 64552 + moreinfo
quit
F
F
flabbergasted wrote on 9 Sep 2023 12:00
[PATCH v2] gnu: Add dhex.
(address . 64552@debbugs.gnu.org)
yvjumkfvh7nhldpwfij26xadfgdcbadmnq2iy4ry26havq53j4@al6skq7qv5c3
* gnu/packages/hexedit.scm (dhex): New variable.
---
gnu/packages/hexedit.scm | 43 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 79c14a2..7d3f7d0 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -29,6 +29,8 @@ (define-module (gnu packages hexedit)
#:use-module (gnu packages ncurses)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu))
(define-public hexedit
@@ -69,6 +71,47 @@ (define-public hexedit
(home-page "http://rigaux.org/hexedit.html")
(license license:gpl2+)))
+(define-public dhex
+ (package
+ (name "dhex")
+ (version "0.69")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.dettus.net/dhex/" name "_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests provided
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install ;multiple issues with provided 'make install'
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (man1 (string-append #$output
+ "/share/man/man1"))
+ (man5 (string-append #$output
+ "/share/man/man5")))
+ (install-file "dhex" bin)
+ (install-file "dhex.1" man1)
+ (install-file "dhexrc.5" man5)
+ (install-file "dhex_markers.5" man5)
+ (install-file "dhex_searchlog.5" man5)))))))
+ (inputs (list ncurses))
+ (home-page "https://www.dettus.net/dhex/")
+ (synopsis "View, edit, and diff files in hexadecimal")
+ (description
+ "Dhex is hex editor which includes a diff mode, which can be used to
+easily and conveniently compare two binary files. It is based on ncurses
+and is themeable.")
+ (license license:gpl2+)))
+
(define-public ht
(package
(name "ht")
--
2.41.0
F
F
flabbergasted wrote on 9 Sep 2023 12:06
thank you
(address . 64552@debbugs.gnu.org)
f7jn7ir566p6oiytpdquz3ikgjzgukpnoolqkacf6l2wbaonih@iygffjkkhvro
Hi Maxim,

thank you for the suggestions! I have updated the patch.
(Apologies if I'm using the bug system incorrectly.)

Kind regards,
(flabbergasted)
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64552@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64552
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch