[PATCH 0/2] Add python-sphinx-autoapi

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Wiktor Żelazny
Owner
unassigned
Submitted by
Wiktor Żelazny
Severity
normal

Debbugs page

Wiktor Żelazny wrote 2 years ago
(address . guix-patches@gnu.org)
20230709142039.19011-1-wz@freeshell.de
python-anyascii is not an input of python-sphinx-autoapi at the packaged
version. However, it is an input for the current version of
python-sphinx-autoapi, and it will come handy when the latter can be
updated.

Wiktor Żelazny (2):
gnu: Add python-anyascii.
gnu: Add python-sphinx-autoapi.

gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
2 files changed, 42 insertions(+)


base-commit: 8306d3e52902c0d9cffd9a79b379c917c8cf49be
--
2.41.0
Wiktor Żelazny wrote 2 years ago
[PATCH 1/2] gnu: Add python-anyascii.
(address . 64541@debbugs.gnu.org)
20230709142139.19113-1-wz@freeshell.de
* gnu/packages/python-xyz.scm (python-anyascii): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f196d7a816..6e1d25cd6c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33003,6 +33003,24 @@ (define-public python-langcodes
install @code{python-language-data}.")
(license license:expat)))
+(define-public python-anyascii
+ (package
+ (name "python-anyascii")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "anyascii" version))
+ (sha256
+ (base32
+ "0c27rr3fmc1cx9mkmgx94zdf9yil0napzfkwpjw2bqjghkpk4pcx"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (home-page "https://anyascii.com")
+ (synopsis "Unicode to ASCII transliteration")
+ (description "@code{anyascii} converts Unicode characters to their best
+ASCII representation.")
+ (license license:isc)))
+
(define-public python-geomet
(package
(name "python-geomet")
--
2.41.0
Wiktor Żelazny wrote 2 years ago
[PATCH 2/2] gnu: Add python-sphinx-autoapi.
(address . 64541@debbugs.gnu.org)
20230709142139.19113-2-wz@freeshell.de
* gnu/packages/sphinx.scm (python-sphinx-autoapi): New variable.
---
gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 65b3dc4ec5..e5d16996aa 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1197,3 +1197,27 @@ (define-public python-pydata-sphinx-theme
"This package provides a Bootstrap-based Sphinx theme from the PyData
community.")
(license license:bsd-3)))
+
+(define-public python-sphinx-autoapi
+ (package
+ (name "python-sphinx-autoapi")
+ (version "2.0.1") ;higher versions require Sphinx >= 5.2.0
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-autoapi" version))
+ (sha256
+ (base32
+ "1fmss6ihjjx22nmjzy7qiapj1f2b86gd1vycn3zg8lh8q9l7kx6d"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-sphinx))
+ (propagated-inputs (list python-astroid python-jinja2 python-pyyaml
+ python-sphinx python-unidecode))
+ (home-page "https://github.com/readthedocs/sphinx-autoapi")
+ (synopsis "Sphinx API documentation generator")
+ (description
+ "Sphinx AutoAPI is a Sphinx extension for generating complete
+API documentation without needing to load, run, or import the project being
+documented. In contrast to the traditional Sphinx @code{autodoc}, which
+requires manual authoring and uses code imports, AutoAPI finds and generates
+documentation by parsing source code.")
+ (license license:expat)))
--
2.41.0
Nicolas Goaziou wrote 4 weeks ago
Re: [PATCH 0/2] Add python-sphinx-autoapi
(address . 64541-done@debbugs.gnu.org)(name . Wiktor Żelazny)(address . wz@freeshell.de)
87pljauj3t.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (2 lines)
> * gnu/packages/sphinx.scm (python-sphinx-autoapi): New variable.

Applied the whole set. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64541@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64541
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help