[PATCH 0/2] Add python-sphinx-autoapi

  • Open
  • quality assurance status badge
Details
One participant
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 9 Jul 2023 16:20
(address . guix-patches@gnu.org)
20230709142039.19011-1-wz@freeshell.de
python-anyascii is not an input of python-sphinx-autoapi at the packaged
version. However, it is an input for the current version of
python-sphinx-autoapi, and it will come handy when the latter can be
updated.

Wiktor ?elazny (2):
gnu: Add python-anyascii.
gnu: Add python-sphinx-autoapi.

gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
2 files changed, 42 insertions(+)


base-commit: 8306d3e52902c0d9cffd9a79b379c917c8cf49be
--
2.41.0
W
W
Wiktor ?elazny wrote on 9 Jul 2023 16:21
[PATCH 1/2] gnu: Add python-anyascii.
(address . 64541@debbugs.gnu.org)
20230709142139.19113-1-wz@freeshell.de
* gnu/packages/python-xyz.scm (python-anyascii): New variable.
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f196d7a816..6e1d25cd6c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33003,6 +33003,24 @@ (define-public python-langcodes
install @code{python-language-data}.")
(license license:expat)))
+(define-public python-anyascii
+ (package
+ (name "python-anyascii")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "anyascii" version))
+ (sha256
+ (base32
+ "0c27rr3fmc1cx9mkmgx94zdf9yil0napzfkwpjw2bqjghkpk4pcx"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core))
+ (home-page "https://anyascii.com")
+ (synopsis "Unicode to ASCII transliteration")
+ (description "@code{anyascii} converts Unicode characters to their best
+ASCII representation.")
+ (license license:isc)))
+
(define-public python-geomet
(package
(name "python-geomet")
--
2.41.0
W
W
Wiktor ?elazny wrote on 9 Jul 2023 16:21
[PATCH 2/2] gnu: Add python-sphinx-autoapi.
(address . 64541@debbugs.gnu.org)
20230709142139.19113-2-wz@freeshell.de
* gnu/packages/sphinx.scm (python-sphinx-autoapi): New variable.
---
gnu/packages/sphinx.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 65b3dc4ec5..e5d16996aa 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1197,3 +1197,27 @@ (define-public python-pydata-sphinx-theme
"This package provides a Bootstrap-based Sphinx theme from the PyData
community.")
(license license:bsd-3)))
+
+(define-public python-sphinx-autoapi
+ (package
+ (name "python-sphinx-autoapi")
+ (version "2.0.1") ;higher versions require Sphinx >= 5.2.0
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-autoapi" version))
+ (sha256
+ (base32
+ "1fmss6ihjjx22nmjzy7qiapj1f2b86gd1vycn3zg8lh8q9l7kx6d"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-sphinx))
+ (propagated-inputs (list python-astroid python-jinja2 python-pyyaml
+ python-sphinx python-unidecode))
+ (home-page "https://github.com/readthedocs/sphinx-autoapi")
+ (synopsis "Sphinx API documentation generator")
+ (description
+ "Sphinx AutoAPI is a Sphinx extension for generating complete
+API documentation without needing to load, run, or import the project being
+documented. In contrast to the traditional Sphinx @code{autodoc}, which
+requires manual authoring and uses code imports, AutoAPI finds and generates
+documentation by parsing source code.")
+ (license license:expat)))
--
2.41.0
?