(address . bug-guix@gnu.org)
Hi Guix!
I noticed that the emacs package has the following value for
tramp-remote-path out of the box:
(tramp-default-remote-path "~/.guix-profile/bin" "~/.guix-profile/sbin"
"/run/current-system/profile/bin" "/run/current-system/profile/sbin"
"/bin" "/usr/bin" "/sbin" "/usr/sbin" "/usr/local/bin" ...)
This does not seem to include guix home bin dirs. Indeed, when I
connect to my remote machine via tramp, and try to run "git", I get:
git: command not found
This can be fixed by evaluating:
(setq tramp-remote-path (-cons* "~/.guix-home/profile/bin"
"~/.guix-home/profile/sbin"
tramp-remote-path))
(tramp-cleanup-all-connections)
In which case, running "git" in a remote shell gives the expected git
help message.
Is there a reason guix home bin dirs are omitted?
-Zacchae