[PATCH guix] gnu: Add git-issue.

  • Open
  • quality assurance status badge
Details
One participant
  • ~rdesfo
Owner
unassigned
Submitted by
~rdesfo
Severity
normal
~
~
~rdesfo wrote on 7 Jul 2023 15:28
(address . guix-patches@gnu.org)
168874007410.6332.11480896758073036778-0@git.sr.ht
From: Ryan Desfosses <rdesfo@sdf.org>

gnu/packages/version-control.scm (git-issue): New variable.
---
gnu/packages/version-control.scm | 34 ++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 40b9e124d2..c097b9cae3 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2015, 2022 David Thompson <davet@gnu.org>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Ryan Desfosses <rdesfo@sdf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3629,3 +3630,36 @@ create and manage trackers, tickets
interact with GraphQL APIs directly
@end table")
(license license:agpl3)))
+
+(define-public git-issue
+ (let ((commit "4d2bc4173bf803d74bf2ae54f892bd08754f1b48")
+ (revision "0"))
+ (package
+ (name "git-issue")
+ (version (git-version "4d2bc41" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dspinellis/git-issue")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jmx8wjvvxkd3y5im2h96d13dnbpds66djf96b6s23jwfbr7dlsz"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-installation-target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("/usr") out)))))
+ (delete 'configure)
+ (delete 'check))))
+ (inputs (list jq curl))
+ (synopsis "Git-based decentralized issue management")
+ (description "This is a minimalist decentralized issue management system
+based on Git, offering (optional) biderectional integration with GitHub and
+GitLab issue management. It has the following advantages over other systems.")
+ (home-page "https://github.com/dspinellis/git-issue")
+ (license license:gpl3+))))
--
2.38.5
~
~
~rdesfo wrote on 7 Jul 2023 15:28
(address . 64513@debbugs.gnu.org)
168894722633.456.553216670173469261-0@git.sr.ht
From: Ryan Desfosses <rdesfo@sdf.org>

gnu/packages/version-control.scm (git-issue): New variable.
---
removed extra sentence out of the description.

gnu/packages/version-control.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c097b9cae3..2ffbf85125 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3660,6 +3660,6 @@ interact with GraphQL APIs directly
(synopsis "Git-based decentralized issue management")
(description "This is a minimalist decentralized issue management system
based on Git, offering (optional) biderectional integration with GitHub and
-GitLab issue management. It has the following advantages over other systems.")
+GitLab issue management.")
(home-page "https://github.com/dspinellis/git-issue")
(license license:gpl3+))))
--
2.38.5
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64513@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64513
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch