[PATCH v1] gnu: Add simtrace-1

  • Open
  • quality assurance status badge
Details
3 participants
  • Denis 'GNUtoo' Carikli
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 7 Jul 2023 16:09
(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
ff689141cb75d35ed673a6867b2551db3cfe9368.1688738697.git.GNUtoo@cyberdimension.org
* gnu/packages/telephony.scm (simtrace-1): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/telephony.scm | 72 ++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)

Toggle diff (94 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index aa65c4eaad..b00a2971c7 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -87,6 +87,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages security-token)
#:use-module (gnu packages serialization)
#:use-module (gnu packages speech)
+ #:use-module (gnu packages tex)
#:use-module (gnu packages tls)
#:use-module (gnu packages upnp)
#:use-module (gnu packages video)
@@ -989,6 +990,77 @@ (define-public libosmocore
(home-page "https://osmocom.org/projects/libosmocore/wiki/Libosmocore")
(license license:gpl2+)))
+(define-public simtrace-1
+ (package
+ (name "simtrace-1")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.osmocom.org/sim-card/simtrace")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "03wjdavp7fbr7jzzhqx6di9v87yvfi19i3kpn798vlpbw7iwkjry"))))
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "DESTDIR="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "host")))
+ (add-after 'chdir 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr")
+ ""))))
+ (delete 'configure)
+ (add-after 'build 'build-usermanual
+ (lambda* (#:key inputs native-inputs
+ #:allow-other-keys)
+ (substitute* "../docs/usermanual.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd")))
+ ;; At the beginning of the document, a table is
+ ;; constructed with the build time in it. This
+ ;; comes from '\newcommand{\DBKdate}{\today}' in
+ ;; share/dblatex/latex/contrib/db2latex/db2latex.sty
+ ;; in /gnu/store/[...]-dblatex-[...]. We used the
+ ;; commit time for the date instead.
+ (invoke (which "faketime") "2019-10-01"
+ (which "dblatex") "../docs/usermanual.xml")))
+ (add-after 'build-usermanual 'install-usermanual
+ (lambda _
+ (install-file "../docs/usermanual.pdf"
+ (string-append #$output
+ "/share/doc/simtrace-1/"))))
+ (add-after 'install 'install-man
+ (lambda _
+ (install-file "simtrace.1"
+ (string-append #$output "/man/man1/")))))))
+ (build-system gnu-build-system)
+ (native-inputs (list dblatex docbook-xml-4.2 libfaketime pkg-config
+ texlive))
+ (inputs (list libosmocore libusb lksctp-tools talloc))
+ (synopsis
+ "Sniff the communication between phones and SIM cards with SIMtrace 1")
+ (description
+ "This contains the simtrace utility.
+It is compatible with the SIMtrace 1 hardware that contains an Atmel AT91SAM7S
+micro-controller. It is not compatible with the SIMtrace 2 hardware that uses
+an Atmel ATSAM3S micro-controller instead. The simtrace utility can display
+the SIM PDUs directly and/or send them to a given IP address to enable users
+to view SIM PDUs in Wireshark. It also contains a complete user manual for
+the SIMtrace 1 hardware.")
+ (home-page "https://osmocom.org/projects/simtrace/wiki/SIMtrace")
+ ;; The utility is GPLv2-only according to the source files headers, and the
+ ;; manual is under the cc-by-sa 3.0
+ (license (list license:gpl2 license:cc-by-sa3.0))))
+
(define-public xgoldmon
;; There are no releases nor tags.
(let ((revision "1")

base-commit: 961ffca1c75141cbb351d143b22b673638e9659d
--
2.40.1
C
C
Christopher Baines wrote on 5 Oct 2023 12:12
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
878r8hgym8.fsf@cbaines.net
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> writes:

Toggle quote (8 lines)
> * gnu/packages/telephony.scm (simtrace-1): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> ---
> gnu/packages/telephony.scm | 72 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 72 insertions(+)
>

...

Toggle quote (4 lines)
> + (build-system gnu-build-system)
> + (native-inputs (list dblatex docbook-xml-4.2 libfaketime pkg-config
> + texlive))

./pre-inst-env guix build simtrace-1
gnu/packages/telephony.scm:1035:25: In procedure native-inputs:
error: texlive: unbound variable
hint: Did you forget `(use-modules (gnu packages texlive))'?

Maybe this broke with some of the texlive changes being made, would you
be able to take a look?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUejb9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfrLA/7BUs5/gWIrCDOmXoYcWzRizdYl9A2mtZ2
xc8ERuHfGj5hzkBLkddsKOiK2OyInBsKMltmrFr+X97/z3xR9bcb9MYhOqLw2I9q
jgwV+Kmpdn8BMpRXh2grd1KD97pnfkxOb6eCc19Iuz3W8JXdpHwWbc4DlU+Wjcob
4snQRADM1jhtYX4mMH+O5tnhyvU8pf9TxdB/Q0VFRRubh7Wyy0zzfLsL1FE/RFB2
B+8bqaKLTsQzxT3aPWS9EUmNOINF/GQp3K5fsRoX+dnwBslVaDr3IaOhnBkzH2xF
v6ivOWuylGdX5jMrO39bj+74gPRYRsCw2LyRAUAV7/FGP7qQG8/OzYq+O4jIw6a7
lDdrZGw/hTlkvYSTq0zKpoQ4VUbvonMJT7YGXHF+vzVp2+kQ1H8GHREkoW6Tdw/V
oN+T7TQqYTu9YJCB/oBgi50WsB9s226M9lwmFd2ii7poRk4MWxzuuOMnuFASYDwG
XDGCX85RSOmUNaGFuuMFDnuCAr3hmvkt1WRqGxfqTGFc5iPo1B/Eczr+S9lSvpnj
dRyMH3Qio7i4uk/qbPGOCuHrAQkCITPvoLO6ymGVH0Yp9r2zwQXV3vpRgzSA82xP
jKnEP+xuMxLQ671x2wHJVR68Bl1AghyidMV0moyKZSZMxs/Zh+Y2ugxMUyBK0tRi
Xwj3c1zxK6A=
=k5WO
-----END PGP SIGNATURE-----

D
D
Denis 'GNUtoo' Carikli wrote on 6 Oct 2023 14:53
(name . Christopher Baines)(address . mail@cbaines.net)
20231006145323.28b90740@primary_laptop
Hi,

On Thu, 05 Oct 2023 11:12:26 +0100
Christopher Baines <mail@cbaines.net> wrote:

Toggle quote (5 lines)
> ./pre-inst-env guix build simtrace-1
> gnu/packages/telephony.scm:1035:25: In procedure native-inputs:
> error: texlive: unbound variable
> hint: Did you forget `(use-modules (gnu packages texlive))'?

Thanks for spotting that. This issue is really interesting.

When I tested the package it worked fine and the texlive package came
from the tex module (and telephony.scm had and still has '#:use-module
(gnu packages tex)').

But since that time the following commit made it in Guix:
Toggle quote (2 lines)
> 0421160f4a350de72422f4a51d7fd101b3764376 ("gnu:
> texlive: Reinstate the monolithic texlive package.")
and that moved texlive package from tex.scm to texlive.scm.

So we need to add '#:use-module (gnu packages texlive)' to fix that.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmUgA0MACgkQX138wUF3
4mOi/BAAmZQR3fCI6vA0QZG4MQGw9oCRcCJZ6y9d48XIZGkvSXAnR8eYMRp9MA7h
5Ook+OImQfx1gzLdqSaj0aqjTqn+BmYHfKTQMEBLs21i9erT6Vxo4Uhc4MUGn2qi
vYqjAdArIHUfWUoy3Cka+l6xrSjHnRt6aCiWY6jAUjMp3PxRs73ZIEAvAicZnC9u
H4rigxjr1RCpjCRBGlNUrklmaO9/8gqqy7o2dfDAQS/0z7nnb83ngmDg5c9yG4fx
UnU3ILd8F9lkI9knjMcwK+6g87QGnDPN56/j9CKDg705yKv/HjmRaIO4nVEevi1I
AzRjBt0xnzePM2BsuKj+Cx0xPksT1Zg+uS9DC2mhqCfnI9GmsZDM3mfJB+BH97cd
VYrhWC/cbN04uwlovymZ8NUlmnt1A1zz4l90UrBhczY31QEVZTYiPOmp5h+AdYum
b1RgnSJktO1FdSghmjAX7iopqZedUfH9ewFSFCxi5cIRI2MWMfql+rGy3haTm2lJ
qDhp7wBoNKj52u8qu5Ir4CYxw9kpE35GMIyqTH9Kusrj2iZYJv2evCIbUY0yc2+z
NoEa477sgmsod1F1z9vNiUsBS2ljcxkvZ3kgydk4HhLB31TXK+CGLhsHABJhDgPk
rmTAWvPDMkbT/C5pB+f04xqCFLKHfVhHtOEi0Q25h87wStszjIM=
=P4O1
-----END PGP SIGNATURE-----


D
D
Denis 'GNUtoo' Carikli wrote on 6 Oct 2023 15:07
(name . Christopher Baines)(address . mail@cbaines.net)
20231006150755.3482fab7@primary_laptop
On Fri, 6 Oct 2023 14:53:23 +0200
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

Toggle quote (1 lines)
> So we need to add '#:use-module (gnu packages texlive)' to fix that.
Sorry my patch added '#:use-module (gnu packages texlive)', so we need
to change tex in texlive.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmUgBqsACgkQX138wUF3
4mNWohAAg3VlbGLjRkME5ssrj2XrdOxy/5sdXcIs7mUW9sRXdTlqHft7ctLt+mUz
O5qXbaHFPIU37RvnHbTQ5P5mswfCmFShkwT8whglskoS5iJ3cTiN6zU21pNM9zpf
qaJniyaQ8dYr+8C6DPfpOeJUDHd3Bsu+9+SFH5xGdMN1NpSvxFlJsN7AzwdF9tE6
psgsmSpGqIQ6CSWFOZyEq/gw5EQiIdoUBLjkMaux2wSCqq5AOjuHgJmkA84TBhlN
A5ZyVpVZ0fgce7DkPLVNbT5O5MGoWMNF9pZinZujs+1N5KyktaERXAlyLrvwBaBm
s1sRe8wBaNFRWmX9+NXC7iPH24thjc1T1cap1aH/FdpJ07m9GRv6iGENh1ikPXir
vN6QVLDfgjuTj5pFWHye+drAxxKYWqJrSXELf8ijbesbpR6K4jkYPop0kNVmSel0
2PfnfYVHyfpaqa43/t4vR2vZt1VsK+caSgEryMCXKBedULo8zAyN6TZYqqgNP1u7
J4Alg3xmlFuaWfGV7S8WgnVUZvhufJ9AUZV0P1IxXMrTAuxkbKNpOr5+UM49Z7MS
+PZbpz4xizvCZWRbumkulCAVOHpIs1Q2QI1YSOJJRonVA2e+sVswejgSTcLajbTA
gyVsDb8XDF39JbD583vqRPD9tzebaNoOuFx6Ln3IDhpn8iYg4O0=
=1PBS
-----END PGP SIGNATURE-----


D
D
Denis 'GNUtoo' Carikli wrote on 6 Oct 2023 18:16
[PATCH v2] gnu: Add simtrace-1
(address . 64510@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
525e005b4c563deadc37f65f7293531b3e98702b.1696608951.git.GNUtoo@cyberdimension.org
* gnu/packages/telephony.scm (simtrace-1): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
ChangeLog:
- change #:use-module (gnu packages tex)
in #:use-module (gnu packages texlive) as texlive moved file.
---
gnu/packages/telephony.scm | 72 ++++++++++++++++++++++++++++++++++++++
1 file changed, 72 insertions(+)

Toggle diff (94 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 42158784ca..0865ab5fe1 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -78,6 +78,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages samba)
#:use-module (gnu packages security-token)
#:use-module (gnu packages speech)
+ #:use-module (gnu packages texlive)
#:use-module (gnu packages tls)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
@@ -977,6 +978,77 @@ (define-public libosmocore
(home-page "https://osmocom.org/projects/libosmocore/wiki/Libosmocore")
(license license:gpl2+)))
+(define-public simtrace-1
+ (package
+ (name "simtrace-1")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.osmocom.org/sim-card/simtrace")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "03wjdavp7fbr7jzzhqx6di9v87yvfi19i3kpn798vlpbw7iwkjry"))))
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "DESTDIR="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "host")))
+ (add-after 'chdir 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr")
+ ""))))
+ (delete 'configure)
+ (add-after 'build 'build-usermanual
+ (lambda* (#:key inputs native-inputs
+ #:allow-other-keys)
+ (substitute* "../docs/usermanual.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd")))
+ ;; At the beginning of the document, a table is
+ ;; constructed with the build time in it. This
+ ;; comes from '\newcommand{\DBKdate}{\today}' in
+ ;; share/dblatex/latex/contrib/db2latex/db2latex.sty
+ ;; in /gnu/store/[...]-dblatex-[...]. We used the
+ ;; commit time for the date instead.
+ (invoke (which "faketime") "2019-10-01"
+ (which "dblatex") "../docs/usermanual.xml")))
+ (add-after 'build-usermanual 'install-usermanual
+ (lambda _
+ (install-file "../docs/usermanual.pdf"
+ (string-append #$output
+ "/share/doc/simtrace-1/"))))
+ (add-after 'install 'install-man
+ (lambda _
+ (install-file "simtrace.1"
+ (string-append #$output "/man/man1/")))))))
+ (build-system gnu-build-system)
+ (native-inputs (list dblatex docbook-xml-4.2 libfaketime pkg-config
+ texlive))
+ (inputs (list libosmocore libusb lksctp-tools talloc))
+ (synopsis
+ "Sniff the communication between phones and SIM cards with SIMtrace 1")
+ (description
+ "This contains the simtrace utility.
+It is compatible with the SIMtrace 1 hardware that contains an Atmel AT91SAM7S
+micro-controller. It is not compatible with the SIMtrace 2 hardware that uses
+an Atmel ATSAM3S micro-controller instead. The simtrace utility can display
+the SIM PDUs directly and/or send them to a given IP address to enable users
+to view SIM PDUs in Wireshark. It also contains a complete user manual for
+the SIMtrace 1 hardware.")
+ (home-page "https://osmocom.org/projects/simtrace/wiki/SIMtrace")
+ ;; The utility is GPLv2-only according to the source files headers, and the
+ ;; manual is under the cc-by-sa 3.0
+ (license (list license:gpl2 license:cc-by-sa3.0))))
+
(define-public xgoldmon
;; There are no releases nor tags.
(let ((revision "1")

base-commit: 8d27ef1ed34a0a7fe14fd76f31541b62d0125498
--
2.41.0
L
L
Ludovic Courtès wrote on 11 Oct 2023 19:16
Re: bug#64510: [PATCH v1] gnu: Add simtrace-1
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
87wmvtrse9.fsf_-_@gnu.org
Hi,

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/telephony.scm (simtrace-1): New variable.

Applied with the change below, suggested by ‘guix lint’.

Thanks!

Ludo’.
Toggle diff (12 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 0865ab5fe1..6974cfcadb 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -987,6 +987,7 @@ (define-public simtrace-1
(uri (git-reference
(url "https://gitea.osmocom.org/sim-card/simtrace")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
"03wjdavp7fbr7jzzhqx6di9v87yvfi19i3kpn798vlpbw7iwkjry"))))
L
L
Ludovic Courtès wrote on 11 Oct 2023 19:17
control message for bug #64510
(address . control@debbugs.gnu.org)
87v8bdrsdm.fsf@gnu.org
reopen 64510
tags 64510 - fixed patch
quit
L
L
Ludovic Courtès wrote on 11 Oct 2023 19:19
Re: bug#64510: [PATCH v1] gnu: Add simtrace-1
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
87r0m1rs8x.fsf_-_@gnu.org
Hi,

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/telephony.scm (simtrace-1): New variable.

[...]

Toggle quote (6 lines)
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitea.osmocom.org/sim-card/simtrace")
> + (commit (string-append "v" version))))

Please add (git-file-name name version), as suggested by ‘guix lint’.

Toggle quote (3 lines)
> + (native-inputs (list dblatex docbook-xml-4.2 libfaketime pkg-config
> + texlive))

Could you replace the dependency on ‘texlive’ (the monolithic package,
more than 4 GiB) by a dependency on the relevant set of texlive-*
packages (info "(guix) Using TeX and LaTeX")?

There are examples you can borrow from under gnu/packages/….

Thanks,
Ludo’.
D
D
Denis 'GNUtoo' Carikli wrote on 12 Jan 06:47 +0100
[PATCH v3] gnu: Add simtrace-1
(address . 64510@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
988cdb8a1f4374b6adde2ecd9755f32ae046250d.1705038349.git.GNUtoo@cyberdimension.org
* gnu/packages/telephony.scm (simtrace-1): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Change-Id: I7e415cd43ea1df5d5ea4ea7cfb814951aa570313
---
ChangeLog v2->v3:
- Replaced texlive by texlive-* packages.
---
gnu/packages/telephony.scm | 92 ++++++++++++++++++++++++++++++++++++++
1 file changed, 92 insertions(+)

Toggle diff (114 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 41e83384ec..9771bdbb67 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -78,6 +78,7 @@ (define-module (gnu packages telephony)
#:use-module (gnu packages samba)
#:use-module (gnu packages security-token)
#:use-module (gnu packages speech)
+ #:use-module (gnu packages tex)
#:use-module (gnu packages tls)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
@@ -1046,6 +1047,97 @@ (define-public libosmocore
(home-page "https://osmocom.org/projects/libosmocore/wiki/Libosmocore")
(license license:gpl2+)))
+(define-public simtrace-1
+ (package
+ (name "simtrace-1")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitea.osmocom.org/sim-card/simtrace")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03wjdavp7fbr7jzzhqx6di9v87yvfi19i3kpn798vlpbw7iwkjry"))))
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "DESTDIR=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "host")))
+ (add-after 'chdir 'fix-makefile
+ (lambda _ (substitute* "Makefile" (("/usr") ""))))
+ (delete 'configure)
+ (add-after 'build 'build-usermanual
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (substitute* "../docs/usermanual.xml"
+ (("http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/docbookx.dtd")))
+ ;; At the beginning of the document, a table is
+ ;; constructed with the build time in it. This
+ ;; comes from '\newcommand{\DBKdate}{\today}' in
+ ;; share/dblatex/latex/contrib/db2latex/db2latex.sty
+ ;; in /gnu/store/[...]-dblatex-[...]. We used the
+ ;; commit time for the date instead.
+ (invoke
+ (which "faketime") "2019-10-01"
+ (which "dblatex")
+ "../docs/usermanual.xml")))
+ (add-after 'build-usermanual 'install-usermanual
+ (lambda _
+ (install-file
+ "../docs/usermanual.pdf"
+ (string-append #$output "/share/doc/simtrace-1/"))))
+ (add-after 'install 'install-man
+ (lambda _
+ (install-file
+ "simtrace.1"
+ (string-append #$output "/man/man1/")))))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list dblatex docbook-xml-4.2 libfaketime pkg-config
+ (texlive-updmap.cfg
+ (list texlive-appendix
+ texlive-changebar
+ texlive-courier
+ texlive-eepic
+ texlive-fancybox
+ texlive-fancyvrb
+ texlive-float
+ texlive-footmisc
+ texlive-helvetic
+ texlive-jknapltx
+ texlive-listings
+ texlive-multirow
+ texlive-overpic
+ texlive-pdflscape
+ texlive-pdfpages
+ texlive-rsfs
+ texlive-subfigure
+ texlive-times
+ texlive-titlesec))))
+ (inputs (list libosmocore libusb lksctp-tools talloc))
+ (synopsis
+ "Sniff the communication between phones and SIM cards with SIMtrace 1")
+ (description
+ "This contains the simtrace utility.
+It is compatible with the SIMtrace 1 hardware that contains an Atmel AT91SAM7S
+micro-controller. It is not compatible with the SIMtrace 2 hardware that uses
+an Atmel ATSAM3S micro-controller instead. The simtrace utility can display
+the SIM PDUs directly and/or send them to a given IP address to enable users
+to view SIM PDUs in Wireshark. It also contains a complete user manual for
+the SIMtrace 1 hardware.")
+ (home-page "https://osmocom.org/projects/simtrace/wiki/SIMtrace")
+ ;; The utility is GPLv2-only according to the source files headers, and the
+ ;; manual is under the cc-by-sa 3.0
+ (license (list license:gpl2 license:cc-by-sa3.0))))
+
(define-public xgoldmon
;; There are no releases nor tags.
(let ((revision "1")

base-commit: 40f5a3ce437083e4f259878735c2c55f41708e81
--
2.41.0
D
D
Denis 'GNUtoo' Carikli wrote on 24 Jan 01:05 +0100
(address . 64510@debbugs.gnu.org)
20240124010548.5c6324c4@primary_laptop
On Fri, 12 Jan 2024 06:47:53 +0100
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> wrote:

Toggle quote (8 lines)
> * gnu/packages/telephony.scm (simtrace-1): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
> Change-Id: I7e415cd43ea1df5d5ea4ea7cfb814951aa570313
> ---
> ChangeLog v2->v3:
> - Replaced texlive by texlive-* packages.

Ping.

All concerns should now be fixed in the v3.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmWwVF0ACgkQX138wUF3
4mMUFg//covk/xX1ewcnBoH30a1K1JiMl3TFfli/yE0vaNaYSyBDyIL1FSM7M+yN
peX0nu5Dy8v0T7i3g8bQ2b+DSSNad0lrQ1DT35fQHbCQp684tsO1fPyuIROX/cfd
rfq2/h6hdKwImWjFHaBK+l4SYGvdqWBk5fkSVMtu6nJr+MeKbSIr7yQQRsZh920T
Hds6BAsqyMODBm0lwBST7nmHwjkd8pIT5sy9Krj2TsvvglSVXIk+1GeyvS7oiigW
3aeb/Gc9bGB8eLfZTMHiHFsYZKQlCFesiNc3JB3B7dPfukXVLQGt8+VcVkNS3xVY
1agIp/11+sXz2eTmjmk7WYTPCl1holxKvRSqKGhsowYHiNl2PVJouJ+Szijme7ao
qEMExUUz99/UCDuiK+XwD6Oohw64hfDCoLRyBIwqBv041thsIPN+arM8RkoSa0ZU
ZCLI4OnpgO3ZEW/dRAdN014HQpCoGynJs2cmc+7XsA9dcpJj6dVH2pxhS1v2FTzE
fP36ejeYJedI4c+PF9rMrLZgleWhvpAVLohhBs8qJ25RPmnkVKqRCY34SSIFfVoR
i3zOvnkmHsq5FZhS1VxzytAgEzJECmLvSyBDs++9/3+L9M6+JfuFO+NPXvU/q0O3
Z7It86sQwM7Uqu7PBryREDWdmSrFpcnM8RvGmBaqa98AZcBxrDY=
=qX78
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64510@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64510
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch