[PATCH] gnu: python-pygments: Update to 2.15.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Lars-Dominik Braun
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 6 Jul 2023 23:18
(address . guix-patches@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
a3fbc81cd84383483da8aee1e52a6dcbcec8863e.1688678327.git.rekado@elephly.net
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-pytest.
---
gnu/packages/python-xyz.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a89f25b5b6..89a75556bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5913,18 +5913,23 @@ (define-public python-doc8
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.12.0")
+ (version "2.15.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "1sr6iqh21xi6p8aba4wa9pqfhjbbpcvn9jcsx0ggy4lniw8idcay"))))
- (build-system python-build-system)
+ "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: Tests require sphinx, which depends on this.
- '(#:tests? #f))
+ (list
+ #:test-flags
+ ;; Some tests require sphinx, which depends on this, so we only run
+ ;; basic tests.
+ '(list "--ignore-glob=tests/*/*")))
+ (native-inputs
+ (list python-pytest))
(home-page "https://pygments.org/")
(synopsis "Syntax highlighting")
(description

base-commit: 2426e51688d479042ea115a634c6be2d8b9f3b99
prerequisite-patch-id: 64bdaf1b46e713c11e7e3befc50968710d721da1
prerequisite-patch-id: 33eb796cc51e4372cab09fce61b1c4da73c5884d
--
2.40.1
L
L
Lars-Dominik Braun wrote on 9 Jul 2023 19:05
(name . Ricardo Wurmus)(address . rekado@elephly.net)
ZKro3YuItgjwN3_4@noor.fritz.box
Hi,

Toggle quote (5 lines)
> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-pytest.

LGTM. How do you want to push this, since it affects alot of
packages? python-team?

Lars
R
R
Ricardo Wurmus wrote on 9 Jul 2023 21:53
(name . Lars-Dominik Braun)(address . lars@6xq.net)
87ttucsvtw.fsf@elephly.net
Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (8 lines)
>> * gnu/packages/python-xyz.scm (python-pygments): Update to 2.15.1.
>> [build-system]: Use pyproject-build-system.
>> [arguments]: Run tests.
>> [native-inputs]: Add python-pytest.
>
> LGTM. How do you want to push this, since it affects alot of
> packages? python-team?

Either that or piggy-backing on the tex-team branch that’s about ready
to be built these days.

--
Ricardo
L
L
Lars-Dominik Braun wrote on 10 Jul 2023 08:17
(name . Ricardo Wurmus)(address . rekado@elephly.net)
ZKuifsgWKxQir995@noor.fritz.box
Hi,

Toggle quote (3 lines)
> Either that or piggy-backing on the tex-team branch that’s about ready
> to be built these days.

tex-team will probably be faster. python-team is not ready yet,
unfortunately :(

Lars
R
R
Ricardo Wurmus wrote on 18 Jul 2023 10:05
(name . Lars-Dominik Braun)(address . lars@6xq.net)
871qh5fxu4.fsf@elephly.net
Lars-Dominik Braun <lars@6xq.net> writes:

Toggle quote (6 lines)
>> Either that or piggy-backing on the tex-team branch that’s about ready
>> to be built these days.
>
> tex-team will probably be faster. python-team is not ready yet,
> unfortunately :(

After discussing with ngz, we think it’s better to keep this out of
tex-team, because there’s a chance of unforeseen breakage. May I push
this to the python-team branch?

--
Ricardo
L
L
Lars-Dominik Braun wrote on 18 Jul 2023 10:41
(name . Ricardo Wurmus)(address . rekado@elephly.net)
ZLZQL_JeRAvKp2_c@noor.fritz.box
Hey Ricardo,

Toggle quote (4 lines)
> After discussing with ngz, we think it’s better to keep this out of
> tex-team, because there’s a chance of unforeseen breakage. May I push
> this to the python-team branch?

sure. Please create a new branch, since python-team does not exist
yet. I’ll also push some things I’m working on later and #64573
would probably be a good candidate for python-team too.

Cheers,
Lars
R
R
Ricardo Wurmus wrote on 18 Jul 2023 11:39
(name . Lars-Dominik Braun)(address . lars@6xq.net)
87sf9leewm.fsf@elephly.net
Hi Lars,

Toggle quote (8 lines)
>> After discussing with ngz, we think it’s better to keep this out of
>> tex-team, because there’s a chance of unforeseen breakage. May I push
>> this to the python-team branch?
>
> sure. Please create a new branch, since python-team does not exist
> yet. I’ll also push some things I’m working on later and #64573
> would probably be a good candidate for python-team too.

Okay, I’ve pushed this and #64573 to a new python-team branch and added
a specification on ci.guix.gnu.org to build the branch for x86_64.

--
Ricardo
J
275dbdc0087f7589205b4d1f9c99dea2@dismail.de
Thanks Ricardo,

I'll take a closer look at the Python branch soon. What is the timeline for when the Python branch is expected to be merged into master?

Have we agreed on that timeline somewhere and I missed it?

all best,

jgart
R
R
Ricardo Wurmus wrote on 20 Jul 2023 08:39
(name . jgart)(address . jgart@dismail.de)
874jlzdr1z.fsf@elephly.net
"jgart" <jgart@dismail.de> writes:

Toggle quote (6 lines)
> I'll take a closer look at the Python branch soon. What is the
> timeline for when the Python branch is expected to be merged into
> master?
>
> Have we agreed on that timeline somewhere and I missed it?

No, there’s no plan yet.

I see that the pygments upgrade broke sphinx, so that would be the next
thing to fix.

--
Ricardo
R
R
Ricardo Wurmus wrote on 27 Feb 11:18 +0100
[PATCH] gnu: python-pygments: Update to 2.15.1.
(address . 64503-done@debbugs.gnu.org)
874jduyzuu.fsf@elephly.net
This is on python-team and sphinx has been upgraded too. Closing.

--
Ricardo
Closed
?