[PATCH] gnu: Add emacs-weyland-yutani-theme.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ahmad Draidi
  • Liliana Marie Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
0f8f8a4c05b78c167821db47b704e0864688f0ee.1688676665.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 21aa820f0b..e6bd3ba5d4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35614,6 +35614,28 @@ (define-public emacs-nord-theme
syntax highlighting and UI components.")
(license license:expat)))
+(define-public emacs-weyland-yutani-theme
+ (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
+ (revision "0"))
+ (package
+ (name "emacs-weyland-yutani-theme")
+ (version (git-version "20210802.2251" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jstaursky/weyland-yutani-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gxlz9b7fvbjkqxsyb4l75g7jsxyms0i1vpnb6y499hl115akcaz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jstaursky/weyland-yutani-theme")
+ (synopsis "Emacs theme based on the Alien movie franchise")
+ (description
+ "Weyland Yutani is a dark Emacs theme based on the Alien movie franchise")
+ (license license:gpl3))))
+
(define-public emacs-janet-mode
(let ((commit "2f5bcabcb6953e1ed1926ba6a2328c453e8b4ac7"))
(package

base-commit: 961ffca1c75141cbb351d143b22b673638e9659d
--
2.40.1
Nicolas Goaziou wrote 2 years ago
(name . Ahmad Draidi via Guix-patches via)(address . guix-patches@gnu.org)
87y1jshem7.fsf@nicolasgoaziou.fr
Hello,

Ahmad Draidi via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New
> variable.

Thank you. Some comments follow.

Toggle quote (7 lines)
> +(define-public emacs-weyland-yutani-theme
> + (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
> + (revision "0"))
> + (package
> + (name "emacs-weyland-yutani-theme")
> + (version (git-version "20210802.2251" revision commit))

Base version is actually "0.1", not "20210802.2251", per "Version"
keyword in main file.

Toggle quote (3 lines)
> + (description
> + "Weyland Yutani is a dark Emacs theme based on the Alien movie franchise")

The final full stop is missing.

Toggle quote (2 lines)
> + (license license:gpl3))))

License is actually gpl3+.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
Ahmad Draidi wrote 2 years ago
[PATCH v2] gnu: Add emacs-weyland-yutani-theme.
(address . 64502@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
381a148c0a409134d2b0ac4731363d29df7dc60c.1688704785.git.a.r.draidi@redscript.org
* gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New variable.
---

Comments fixed.

Thanks for the support!

gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 21aa820f0b..94bc9c02ac 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35614,6 +35614,29 @@ (define-public emacs-nord-theme
syntax highlighting and UI components.")
(license license:expat)))
+(define-public emacs-weyland-yutani-theme
+ (let ((commit "e89a63a62e071180c9cdd9067679fadc3f7bf796")
+ (revision "0"))
+ (package
+ (name "emacs-weyland-yutani-theme")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jstaursky/weyland-yutani-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gxlz9b7fvbjkqxsyb4l75g7jsxyms0i1vpnb6y499hl115akcaz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jstaursky/weyland-yutani-theme")
+ (synopsis "Emacs theme based on the Alien movie franchise")
+ (description
+ "Weyland Yutani is a dark Emacs theme based on the Alien movie
+franchise.")
+ (license license:gpl3+))))
+
(define-public emacs-janet-mode
(let ((commit "2f5bcabcb6953e1ed1926ba6a2328c453e8b4ac7"))
(package

base-commit: 961ffca1c75141cbb351d143b22b673638e9659d
--
2.40.1
Liliana Marie Prikler wrote 2 years ago
(name . Andrew Tropin)(address . andrew@trop.in)
325d059b328305ff8fe95492717ad2a0ca3d0085.camel@gmail.com
Am Freitag, dem 07.07.2023 um 08:41 +0400 schrieb Ahmad Draidi:
Toggle quote (5 lines)
> * gnu/packages/emacs-xyz.scm (emacs-weyland-yutani-theme): New
> variable.
> ---
>
> Comments fixed.
Pushed the updated patch.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64502@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64502
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help