[PATCH] gnu: rocm: Update to 5.6.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
John Kehayias
Severity
normal

Debbugs page

John Kehayias wrote 2 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)(name . Lars-Dominik Braun)(address . lars@6xq.net)
87a5w9knl9.fsf@protonmail.com
Hi Guix and Lars (as a known ROCm user and knowledgeable about these packages),

Attached is a patch to update our rocm packages to the new release, 5.6.0. Nothing too major here in terms of packaging updates, was able to get rid of some unneeded patches and did some style updates at the same time. I also did llvm-for-rocm together in one patch/commit this time since I think it makes the most sense to include it as it should match rocm-version as well. I tested everything build locally (x86_64 only) and Darktable OpenCL works with this.

One gotcha I hit I wanted to note for future reference: rocm-comgr had lld (linker from LLVM) as an input which had worked. Until you change the order of the inputs. I guess some collision/conflict with the llvm-for-rocm used to build the package. The errors for 5.6.0 I saw were unable to link to LLVM libraries. Everything works fine removing that input.

Thanks!
John
John Kehayias wrote 2 years ago
Re: bug#64498: [PATCH v2] gnu: rocm: Update to 5.6.0.
(address . 64498@debbugs.gnu.org)(name . Lars-Dominik Braun)(address . lars@6xq.net)
877crclvk4.fsf@protonmail.com
Hello,

On Thu, Jul 06, 2023 at 04:32 PM, John Kehayias wrote:

Toggle quote (18 lines)
> Hi Guix and Lars (as a known ROCm user and knowledgeable about these packages),
>
> Attached is a patch to update our rocm packages to the new release,
> 5.6.0. Nothing too major here in terms of packaging updates, was able
> to get rid of some unneeded patches and did some style updates at the
> same time. I also did llvm-for-rocm together in one patch/commit this
> time since I think it makes the most sense to include it as it should
> match rocm-version as well. I tested everything build locally (x86_64
> only) and Darktable OpenCL works with this.
>
> One gotcha I hit I wanted to note for future reference: rocm-comgr had
> lld (linker from LLVM) as an input which had worked. Until you change
> the order of the inputs. I guess some collision/conflict with the
> llvm-for-rocm used to build the package. The errors for 5.6.0 I saw
> were unable to link to LLVM libraries. Everything works fine removing
> that input.
>

Fixed a minor typo in phase name, here's v2.
Lars-Dominik Braun wrote 2 years ago
Re: [PATCH] gnu: rocm: Update to 5.6.0.
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 64498@debbugs.gnu.org)
ZKr3iFcY1RskVO4l@noor.fritz.box
Hi,

Toggle quote (2 lines)
> Subject: [PATCH] gnu: rocm: Update to 5.6.0.

looks good to me and with the attached patch it even works on my RX 460
(aka gfx803). It still works for you, right?

Cheers,
Lars
Toggle diff (36 lines)
diff --git a/gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch b/gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch
new file mode 100644
index 0000000000..2948234029
--- /dev/null
+++ b/gnu/packages/patches/rocclr-5.6.0-enable-gfx800.patch
@@ -0,0 +1,16 @@
+#From xuhuisheng
+#at https://github.com/RadeonOpenCompute/ROCm/issues/1659#issuecomment-1041026624
+
+diff --git a/utils/flags.hpp b/utils/flags.hpp
+index 8f0228cc..2eaa47c5 100644
+--- a/utils/flags.hpp
++++ b/utils/flags.hpp
+@@ -245,7 +245,7 @@ release(bool, ROC_SYSTEM_SCOPE_SIGNAL, true, \
+ "Enable system scope for signals (uses interrupts).") \
+ release(bool, ROC_SKIP_COPY_SYNC, false, \
+ "Skips copy syncs if runtime can predict the same engine.") \
+-release(bool, ROC_ENABLE_PRE_VEGA, false, \
++release(bool, ROC_ENABLE_PRE_VEGA, true, \
+ "Enable support of pre-vega ASICs in ROCm path") \
+ release(bool, HIP_FORCE_QUEUE_PROFILING, false, \
+ "Force command queue profiling by default") \
diff --git a/gnu/packages/rocm.scm b/gnu/packages/rocm.scm
index 8140b1a46f..e883371928 100644
--- a/gnu/packages/rocm.scm
+++ b/gnu/packages/rocm.scm
@@ -193,7 +193,8 @@ (define rocclr-src
(commit (string-append "rocm-" %rocm-version))))
(sha256
(base32
- "1fzvnngxcvxscn718cqfglm4izccx88zjdr3g5ldfqw7hyd034sk"))))
+ "1fzvnngxcvxscn718cqfglm4izccx88zjdr3g5ldfqw7hyd034sk"))
+ (patches (search-patches "rocclr-5.6.0-enable-gfx800.patch"))))
(define-public rocm-opencl-runtime
(package
John Kehayias wrote 2 years ago
(name . Lars-Dominik Braun)(address . lars@6xq.net)(address . 64498-done@debbugs.gnu.org)
87r0pe1kl3.fsf@protonmail.com
Hi Lars,

On Sun, Jul 09, 2023 at 08:08 PM, Lars-Dominik Braun wrote:

Toggle quote (8 lines)
> Hi,
>
>> Subject: [PATCH] gnu: rocm: Update to 5.6.0.
>
> looks good to me and with the attached patch it even works on my RX 460
> (aka gfx803). It still works for you, right?
>

Yes, that was the patch I had mentioned before but I thought it didn't work for you? Or maybe something else has changed too, but glad it works! And I tested locally for myself with the additional patch and darktable-cltest still works.

I added the patch, adjusted the commit message, registered the patch, and pushed as 15f9870eb36e688fac2af37828971779b6c56916.

Thanks!

John
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64498@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64498
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help