[PATCH 0/3] Update awscli to 1.28.0

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 5 Jul 2023 13:02
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
cover.1688554325.git.roman@burningswell.com
Hi Guix,

this patch series updates awscli to version 1.28.0. I also updated
python-botocore (as mentioned in the awscli package), and python-s3transfer
which was necessary to satisfy a version requirement in awscli.

Could you please review the patches?

Thanks

Roman Scherer (3):
gnu: python-botocore: Update to 1.30.0.
gnu: python-s3transfer: Update to 0.6.1.
gnu: awscli: Update to 1.28.0.

gnu/packages/python-web.scm | 8 ++++----
gnu/packages/python-xyz.scm | 4 ++--
2 files changed, 6 insertions(+), 6 deletions(-)

--
2.40.1
R
R
Roman Scherer wrote on 5 Jul 2023 14:17
[PATCH 1/3] gnu: python-botocore: Update to 1.30.0.
(address . 64474@debbugs.gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
c497e4a2a4cf9ffeaade7768ca8cf7ab4de9af69.1688554325.git.roman@burningswell.com
* gnu/packages/python-xyz.scm (python-botocore): Update to 1.30.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a9df4e6a9..34a6170ae9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16776,14 +16776,14 @@ (define-public python-botocore
;; are compatible.
(package
(name "python-botocore")
- (version "1.24.35")
+ (version "1.30.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "botocore" version))
(sha256
(base32
- "0rv8mvhq5s373zdjs2yb45hzvqcqdh2lp2rbb21jjc8ciwnl5d9n"))))
+ "0gy26zq3s02m1hn3z6cm3fj9l0k933q6cl6q91d63w49l9w5pjxr"))))
(build-system python-build-system)
(arguments
;; FIXME: Many tests are failing.
--
2.40.1
R
R
Roman Scherer wrote on 5 Jul 2023 14:17
[PATCH 2/3] gnu: python-s3transfer: Update to 0.6.1.
(address . 64474@debbugs.gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
a98d9ce156481b95ef26e154dfdb4300ad158d15.1688554325.git.roman@burningswell.com
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.6.1.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d0ac175039..ddce9d504a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4028,13 +4028,13 @@ (define-public python-betamax-serializers
(define-public python-s3transfer
(package
(name "python-s3transfer")
- (version "0.5.0")
+ (version "0.6.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "s3transfer" version))
(sha256
(base32
- "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
+ "1adwmjf8w7s1a948h9xd6lcqhwdpmrm2pxp10l4hqk0zf69b82v4"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.40.1
R
R
Roman Scherer wrote on 5 Jul 2023 14:17
[PATCH 3/3] gnu: awscli: Update to 1.28.0.
(address . 64474@debbugs.gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
6a2b6192f2e306112f03f5c1e0aab61ecb46d91a.1688554325.git.roman@burningswell.com
* gnu/packages/python-web.scm (awscli): Update to 1.28.0.
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ddce9d504a..761343d2ad 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3490,14 +3490,14 @@ (define-public awscli
(package
;; Note: updating awscli typically requires updating botocore as well.
(name "awscli")
- (version "1.22.90")
+ (version "1.28.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "0ky4ax4xh7s8w1l0hwc7w9ii8afvh9nib3kz09qhiqdinxzrlv54"))))
+ "0rmvnwlvr12lgin09gbcppsj21nn6ynfypvcxpsvzmr3vxg1j0qg"))))
(build-system python-build-system)
(arguments
;; FIXME: The 'pypi' release does not contain tests.
--
2.40.1
L
L
Ludovic Courtès wrote on 18 Jul 2023 00:22
Re: bug#64474: [PATCH 0/3] Update awscli to 1.28.0
(name . Roman Scherer)(address . roman@burningswell.com)
87fs5mnpor.fsf@gnu.org
Hi Roman,

Roman Scherer <roman@burningswell.com> skribis:

Toggle quote (6 lines)
> this patch series updates awscli to version 1.28.0. I also updated
> python-botocore (as mentioned in the awscli package), and python-s3transfer
> which was necessary to satisfy a version requirement in awscli.
>
> Could you please review the patches?

This introduces build failures according to

Could you take a look?

Cc’ing Greg Hogan who often takes care of these packages.

Thanks,
Ludo’.
R
R
Roman Scherer wrote on 31 Jul 2023 14:23
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAEc_D2_n78JnOhwBR8JHBDUzQJcXXFkQompTPvuZfNYPtm-CWA@mail.gmail.com
Hi Ludovic,

sorry for the late reply, I was/am traveling. I followed the link but I
don't see/understand where the error is.
Could it be that it disappeared? The badge says QA/unknown. Is there a way
for me to trigger this build again, so I can see the error(s)?

Roman

On Tue, Jul 18, 2023 at 12:22?AM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (21 lines)
> Hi Roman,
>
> Roman Scherer <roman@burningswell.com> skribis:
>
> > this patch series updates awscli to version 1.28.0. I also updated
> > python-botocore (as mentioned in the awscli package), and
> python-s3transfer
> > which was necessary to satisfy a version requirement in awscli.
> >
> > Could you please review the patches?
>
> This introduces build failures according to
> <https://qa.guix.gnu.org/issue/64474>.
>
> Could you take a look?
>
> Cc’ing Greg Hogan who often takes care of these packages.
>
> Thanks,
> Ludo’.
>
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64474@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64474
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch