[PATCH] gnu: python-pymol: Fix launch script.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • David Elsing
Owner
unassigned
Submitted by
David Elsing
Severity
normal

Debbugs page

David Elsing wrote 2 years ago
(address . guix-patches@gnu.org)(name . David Elsing)(address . david.elsing@posteo.net)
ada8c17e2837573be015a05590fd3d55bea0d462.1688419842.git.david.elsing@posteo.net
* gnu/packages/chemistry.scm (python-pymol)[#:phases]: Add ‘disable-unchroot’.
[native-inputs]: Remove python-setuptools.
---
gnu/packages/chemistry.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..1f8b051a85 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2022 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2022, 2023 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -554,6 +554,12 @@ (define-public python-pymol
(assoc-ref inputs "libxml2")
"/include/libxml2:"
(getenv "CPLUS_INCLUDE_PATH")))))
+ ;; Prevent deleting the leading / in the __init__.py path in the
+ ;; launch script.
+ (add-after 'unpack 'disable-unchroot
+ (lambda _
+ (substitute* "setup.py"
+ (("self\\.unchroot") ""))))
;; The setup.py script does not support one of the Python build
;; system's default flags, "--single-version-externally-managed".
(replace 'install
@@ -572,8 +578,7 @@ (define-public python-pymol
python-pyqt
glm
netcdf))
- (native-inputs
- (list catch2 python-setuptools))
+ (native-inputs (list catch2))
(home-page "https://pymol.org")
(synopsis "Molecular visualization system")
(description "PyMOL is a capable molecular viewer and renderer. It can be
--
2.40.1
Andreas Enge wrote 2 years ago
(name . David Elsing)(address . david.elsing@posteo.net)
ZMEq0YnoL_91ridD@jurong
Applied, thanks!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64447@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64447
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help