[PATCH] gnu: Add python-gatspy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
b5ff7de80a80822635df4b8a5376401c49f6d04a.1688396891.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-gatspy): New variable.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 0f3f64b98f..47ea11fa53 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3477,6 +3477,34 @@ (define-public python-pysam
also includes an interface for tabix.")
(license license:expat)))
+(define-public python-gatspy
+ (package
+ (name "python-gatspy")
+ (version "0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gatspy" version))
+ (sha256
+ (base32
+ "1gw2z6x8nikvnw2gkdl70gr81cwczd1pd7v8ry2kjn6k4kssrfav"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:test-flags '(list "-k"
+ ;; These tests require internet access
+ (string-append "not test_download_data.py"
+ " and not test_rrlyrae.py"
+ " and not test_rrlyrae_lightcurves"
+ " and not test_rrlyrae_generated.py"
+ " and not test_lomb_scargle.py"
+ " and not test_supersmoother.py"
+ " and not test_templates.py"))))
+ (propagated-inputs (list python-numpy python-scipy))
+ (native-inputs (list python-pytest python-nose python-setuptools-scm))
+ (home-page "https://github.com/astroml/gatspy")
+ (synopsis "General tools for astronomical time series in Python")
+ (description "General tools for astronomical time series in Python")
+ (license license:bsd-2)))
+
(define-public python-twobitreader
(package
(name "python-twobitreader")

base-commit: 29ccd7cac93da290e1d0466a1d33748ad4ccbf08
prerequisite-patch-id: 2e072dec7e75b2dcc08789c562b9c3f8491fc05f
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 64438-done@debbugs.gnu.org)
875y71t2sy.fsf@elephly.net
Thanks for the patch!

I noticed that some of the tests only failed because we didn’t have
astroML. So I packaged it and added it to the inputs, so now only two
tests are disabled.

Pushed it to the master branch with commit
07f083e94f4f5c5f53e4d8aa644de2064a6256c9.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64438@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64438
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help