Failure with "package-with-extra-configure-variable" & cross-gcc

  • Open
  • quality assurance status badge
Details
One participant
  • Michael Ford
Owner
unassigned
Submitted by
Michael Ford
Severity
normal
M
M
Michael Ford wrote on 3 Jul 2023 14:43
(address . bug-guix@gnu.org)
CAFyhPjX7JqyXhpWpN94s4pE3uaTYWNgHW7mWLNWogY9-NsTPQw@mail.gmail.com
The following is minimised from a manifest we are using to build a
number of cross-compilers, and related packages.

Using what is currently latest Guix:

"guix (GNU Guix) 669f0eaed6310233295fbd0a077afc9ce054c6ab"

and the following manifest:

(use-modules (guix)
(guix build-system gnu)
(gnu packages cross-base))

(define (gcc-with-extra-conf-var gcc)
(package-with-extra-configure-variable gcc "--enable-gcov" "no"))

(packages->manifest
(append
(list
(gcc-with-extra-conf-var (cross-gcc "x86_64-w64-mingw32"))
)
)
)

I see the following build failure:

guix shell --no-substitutes --container -m test.scm
The following derivations will be built:
/gnu/store/z0lgdcw0h7v8d6vjvyb63lpivqlfprvg-profile.drv
/gnu/store/07vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv

building /gnu/store/07vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv...
|builder for `/gnu/store/07vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv'
failed with exit code 1
build of /gnu/store/07vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv
failed
View build log at
'/var/log/guix/drvs/07/vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv.gz'.
cannot build derivation
`/gnu/store/z0lgdcw0h7v8d6vjvyb63lpivqlfprvg-profile.drv': 1
dependencies couldn't be built
guix shell: error: build of
`/gnu/store/z0lgdcw0h7v8d6vjvyb63lpivqlfprvg-profile.drv' failed

cat /var/log/guix/drvs/07/vg6708dqasnpwy2555ks8m6icrpn8h-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0.drv
ice-9/read.scm:126:4: In procedure read-expr*:
/gnu/store/mam4l4yyzks9jxsa60bcd124am81r3f9-gcc-cross-sans-libc-x86_64-w64-mingw32-11.3.0-builder:1:6398:
Unknown # object: "#<"
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64436@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64436
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch