[PATCH] gnu: Add r-dtmm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
e85684e432e5d51c2af92c639a71bffbf4ed7018.1688383652.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-dtmm): New variable.
---
gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f3ea86544d..0f3f64b98f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14644,6 +14644,30 @@ (define-public r-disgenet2r
to retrieve data from DisGeNET v6.0 (Jan, 2019).")
(license license:expat))))
+(define-public r-dtmm
+ (let ((commit "3a553b1e17d27d90a496d2e23e98e5dfe4abc266")
+ (revision "1"))
+ (package
+ (name "r-dtmm")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MaStatLab/DTMM")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19279wafqfs9gk9489f8zsp52qcdb0mkxgvqszq4i733ckr2mmkk"))))
+ (properties `((upstream-name . "DTMM")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape r-rcpp r-rcpparmadillo))
+ (home-page "https://github.com/MaStatLab/DTMM")
+ (synopsis "Dirichlet-tree multinomial mixtures")
+ (description
+ "Dirichlet-tree multinomial mixtures for clustering microbiome compositions.")
+ (license license:cc0))))
+
(define-public r-dyngen
(package
(name "r-dyngen")

base-commit: 29ccd7cac93da290e1d0466a1d33748ad4ccbf08
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 64435-done@debbugs.gnu.org)
87mt0dte2j.fsf@elephly.net
Hi Navid,

thank you for the patch! I applied it and pushed it to Guix with commit
669f0eaed6310233295fbd0a077afc9ce054c6ab after expanding on the
description a little to turn it into a complete sentence.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64435@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64435
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help