[PATCH 0/2] Update xarcan to 0.6.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1688288993.git.a.r.draidi@redscript.org
Hello Guix,

This patch series updates xarcan to 0.6.1, which requires a build system
switch to meson. It also restyles the format since we removed a level of
parenthesis.

Thanks,
Ahmad


Ahmad Draidi (2):
gnu: xarcan: Update to 0.6.1.
gnu: xarcan: Restyle format.

gnu/packages/arcan.scm | 125 +++++++++++++++++++++++------------------
1 file changed, 71 insertions(+), 54 deletions(-)


base-commit: a919a16898e7219fdd26bdfe33a9959e7156d59d
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH 1/2] gnu: xarcan: Update to 0.6.1.
(address . 64412@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
c2c872aee84f1760d6e7a1cb7bd5a43c44955ff6.1688288993.git.a.r.draidi@redscript.org
* gnu/packages/arcan.scm (xarcan): Update to 0.6.1.
[use-modules]: Remove no longer used '(guix build-system gnu)' and add
'(guix build-system meson)'. Add '(gnu packages fonts)',
'(gnu packages onc-rpc)' for new dependencies and '(guix gexp)' for arguments.
[source]: Use version instead of commit, and update hash.
[build-system]: Switch to 'meson-build-system' since this is what's
used upstream now.
[arguments]: Use new configuration flags for the new build system. Switch to
new arguments style.
[inputs]: Add font-dejavu, libtirpc, libxshmfence, xcb-util, xcb-util-wm.
Replace libressl with openssl. Sort inputs by name.
[license]: Add 3-Clause BSD license.
---
gnu/packages/arcan.scm | 95 +++++++++++++++++++++++++-----------------
1 file changed, 57 insertions(+), 38 deletions(-)

Toggle diff (154 lines)
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 7483777ff0..86e9dc4608 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 L p R n d n <guix@lprndn.info>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,7 +20,8 @@
(define-module (gnu packages arcan)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -29,6 +31,7 @@ (define-module (gnu packages arcan)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gl)
@@ -39,6 +42,7 @@ (define-module (gnu packages arcan)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages ocr)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages ruby)
@@ -185,61 +189,76 @@ (define-public arcan-sdl
(synopsis "Combined display server, multimedia framework and game engine (SDL)")))
(define-public xarcan
- (let ((commit "8e6ee029388326cfe5cddeffe482eb3702e9b7f3")
- (revision "1" ))
(package
(name "xarcan")
- (version (git-version "0.5.4" revision commit))
+ (version "0.6.1")
(source
(origin
(method git-fetch)
(file-name (git-file-name name version))
(uri (git-reference
(url "https://github.com/letoram/xarcan")
- (commit commit)))
+ (commit version)))
(sha256
- (base32 "0zng7cs6733mnf0p6g5wv02981f2sf567n56csax6cmzb8fpamym"))))
- (build-system gnu-build-system)
+ (base32 "1z4sf101i2y6rg2vcxfwmp1nkzfa3rw1pp48ym1ds1ka513vy128"))))
+ (build-system meson-build-system)
(arguments
- `(#:configure-flags
- `("--enable-kdrive" "--enable-xarcan"
- "--disable-xorg" "--disable-xwayland"
- "--disable-xnest" "--disable-xvfb"
- "--enable-glamor" "--enable-glx"
- "--disable-int10-module" "--enable-ipv6"
- "--enable-record" "--without-systemd-daemon"
- "--enable-xcsecurity" "--disable-static"
- ,(string-append "--with-xkb-path="
- (assoc-ref %build-inputs "xkeyboard-config")
- "/share/X11/xkb")
- ,(string-append "--with-xkb-bin-directory="
- (assoc-ref %build-inputs "xkbcomp")
- "/bin")
- ,(string-append "--with-xkb-output="
- "/tmp")))) ; FIXME: Copied from xorg
+ (list #:configure-flags #~(list
+ "-Dglamor=true" "-Dint10=false"
+ "-Dipv6=true"
+ "-Dsystemd_logind=false"
+
+ ;; The following arguments were taken from
+ ;; the Xwayland package.
+
+ ;; The build system insist on providing a
+ ;; default font path; give that of dejavu,
+ ;; the same used for our fontconfig package.
+ (string-append "-Ddefault_font_path="
+ (assoc-ref %build-inputs
+ "font-dejavu")
+ "/share/fonts")
+ (string-append "-Dxkb_dir="
+ (assoc-ref %build-inputs
+ "xkeyboard-config")
+ "/share/X11/xkb")
+ (string-append "-Dxkb_bin_dir="
+ (assoc-ref %build-inputs
+ "xkbcomp")
+ "/bin")
+ (format #f
+ "-Dbuilder_string=\"Build ID: ~a ~a\""
+ #$name
+ #$version))))
(native-inputs
(list pkg-config autoconf automake libtool util-macros))
(inputs
- `(("arcan" ,arcan)
- ("font-util" ,font-util)
- ("libdrm" ,libdrm)
- ("libepoxy" ,libepoxy)
- ("libkbfile" ,libxkbfile)
- ("libressl" ,libressl)
- ("libx11" ,libx11)
- ("libxfont2" ,libxfont2)
- ("mesa" ,mesa)
- ("pixman" ,pixman)
- ("xkeyboard-config" ,xkeyboard-config)
- ("xkbcomp" ,xkbcomp)
- ("xorgproto" ,xorgproto)
- ("xtrans" ,xtrans)))
+ (list arcan
+ font-dejavu
+ font-util
+ libdrm
+ libepoxy
+ libtirpc
+ libx11
+ libxfont2
+ libxkbfile
+ libxshmfence
+ mesa
+ openssl
+ pixman
+ xcb-util
+ xcb-util-wm
+ xkbcomp
+ xkeyboard-config
+ xorgproto
+ xtrans))
(home-page "https://arcan-fe.com")
(synopsis "Patched Xserver that bridges connections to Arcan")
(description "Patched Xserver with a KDrive backend that uses the arcan-shmif
to map Xlib/Xcb/X clients to a running arcan instance. It allows running an X session
as a window under Arcan.")
- (license license:expat))))
+ (license (list license:expat
+ license:bsd-3))))
(define-public arcan-wayland
(package
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH 2/2] gnu: xarcan: Restyle format.
(address . 64412@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
d1e8435a115b6623935f46698e5bc6543fb536f8.1688288993.git.a.r.draidi@redscript.org
* gnu/packages/arcan.scm (xarcan): Run 'guix style' over the package.
---
gnu/packages/arcan.scm | 130 ++++++++++++++++++++---------------------
1 file changed, 64 insertions(+), 66 deletions(-)

Toggle diff (147 lines)
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 86e9dc4608..802fe73500 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -189,76 +189,74 @@ (define-public arcan-sdl
(synopsis "Combined display server, multimedia framework and game engine (SDL)")))
(define-public xarcan
- (package
- (name "xarcan")
- (version "0.6.1")
- (source
- (origin
- (method git-fetch)
- (file-name (git-file-name name version))
- (uri (git-reference
- (url "https://github.com/letoram/xarcan")
- (commit version)))
- (sha256
- (base32 "1z4sf101i2y6rg2vcxfwmp1nkzfa3rw1pp48ym1ds1ka513vy128"))))
- (build-system meson-build-system)
- (arguments
- (list #:configure-flags #~(list
- "-Dglamor=true" "-Dint10=false"
- "-Dipv6=true"
- "-Dsystemd_logind=false"
+ (package
+ (name "xarcan")
+ (version "0.6.1")
+ (source (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url "https://github.com/letoram/xarcan")
+ (commit version)))
+ (sha256
+ (base32
+ "1z4sf101i2y6rg2vcxfwmp1nkzfa3rw1pp48ym1ds1ka513vy128"))))
+ (build-system meson-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-Dglamor=true"
+ "-Dint10=false"
+ "-Dipv6=true"
+ "-Dsystemd_logind=false"
- ;; The following arguments were taken from
- ;; the Xwayland package.
+ ;; The following arguments were taken from
+ ;; the Xwayland package.
- ;; The build system insist on providing a
- ;; default font path; give that of dejavu,
- ;; the same used for our fontconfig package.
- (string-append "-Ddefault_font_path="
- (assoc-ref %build-inputs
- "font-dejavu")
- "/share/fonts")
- (string-append "-Dxkb_dir="
- (assoc-ref %build-inputs
- "xkeyboard-config")
- "/share/X11/xkb")
- (string-append "-Dxkb_bin_dir="
- (assoc-ref %build-inputs
- "xkbcomp")
- "/bin")
- (format #f
- "-Dbuilder_string=\"Build ID: ~a ~a\""
- #$name
- #$version))))
- (native-inputs
- (list pkg-config autoconf automake libtool util-macros))
- (inputs
- (list arcan
- font-dejavu
- font-util
- libdrm
- libepoxy
- libtirpc
- libx11
- libxfont2
- libxkbfile
- libxshmfence
- mesa
- openssl
- pixman
- xcb-util
- xcb-util-wm
- xkbcomp
- xkeyboard-config
- xorgproto
- xtrans))
- (home-page "https://arcan-fe.com")
- (synopsis "Patched Xserver that bridges connections to Arcan")
- (description "Patched Xserver with a KDrive backend that uses the arcan-shmif
+ ;; The build system insist on providing a
+ ;; default font path; give that of dejavu,
+ ;; the same used for our fontconfig package.
+ (string-append "-Ddefault_font_path="
+ (assoc-ref %build-inputs
+ "font-dejavu")
+ "/share/fonts")
+ (string-append "-Dxkb_dir="
+ (assoc-ref %build-inputs
+ "xkeyboard-config")
+ "/share/X11/xkb")
+ (string-append "-Dxkb_bin_dir="
+ (assoc-ref %build-inputs
+ "xkbcomp")
+ "/bin")
+ (format #f
+ "-Dbuilder_string=\"Build ID: ~a ~a\""
+ #$name
+ #$version))))
+ (native-inputs (list pkg-config autoconf automake libtool util-macros))
+ (inputs (list arcan
+ font-dejavu
+ font-util
+ libdrm
+ libepoxy
+ libtirpc
+ libx11
+ libxfont2
+ libxkbfile
+ libxshmfence
+ mesa
+ openssl
+ pixman
+ xcb-util
+ xcb-util-wm
+ xkbcomp
+ xkeyboard-config
+ xorgproto
+ xtrans))
+ (home-page "https://arcan-fe.com")
+ (synopsis "Patched Xserver that bridges connections to Arcan")
+ (description
+ "Patched Xserver with a KDrive backend that uses the arcan-shmif
to map Xlib/Xcb/X clients to a running arcan instance. It allows running an X session
as a window under Arcan.")
- (license (list license:expat
- license:bsd-3))))
+ (license (list license:expat license:bsd-3))))
(define-public arcan-wayland
(package
--
2.40.1
Ahmad Draidi wrote 2 years ago
Re: [PATCH 0/2] Update xarcan to 0.6.1.
f3a4707d-4eca-9da2-0e09-3874c5c04f81@redscript.org
On 7/2/23 13:15, Ahmad Draidi wrote:
Toggle quote (5 lines)
> Hello Guix,
>
> This patch series updates xarcan to 0.6.1, which requires a build system
> switch to meson. It also restyles the format since we removed a level of
> parenthesis.
I forgot to mention this patch fails to build since it depends on arcan,
which currently fails to build in Guix. Arcan build is fixed in [1],
which also allows this package to build.
Toggle quote (3 lines)
>
> Thanks,
> Ahmad
Toggle quote (10 lines)
>
> Ahmad Draidi (2):
> gnu: xarcan: Update to 0.6.1.
> gnu: xarcan: Restyle format.
>
> gnu/packages/arcan.scm | 125 +++++++++++++++++++++++------------------
> 1 file changed, 71 insertions(+), 54 deletions(-)
>
>
> base-commit: a919a16898e7219fdd26bdfe33a9959e7156d59d
Maxim Cournoyer wrote 2 years ago
Re: bug#64412: [PATCH 0/2] Update xarcan to 0.6.1.
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 64412-done@debbugs.gnu.org)
87ledkf7y5.fsf_-_@gmail.com
Hi,

Ahmad Draidi <a.r.draidi@redscript.org> writes:

Toggle quote (17 lines)
> On 7/2/23 13:15, Ahmad Draidi wrote:
>> Hello Guix,
>>
>> This patch series updates xarcan to 0.6.1, which requires a build system
>> switch to meson. It also restyles the format since we removed a level of
>> parenthesis.
> I forgot to mention this patch fails to build since it depends on
> arcan, which currently fails to build in Guix. Arcan build is fixed in
> [1], which also allows this package to build.
>>
>> Thanks,
>> Ahmad
> [1] https://issues.guix.gnu.org/64387
>>
>> Ahmad Draidi (2):
>> gnu: xarcan: Update to 0.6.1.

I've changed the (assoc-ref ...) calls into #$(this-package-input ... )
ones.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64412@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64412
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help