(address . guix-patches@gnu.org)(name . Soren Stoutner)(address . soren@stoutner.com)
* gnu/packages/privacybrowser.scm: New file.
---
gnu/packages/privacybrowser.scm | 58 +++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)
create mode 100644 gnu/packages/privacybrowser.scm
Toggle diff (66 lines)
diff --git a/gnu/packages/privacybrowser.scm b/gnu/packages/privacybrowser.scm
new file mode 100644
index 0000000000..e0cf871f85
--- /dev/null
+++ b/gnu/packages/privacybrowser.scm
@@ -0,0 +1,58 @@
+;;; Privacy Browser PC --- A web browser that respects your privacy.
+;;; Copyright © 2023 Soren Stoutner <soren@stoutner.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages privacybrowser)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-systemtools)
+ #:use-module (gnu packages qt))
+
+(define-public privacybrowser
+ (package
+ (name "privacybrowser")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.stoutner.com/privacybrowser-pc/privacybrowser-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1c458n2g4zic5fizn2mir0nah28f0yp7swdyy6xk5hqg7nxk2akc"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list breeze-icons
+ kcrash
+ kdbusaddons
+ khelpcenter
+ ki18n
+ kio
+ knotifications
+ qtsvg-5
+ qtwebengine-5))
+ (home-page "https://www.stoutner.com/privacy-browser-pc/")
+ (synopsis "Web browser that respects your privacy")
+ (description
+ "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security. Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+ (license gpl3+)))
--
2.39.2