[PATCH] gnu: Add privacybrowser.

  • Open
  • quality assurance status badge
Details
4 participants
  • Clément Lassieur
  • Tobias Geerinckx-Rice
  • martin
  • Soren Stoutner
Owner
unassigned
Submitted by
Soren Stoutner
Severity
normal
S
S
Soren Stoutner wrote on 2 Jul 2023 00:49
(address . guix-patches@gnu.org)(name . Soren Stoutner)(address . soren@stoutner.com)
20230701224939.5503-1-soren@stoutner.com
* gnu/packages/privacybrowser.scm: New file.
---
gnu/packages/privacybrowser.scm | 58 +++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)
create mode 100644 gnu/packages/privacybrowser.scm

Toggle diff (66 lines)
diff --git a/gnu/packages/privacybrowser.scm b/gnu/packages/privacybrowser.scm
new file mode 100644
index 0000000000..e0cf871f85
--- /dev/null
+++ b/gnu/packages/privacybrowser.scm
@@ -0,0 +1,58 @@
+;;; Privacy Browser PC --- A web browser that respects your privacy.
+;;; Copyright © 2023 Soren Stoutner <soren@stoutner.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages privacybrowser)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-systemtools)
+ #:use-module (gnu packages qt))
+
+(define-public privacybrowser
+ (package
+ (name "privacybrowser")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.stoutner.com/privacybrowser-pc/privacybrowser-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1c458n2g4zic5fizn2mir0nah28f0yp7swdyy6xk5hqg7nxk2akc"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list breeze-icons
+ kcrash
+ kdbusaddons
+ khelpcenter
+ ki18n
+ kio
+ knotifications
+ qtsvg-5
+ qtwebengine-5))
+ (home-page "https://www.stoutner.com/privacy-browser-pc/")
+ (synopsis "Web browser that respects your privacy")
+ (description
+ "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security. Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+ (license gpl3+)))
--
2.39.2
S
S
Soren Stoutner wrote on 24 Jul 2023 18:16
Next step?
(address . 64408@debbugs.gnu.org)
2582765.uRsfM6caOx@soren-desktop
What is the next step to get Privacy Browser added to Guix?

--
Soren Stoutner
soren@stoutner.com
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmS+o+0ACgkQwufLJ66w
tgMNTA/+NS2tE+jyoKeUHXHEDw/nDjVVWgZxSn4KivtpFW29ZspTI+UYp50XlPbN
5ew7D06hz757G+/pMM3s1F00DTBHNEdj31gTTodjJII2bxamvynyPk8oPilAzJq7
qR72XWj+OLxfcEGNDwpTMQ/MbfZa3rGNGtDY089rpWpu0QaMzLqb846qgdAqKH03
Wl4Xw9A90eLN1VEC+nS6lfByuXBA7hISae30KRTcrRoJ+xu5mbssbPmOE5lOMX21
NYOiDbTfBFhsUXEPf5q5chi5iqhDLduVva4MNA3GRmxX1P2mhihMQ5CW95+RdlhQ
o1GUDNB6k5cUIDNT63KVRZ+36QLmbO9gaYq7iMzDD63GtdAX2zrJmvnAw49bRMbR
gxI9/Hr27+FhnRFjsX0swFPsGih82HeOSarplI5i9S1vGhDTd3JQTf2kYkyKuBqx
bACF4CItDpgOqxDJjiWHMdAK15/sVxc9G1WbOyU44U5YeuO7FhWAjenO//Tlb8t5
v9hNfazcxxakM2Qej/nYROp6c026ChHFWYX+HM7fnZEIxoX/gWhfMPEvWQ1bZMyh
Hbb4KtNhSJayuAuqG/9CbUw5HA98nE/z+7VQNhtVGf2iXeRuGUfJ+kW1u6vocXq4
WCUD6P7wFFdek1tUfiXu5HQ8/9/GIWNGyra5wLNJoIcg8L37/0I=
=DUCD
-----END PGP SIGNATURE-----


T
T
Tobias Geerinckx-Rice wrote on 16 Aug 2023 21:08
Re: [PATCH] gnu: Add privacybrowser.
(address . 64408@debbugs.gnu.org)
b56561905ea0f95ad26c4516eace02b0@tobias.gr
Hi Soren,

Thanks for the patch! It looks good, but I wonder about ‘khelpcenter’.

Notably, it doesn't enable the ‘Help’ → ‘Privacy Browser Handbook’.
That prints

kf.guiaddons: Could not find a suitable handler for "help:/"

in the console and does nothing in the GUI. Is this something that
could be fixed?

If it's something that requires a full(er) KDE installation, does adding
‘khelpcenter’ make a difference? It doesn't for me.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
M
M
martin wrote on 29 Aug 2023 00:05
Availability in Guix Soon?
(address . 64408@debbugs.gnu.org)
trinity-79e6879b-07c3-4226-aebf-1ea69dfc5bf0-1693260354255@3c-app-mailcom-bs05
Attachment: file
S
S
Soren Stoutner wrote on 16 Oct 2023 19:44
[PATCH] gnu: Add privacybrowser.
(address . 64408@debbugs.gnu.org)
2308775.AYvPD9mGtg@soren-desktop
I apologize for not responding sooner. I assumed that when someone commented
on the issue I would receive an email, but either it never came or I missed it
somehow.

KHelpCenter is required to be able to open the Handbook (press F1 inside of
the program). There is a lot of important information in the Handbook that
users of Privacy Browser would benefit reading.

--
Soren Stoutner
soren@stoutner.com
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmUtdpAACgkQwufLJ66w
tgPpbg/+Ph8Z1xnnmH3VM2jS0atvEyXj4pGDW5q+MSmnpeLTHwz1fROPL2RyBSGS
JqtCrJQ0nSJ6DaoJBhIZ8BcY6jXLdTC8TkLkRtWj05d6NG3ivv0aYgHNhJCA0opM
yGsX14VVD8KbdtKHETYpD2514HGfinX7KjdXlnNYC3qOHWxlQ9o0SDGNk62ux6gx
Pavz+V7kB4XMK4pG6FsVf/q1qw+tfjQfiPl7oUinhA1Lf+U5C6kAZ9OxgJGnOXYC
Ow2r+SklMLBmdA8iqOY2T75S7TuL9S8jVeTZBavyQ7g49NtnY96p0nJ92G9VLjA7
RUDPMkL3k4cNsxANIdQ+s0GpWHVTlJG2U3Gpq7ShykWCu3/b7QX6Swt6C4QYIgUy
x5uB3f1otv6AvIBdiduxdqhat/itvq4U8Tgmg/uN0Z1v9ePo/3VVP99glnB1tRBE
ynymoeRXZmfBgizKgA3cNq0zEH/WDIXDpxT/l5SnKsrIDfbTAONKGO+CZIi01GgF
YfWfnK0TEIuEOlJswQ91KOud2Hj7hLBMmqFvM0Ket0RZ6vz7pmYoQ4vjrx+JtPIF
k0uI4r513E+SA9nFV5Lyr1u7/0hsY3rI21XF2g33yvPbKfzf1Zt2w+JguzuVmeSt
hDYL49OCPjXCl6yaVbWkcy204b+Pojzji08cScLkk1i9RT4n9XI=
=HY9D
-----END PGP SIGNATURE-----


S
S
Soren Stoutner wrote on 16 Oct 2023 21:12
(address . 64408@debbugs.gnu.org)
15719859.c1JmnpQEJM@soren-desktop
Note that for KHelpCenter to function, it must be specified at runtime. For
example:

guix shell privacybrowser khelpcenter -- privacybrowser

It seems there are a few missing icons and there are some warnings written to
the console. I assume that relates to some deficiency in the KHelpCenter
package. But all the text of the Handbook can be read.

--
Soren Stoutner
soren@stoutner.com
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmUtiwwACgkQwufLJ66w
tgN7VQ/+NQonKjkjL2N/DA7BdwuxtNqFMq88ITk0BIYPAvVb6+tI6t70BljlQgno
kmpBn+noNeWmp2LdwRloiTWQ/uPgZSY3aUUvp8tjGeGbMSwLkCSo2tvHaW8A5Hgd
7X6c6PcNWp4OWC6m5FH2iQqICQahJ1RehxOIu+6m5NmfBv2C3lXrppU9UE7a6a5W
loPDvftpf9J69a2eowUIotDSpmnCpOOH8nm47Lj4iaWXGfxTpPZGHeAfHI8Dy/HB
GKPZz4iYwebE7UwjdSEhop4B/rdlAFhAdMA/6fFVP1BVBok7gHAjnq/cWXVw9MBR
Cn9xfW0TkcxYsG1sXM3S4rsHOVAiLzUVKDPHm2MqYNn6pc37tBQ1OJ0qvkzuyEsg
ZRVV0MteQdtlnWthf644fNzxVMkpKBXROJDebROi3Jv+I0UFvw6to3zXlduf/KTq
IxFVRtWINVbJSrYYyudvZNGuwzpv/go8RbXmFcIcXlHScYiARPbHYmcbh/Mwk/1b
EvYbvyYOBlfG7VPfLKlU2IH2P+U1jP5t1ImvDMPteeYcD3A/hiZE4mXRgMe+UA+C
4uF1B7Rfg3Isaug74pL22hjZ3I49JYhXRlMWwYGA+vxY3dCFzaTiuYkE2v79la6Z
A66V0vZJ0q73C457tg/CmOSdzoFgJo5XAsZ6Mw8JD/1InVGV9ho=
=88F7
-----END PGP SIGNATURE-----


S
S
Soren Stoutner wrote on 17 Oct 2023 20:01
(address . 64408@debbugs.gnu.org)
14031887.Zlvoba7YER@soren-desktop
Privacy Browser 0.5 has been released. Attached is an updated patch.

--
Soren Stoutner
soren@stoutner.com
From d5358a483d55c54573b336b297ae3728fbcff029 Mon Sep 17 00:00:00 2001
Message-Id: <d5358a483d55c54573b336b297ae3728fbcff029.1697564327.git.soren@stoutner.com>
From: Soren Stoutner <soren@stoutner.com>
Date: Tue, 17 Oct 2023 10:30:53 -0700
Subject: [PATCH] gnu: Add Privacy Browser.

* gnu/packages/privacybrowser.scm: New file.
---
gnu/packages/privacybrowser.scm | 58 +++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)
create mode 100644 gnu/packages/privacybrowser.scm

Toggle diff (68 lines)
diff --git a/gnu/packages/privacybrowser.scm b/gnu/packages/privacybrowser.scm
new file mode 100644
index 0000000000..6ae7247ed0
--- /dev/null
+++ b/gnu/packages/privacybrowser.scm
@@ -0,0 +1,58 @@
+;;; Privacy Browser PC --- A web browser that respects your privacy.
+;;; Copyright © 2023 Soren Stoutner <soren@stoutner.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages privacybrowser)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-systemtools)
+ #:use-module (gnu packages qt))
+
+(define-public privacybrowser
+ (package
+ (name "privacybrowser")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.stoutner.com/privacybrowser-pc/privacybrowser-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "1rywfmmw535bs0h3i4yrif3xmz2a4flp04bmhqdlbri4h1pk7x2y"))))
+ (build-system qt-build-system)
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list breeze-icons
+ kcrash
+ kdbusaddons
+ khelpcenter
+ ki18n
+ kio
+ knotifications
+ qtsvg-5
+ qtwebengine-5))
+ (home-page "https://www.stoutner.com/privacy-browser-pc/")
+ (synopsis "Web browser that respects your privacy")
+ (description
+ "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security. Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+ (license gpl3+)))

base-commit: b437896e87a51cc610388d4c462893652dd773e6
--
2.39.2
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmUuzAsACgkQwufLJ66w
tgP4jxAAgHaCVyuA8HIcyY0UHwLmnWLIKM3nCL+SKArekRnqSAkrOyc7u7DwFnJn
tbh3I3mmVVXJpyB3Nx7A2n0Qw4AxGucV6h6O6BXPq+eoHPstcu0r/vetncqeOx61
QUrxjr0jVQezgSzlgy7LCJg0Py4jBrt1NikcssvM6X+eIpyOHYckckdv9WhtQ1Yu
YMFpbG5F4FHAzdZabHyAziTC7g5dEb6xAWaFn7Pg8LolluRGUng+QU+FWjSfuA34
Tl/eSlZ/dgRkzI1kAQXP5aKaFdfUbQRGHzyvuYvrsdiSs3qhXK7OnjSiiqMknUsS
QFJg3+8pss3BGpWiUQsI0N+NrPvp8HOUD11l6hrnaIeP0Aejj3Jqvosu3VnHQ9gh
ViWRUneTlPLkZmqTCaKwOezUuZB1JgS1MuQz2C23DPiCe/jmzU9JY6doWKAvCfYm
jkr0RiUgPFUTquGXI/2WsEo9nwsgaWDcfN7TsXJWTsOsKZQYusNDsO4Dzfp1/mPm
1yjsP9A4VEGNok0VwlpdH+Skp1DZalaPKkPae7GLyRD+PfNZ3LIMZDLMOtzF8AlW
oHZAzbmxwi06X3A1HIgFsMdep9Qx0GswaWHudQwSyOPhG1ZmiwPMI8F6HgG1u4Dr
MKpPpc5auy99aneTD2zltqVCVQLwCa79man/xRe/D8i6fqNbah8=
=cmf+
-----END PGP SIGNATURE-----


C
C
Clément Lassieur wrote on 13 Jan 11:45 +0100
(name . Soren Stoutner)(address . soren@stoutner.com)
87bk9pikaz.fsf@lassieur.org
Hi,

Thank you for this patch.

On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:

Toggle quote (5 lines)
> Note that for KHelpCenter to function, it must be specified at runtime. For
> example:
>
> guix shell privacybrowser khelpcenter -- privacybrowser

Maybe it should be a propagated input then?


Also does it have to be in a specific file? I imagine it could fit in
qt.scm?

Thanks,
Clément
S
S
Soren Stoutner wrote on 13 Jan 18:49 +0100
(name . Clément Lassieur)(address . clement@lassieur.org)
9169996.dMYhFxK67x@soren-desktop
Clément

On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
Toggle quote (2 lines)
> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
> > Note that for KHelpCenter to function, it must be specified at runtime.
For
Toggle quote (6 lines)
> > example:
> >
> > guix shell privacybrowser khelpcenter -- privacybrowser
>
> Maybe it should be a propagated input then?

How is that done?

Toggle quote (3 lines)
> Also does it have to be in a specific file? I imagine it could fit in
> qt.scm?

You can put it wherever it makes the most sense. If you would like to place
it inside of another scm, I would imagine that web-browsers.scm is probably
the most logical location.

--
Soren Stoutner
soren@stoutner.com
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmWizSsACgkQwufLJ66w
tgN6WA/+N57/cVDX2t6l738jEVlOAtjqgDoAKWgZ2pDHMpUVwrPGy01eyTwE0bGk
ZZwsYH52hCg2CvySFOhPKxGQj3pUvoyTdzl0w/tn6ui16wibJ1wn6ig5/ZmzbubD
nZQtIKMv+6okDC1vPJRiKbBX3aprNH0xVKjXXSURbClRI95NdZafINmOA9CqSrAX
Cv9C3sYO8sTA0nBT+lXfj5QPHPDN/QciCVPkgHJY0MwIQqAPqRX4k9vdN8B7yU2v
dKMB8Y6yJY+y89tVgq+100WRNr9ozaVp3i3vV/R8U9vWW3tS5xHy5d1k5/bEj8LZ
ui4z/foAFBPoSF83DHmSE3UjgjVfVjIpk0X/U9yG+LFXkIr8aIJTvdOkluxVS5tv
seEUk5wm3eip4PW8kCuQbn9XuXDrrFFKa1nB61Pz9x3KEqnZRqaJ7JLv+/YR5c9S
RT7yehCtJdoLQL6Yf02oe0z6FA/8vSAD7NpS/CxyyjIUvi/Wa7AYRR6plqgtmDpN
etmQxZdOejd08knxZcY1ej2O9m5dje3uucKKKaa9Zn0A1oKUUF6mbR7+Rew5Gc3H
Qn8nSoeOpN54MW/8m9RmJvUy4lhSIjhXwPpN/m7ljJ0CdQpdenma9uVYUuQYjMF5
oBNsvvwrZnKUNTrysjeOrDGjc8sGx8FmDfaD1PdlQTYO9WuFwnE=
=ge4J
-----END PGP SIGNATURE-----


C
C
Clément Lassieur wrote on 14 Jan 10:17 +0100
(name . Soren Stoutner via Guix-patches via)(address . guix-patches@gnu.org)
87le8ss29f.fsf@lassieur.org
On Sat, Jan 13 2024, Soren Stoutner via Guix-patches via wrote:

Toggle quote (12 lines)
> Clément
>
> On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
>> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
>> > Note that for KHelpCenter to function, it must be specified at runtime.
> For
>> > example:
>> >
>> > guix shell privacybrowser khelpcenter -- privacybrowser
>>
>> Maybe it should be a propagated input then?

You use the propagated-inputs field instead of the inputs field. The
consequence is that installing "PrivacyBrowser" will install the
propagated inputs too. Same with "guix shell". So "guix shell
privacybrowser -- privacybrowser" will work.

Toggle quote (9 lines)
> How is that done?
>
>> Also does it have to be in a specific file? I imagine it could fit in
>> qt.scm?
>
> You can put it wherever it makes the most sense. If you would like to place
> it inside of another scm, I would imagine that web-browsers.scm is probably
> the most logical location.

Indeed, sounds like the right place.

Can you send an updated patch?
S
S
Soren Stoutner wrote on 23 Jan 06:59 +0100
5746518.DvuYhMxLoT@soren-desktop
Attached is an updated patch.

On Sunday, January 14, 2024 2:17:00 AM MST Clément Lassieur wrote:
Toggle quote (26 lines)
> On Sat, Jan 13 2024, Soren Stoutner via Guix-patches via wrote:
> > Clément
> >
> > On Saturday, January 13, 2024 3:45:08 AM MST Clément Lassieur wrote:
> >> On Mon, Oct 16 2023, Soren Stoutner via Guix-patches via wrote:
> >> > Note that for KHelpCenter to function, it must be specified at runtime.
> >
> > For
> >
> >> > example:
> >> >
> >> > guix shell privacybrowser khelpcenter -- privacybrowser
> >>
> >> Maybe it should be a propagated input then?
>
> You use the propagated-inputs field instead of the inputs field. The
> consequence is that installing "PrivacyBrowser" will install the
> propagated inputs too. Same with "guix shell". So "guix shell
> privacybrowser -- privacybrowser" will work.
>
> > How is that done?
> >
> >> Also does it have to be in a specific file? I imagine it could fit in
> >> qt.scm?
> >
> > You can put it wherever it makes the most sense. If you would like to
place
Toggle quote (1 lines)
> > it inside of another scm, I would imagine that web-browsers.scm is
probably
Toggle quote (7 lines)
> > the most logical location.
>
> Indeed, sounds like the right place.
>
> Can you send an updated patch?


--
Soren Stoutner
soren@stoutner.com
From e194cdf0955c66f2eb2d41cece5b8e4c0ed465b3 Mon Sep 17 00:00:00 2001
Message-Id: <e194cdf0955c66f2eb2d41cece5b8e4c0ed465b3.1705989200.git.soren@stoutner.com>
From: Soren Stoutner <soren@stoutner.com>
Date: Mon, 22 Jan 2024 22:48:55 -0700
Subject: [PATCH] gnu: privacybrowser: Add Privacy Browser 0.5.

* gnu/packages/web-browsers.scm: (privacybrowser): Add Privacy
Browser 0.5.

Change-Id: I4e8d624ef10acb15a6d699f4b9432e6bce4e1322
---
gnu/packages/web-browsers.scm | 41 +++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 71289dbb2b..4d0f1c1ea5 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
+;;; Copyright © 2023-2024 Soren Stoutner <soren@stoutner.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,7 @@ (define-module (gnu packages web-browsers)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -73,6 +75,8 @@ (define-module (gnu packages web-browsers)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-systemtools)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libunistring)
@@ -458,6 +462,43 @@ (define-public kristall
;; for breeze-stylesheet
license:expat)))))
+(define-public privacybrowser
+ (package
+ (name "privacybrowser")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.stoutner.com/"
+ "privacybrowser-pc/privacybrowser-" version
+ ".tar.xz"))
+ (sha256
+ (base32 "1rywfmmw535bs0h3i4yrif3xmz2a4flp04bmhqdlbri4h1pk7x2y"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules))
+ (inputs
+ (list breeze-icons
+ kcrash
+ kdbusaddons
+ khelpcenter
+ ki18n
+ kio
+ knotifications
+ qtsvg-5
+ qtwebengine-5))
+ (propagated-inputs
+ (list khelpcenter))
+ ; khelpcenter needs to be propagates so that F1 work inside
+ ; privacybrowser.
+ (home-page "https://www.stoutner.com/privacy-browser-pc/")
+ (synopsis "Web browser that respects your privacy")
+ (description "Privacy Browser is a web browser based on Qt WebEngine
+with a focus on privacy and security. Features like JavaScript and
+cookies are disabled by default but are easy to automatically enable
+on-the-fly or by domain.")
+ (license license:gpl3+)))
+
(define-public qutebrowser
(package
(name "qutebrowser")

base-commit: f7c0ccb1866b559dc2ce0c538d10a150822824c8
--
2.39.2
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEJKVN2yNUZnlcqOI+wufLJ66wtgMFAmWvVbcACgkQwufLJ66w
tgMlrhAAhQmUGQh4oqVZLPdG1wQSgf/P9Q4yX8L0kuVg1JAT8TSI91RpnA3Twy+u
XViODRgUpMfaL3Vb/KZ0A9Z/rFanI9L1aPH6bosVkyUc8c5D0UOMhsQwZVr665jf
JMHAlUEyKSFWFZb0Oqmt919KyLrMzhZQkaFILH9KZ+A0fpivY6h/1Ygnk3ceM/FQ
FHnkoKy5okFIZ++e+DgJzjjdGAs3+ZmX/d5jXH9AsIb4CS0McH3Om/za9jrEI8mB
qheQJlirjqSEgv+6vdybuZ/tlzbaU99bvJ7/tPhqxWPmNuP07YbkeXyVUKHUPOxl
SkvyYyidxjUvNbpGtZA+QaNFfO9WLvS4FxA2c1Ubc5+ea36S2o1D+AyFWcyYijTh
xJ0f4mLFs9c9guwH6x5+FvKSQIzBPeGJnNK4QaMeXZgWzOczrDUljjDjRT2cIJ2+
fG9E2uxUDs8eqYc3n4edxdQjnvWe2giFDMDEEh8ER/ECZolqj4X5I95w2JeJwRqk
0vJnloV1E06XZZsUcCX5zxrCalcpJ85Acx50QMt4XBE3YEqBQi5Jm7CHfKwLktVW
bZTH3qDsApeCDN4cBB6cXMlSCLayCC+C0pDipfRHYSXQw/vi2Ejnalyl/t59XtFM
Lp9mlGzSS/SCH2gMhfCYUJBh/W7MhvABRXf8hwE1aEq4uOeMf/w=
=XgAB
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64408@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64408
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch