[PATCH] gnu: ardour: Update to 7.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 2 years ago
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
d0bfbab5a54924ecb9d780ab17fba4fea1457063.1688154760.git.sughosha@disroot.org
* gnu/packages/audio.scm (ardour): Update to 7.5.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 88dbbbc7a2..550f653420 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -738,7 +738,7 @@ (define (ardour-rpath-phase major-version)
(define-public ardour
(package
(name "ardour")
- (version "7.4")
+ (version "7.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -755,7 +755,7 @@ (define-public ardour
namespace ARDOUR { const char* revision = \"" version "\" ; const char* date = \"\"; }")))))
(sha256
(base32
- "0v66h9fghjyjinldw9yfhhlfi3my235x6n4dpxx432z35lka2h89"))
+ "18pgxnxfp0pqsy24cmf3hanr6vh0pnimsh48x5nfbflqy7ljsrkj"))
(file-name (string-append name "-" version))))
(build-system waf-build-system)
(arguments

base-commit: a98126e604b666d08a4c9d838bf9c341acea7f17
--
2.40.1
Sughosha wrote 2 years ago
[PATCH v2 1/3] gnu: ardour: Update to 7.5.
(address . 64374@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
d0bfbab5a54924ecb9d780ab17fba4fea1457063.1688416868.git.sughosha@disroot.org
* gnu/packages/audio.scm (ardour): Update to 7.5.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 88dbbbc7a2..550f653420 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -738,7 +738,7 @@ (define (ardour-rpath-phase major-version)
(define-public ardour
(package
(name "ardour")
- (version "7.4")
+ (version "7.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -755,7 +755,7 @@ (define-public ardour
namespace ARDOUR { const char* revision = \"" version "\" ; const char* date = \"\"; }")))))
(sha256
(base32
- "0v66h9fghjyjinldw9yfhhlfi3my235x6n4dpxx432z35lka2h89"))
+ "18pgxnxfp0pqsy24cmf3hanr6vh0pnimsh48x5nfbflqy7ljsrkj"))
(file-name (string-append name "-" version))))
(build-system waf-build-system)
(arguments

base-commit: a98126e604b666d08a4c9d838bf9c341acea7f17
--
2.40.1
Sughosha wrote 2 years ago
[PATCH v2 2/3] gnu: ardour: Install bundled MIDI loops.
(address . 64374@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
525fecd2e07fd9e513af675ecae52cde0911cc62.1688416868.git.sughosha@disroot.org
* gnu/packages/audio.scm (ardour)[#:phases]: Add install-bundled-media.
[native-inputs]: Add unzip.
[license]: Add cc0 and expat.
---
gnu/packages/audio.scm | 24 +++++++++++++++++++++---
1 file changed, 21 insertions(+), 3 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 550f653420..25fa8acf33 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -735,6 +735,14 @@ (define (ardour-rpath-phase major-version)
libdir "/surfaces" ":"
libdir "/vamp" "\"]"))))))
+(define ardour-bundled-media
+ (origin
+ (method url-fetch)
+ (uri "http://stuff.ardour.org/loops/ArdourBundledMedia.zip")
+ (sha256
+ (base32
+ "0k135sm559yywfidrya7h5cddwqa2p2abhimrar2khydf43f03d0"))))
+
(define-public ardour
(package
(name "ardour")
@@ -793,7 +801,14 @@ (define-public ardour
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(install-file "ardour.1" (string-append (assoc-ref outputs "out")
- "/share/man/man1")))))
+ "/share/man/man1"))))
+ (add-after 'install 'install-bundled-media
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "unzip" "-d" (string-append (assoc-ref outputs "out")
+ "/share/ardour"
+ ,(version-major version)
+ "/media/")
+ ,ardour-bundled-media))))
#:test-target "test"))
(inputs
(list alsa-lib
@@ -848,14 +863,17 @@ (define-public ardour
gettext-minimal
itstool
perl
- pkg-config))
+ pkg-config
+ unzip))
(home-page "https://ardour.org")
(synopsis "Digital audio workstation")
(description
"Ardour is a multi-channel digital audio workstation, allowing users to
record, edit, mix and master audio and MIDI projects. It is targeted at audio
engineers, musicians, soundtrack editors and composers.")
- (license license:gpl2+)))
+ (license (list license:gpl2+
+ license:cc0 ;used by MIDI Beats
+ license:expat)))) ;used by MIDI Chords and Progressions
(define-public audacity
(package
--
2.40.1
Sughosha wrote 2 years ago
[PATCH v2 3/3] gnu: ardour: Move ardour-rpath-phase inside this definition.
(address . 64374@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
7d3a663f9e847009e20a2161227faa33daca91df.1688416868.git.sughosha@disroot.org
* gnu/packages/audio.scm (ardour)[#:phases]: Move ardour-rpath-phase
inside this definition.
(ardour-rpath-phase): Delete variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++----------------
1 file changed, 14 insertions(+), 16 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 25fa8acf33..b08827b133 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -720,21 +720,6 @@ (define-public qm-dsp
purposes developed at Queen Mary, University of London.")
(license license:gpl2+)))
-(define (ardour-rpath-phase major-version)
- `(lambda* (#:key outputs #:allow-other-keys)
- (let ((libdir (string-append (assoc-ref outputs "out")
- "/lib/ardour" ,major-version)))
- (substitute* "wscript"
- (("linker_flags = \\[\\]")
- (string-append "linker_flags = [\""
- "-Wl,-rpath="
- libdir ":"
- libdir "/backends" ":"
- libdir "/engines" ":"
- libdir "/panners" ":"
- libdir "/surfaces" ":"
- libdir "/vamp" "\"]"))))))
-
(define ardour-bundled-media
(origin
(method url-fetch)
@@ -776,7 +761,20 @@ (define-public ardour
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-rpath-in-LDFLAGS
- ,(ardour-rpath-phase (version-major version)))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((libdir (string-append (assoc-ref outputs "out")
+ "/lib/ardour"
+ ,(version-major version))))
+ (substitute* "wscript"
+ (("linker_flags = \\[\\]")
+ (string-append "linker_flags = [\""
+ "-Wl,-rpath="
+ libdir ":"
+ libdir "/backends" ":"
+ libdir "/engines" ":"
+ libdir "/panners" ":"
+ libdir "/surfaces" ":"
+ libdir "/vamp" "\"]"))))))
(add-after 'install 'install-freedesktop-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.40.1
宋文武 wrote 2 years ago
Re: bug#64374: [PATCH] gnu: ardour: Update to 7.5.
(name . Sughosha)(address . sughosha@disroot.org)(address . 64374-done@debbugs.gnu.org)
87r0p5xv3m.fsf_-_@envs.net
Sughosha <sughosha@disroot.org> writes:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (ardour): Update to 7.5.

Pushed to master, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64374@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64374
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help