(address . guix-patches@gnu.org)
* gnu/packages/python-xyz.scm (python-wand)[arguments]<#:phases>: Pass tests?
to 'check.
Reported-by: Thorsten Wilms <t_w_@freenet.de>
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4105c4685..bf0ccfe07b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2445,7 +2445,7 @@ (define-public python-wand
(setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
(setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs
base-commit: 94ac93042f09b4ba68b7b64ed1feeebd3dab1ea4
--
2.40.1