[PATCH] gnu: python-wand: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Bruno Victal
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 30 Jun 2023 09:56
(address . guix-patches@gnu.org)
45dbedbb4a398f7aa1f857e4944aaa6d721b78fa.1688111652.git.hako@ultrarare.space

* gnu/packages/python-xyz.scm (python-wand)[arguments]<#:phases>: Pass tests?
to 'check.

Reported-by: Thorsten Wilms <t_w_@freenet.de>
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4105c4685..bf0ccfe07b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2445,7 +2445,7 @@ (define-public python-wand
(setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
(setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs

base-commit: 94ac93042f09b4ba68b7b64ed1feeebd3dab1ea4
--
2.40.1
H
H
Hilton Chain wrote on 17 Jul 2023 14:43
[PATCH v2] gnu: python-wand: Honor #:tests? argument.
(address . 64361@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
a26b81e92e1415911c209c5e5ffc779bcff4e959.1689597664.git.hako@ultrarare.space

* gnu/packages/python-xyz.scm (python-wand)[arguments]<#:phases>: Pass keyword
argument #:tests? to 'check.

Reported-by: Thorsten Wilms <t_w_@freenet.de>
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 973216c5ed..f07ae0b1f9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2446,7 +2446,7 @@ (define-public python-wand
(setenv "MAGICK_HOME" (assoc-ref inputs "imagemagick"))
(setenv "WAND_MAGICK_LIBRARY_SUFFIX" ".Q16")))
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs

base-commit: ad08f9331fee7a8e71e94b02f86f54ab3e1001a8
--
2.41.0
B
B
Bruno Victal wrote on 19 Jul 2023 06:45
(name . Hilton Chain)(address . hako@ultrarare.space)
14fa06c8-e204-f451-b21e-22ac4a751248@makinata.eu
Fixed with 13cb9b302868b5a966a6ae177412c474084f4bf1.

--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64361@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64361
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch