Orca screenreader crashes on start

  • Open
  • quality assurance status badge
Details
One participant
  • Nathan Dehnel
Owner
unassigned
Submitted by
Nathan Dehnel
Severity
normal
N
N
Nathan Dehnel wrote on 29 Jun 2023 22:56
(name . bug-guix)(address . bug-guix@gnu.org)
CAEEhgEsrFJ5Q9Raa6siXPefDrS03SPrZ-C+d2UB5tkzYKNZDuw@mail.gmail.com
guix ac86174

/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/module.py:163:
Warning: cannot register existing type 'AtkImplementorIface'
g_type = info.get_g_type()
/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/module.py:197:
Warning: g_type_get_qdata: assertion 'node != NULL' failed
type_ = g_type.pytype
/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/types.py:247:
Warning: cannot register existing type 'AtkImplementorIface'
register_interface_info(cls.__info__.get_g_type())
Traceback (most recent call last):
File "/gnu/store/8kfgp7rsls97yrv06d7dgzcgmdcyji5z-orca-42.3/bin/.orca-real",
line 32, in <module>
import pyatspi
File "/gnu/store/5fy25w379g86rdkkrck6bga946n4g275-python-pyatspi-2.45.90/lib/python3.10/site-packages/pyatspi/__init__.py",
line 20, in <module>
from gi.repository import Gtk
File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 672, in _load_unlocked
File "<frozen importlib._bootstrap>", line 632, in _load_backward_compatible
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/importer.py",
line 150, in load_module
dynamic_module = load_overrides(introspection_module)
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/overrides/__init__.py",
line 118, in load_overrides
override_mod = importlib.import_module(override_package_name)
File "/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/lib/python3.10/importlib/__init__.py",
line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/overrides/Gtk.py",
line 111, in <module>
class Widget(Gtk.Widget):
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/module.py",
line 168, in __getattr__
interfaces = tuple(interface for interface in
get_interfaces_for_object(info)
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/module.py",
line 94, in get_interfaces_for_object
interfaces.append(getattr(module, name))
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/module.py",
line 207, in __getattr__
wrapper = metaclass(name, bases, dict_)
File "/gnu/store/c6n7h131fdckr39yv1rc7z9fbm0yk177-python-pygobject-3.42.2/lib/python3.10/site-packages/gi/types.py",
line 247, in __init__
register_interface_info(cls.__info__.get_g_type())
TypeError: must be an interface
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 64357@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64357
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch