[PATCH] gnu: fluxbox: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 2 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20230629185906.22211-1-dannym@scratchpost.org
* gnu/packages/patches/fluxbox-1.3.7-gcc.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/wm.scm (fluxbox)[source](patches): Add it.
---
gnu/local.mk | 1 +
gnu/packages/patches/fluxbox-1.3.7-gcc.patch | 16 ++++++++++++++++
gnu/packages/wm.scm | 3 ++-
3 files changed, 19 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/fluxbox-1.3.7-gcc.patch

Toggle diff (50 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 2b3df5d75a..478a7cb954 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1144,6 +1144,7 @@ dist_patch_DATA = \
%D%/packages/patches/flatpak-fix-path.patch \
%D%/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch \
%D%/packages/patches/fluxbox-1.3.7-no-dynamic-cursor.patch \
+ %D%/packages/patches/fluxbox-1.3.7-gcc.patch \
%D%/packages/patches/fontconfig-cache-ignore-mtime.patch \
%D%/packages/patches/foobillard++-pkg-config.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
diff --git a/gnu/packages/patches/fluxbox-1.3.7-gcc.patch b/gnu/packages/patches/fluxbox-1.3.7-gcc.patch
new file mode 100644
index 0000000000..0c805251ac
--- /dev/null
+++ b/gnu/packages/patches/fluxbox-1.3.7-gcc.patch
@@ -0,0 +1,16 @@
+Author: Danny Milosavljevic <dannym@scratchpost.org>
+Date: 2023-06-12
+License: expat
+
+diff -ur orig/fluxbox-1.3.7/util/fluxbox-remote.cc fluxbox-1.3.7/util/fluxbox-remote.cc
+--- orig/fluxbox-1.3.7/util/fluxbox-remote.cc 1970-01-01 01:00:01.000000000 +0100
++++ fluxbox-1.3.7/util/fluxbox-remote.cc 2023-05-01 01:11:52.225547895 +0200
+@@ -73,7 +73,7 @@
+ if (strcmp(cmd, "result") == 0) {
+ XTextProperty text_prop;
+ if (XGetTextProperty(disp, root, &text_prop, atom_result) != 0
+- && text_prop.value > 0
++ && text_prop.value != NULL
+ && text_prop.nitems > 0) {
+
+ printf("%s", text_prop.value);
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c380abc0e8..f5bbf40fcd 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1033,7 +1033,8 @@ (define-public fluxbox
(base32
"1h1f70y40qd225dqx937vzb4k2cz219agm1zvnjxakn5jkz7b37w"))
(patches
- (search-patches "fluxbox-1.3.7-no-dynamic-cursor.patch"))))
+ (search-patches "fluxbox-1.3.7-no-dynamic-cursor.patch"
+ "fluxbox-1.3.7-gcc.patch"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("CPPFLAGS=-U__TIME__") ;ugly, but for reproducibility
--
2.39.2
Ludovic Courtès wrote 2 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 64352@debbugs.gnu.org)
87lefemagu.fsf@gnu.org
Hey Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/patches/fluxbox-1.3.7-gcc.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/wm.scm (fluxbox)[source](patches): Add it.

Go for it!

Ludo’.
Danny Milosavljevic wrote 2 years ago
[PATCH] gnu: fluxbox: Fix build.
(address . 64352-done@debbugs.gnu.org)
20230819132837.0b082f92@scratchpost.org
This fluxbox build fix was pushed to guix master as commit 18b6e309cec3a0c9c7401b131e18612914f1fcf9.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmTgp2UACgkQ5xo1VCww
uqVHSgf8C4V9/AWfSJSdfA18cWWHyr0ZGWmux2fBSPT7UjzxHlw6MfAKWZ6mHfrS
ZIv+emtaMmSgvqiH3HhrTxf1VwM7ERPa4CJHca66338ANcWamCUt4QdP3JuilDKH
hGrHD5OwGM3Q5xR2tluQX3CzdZ2bJaajm/hX+nmbcWbCZ04qZcODeeh07VjW31Ka
ikN3PSOm5o1E3AAxf+EsCJnm7NUBHtqbPh+C1+rtIj/d2GIG0BWVz+yB/FoQECrY
twjLwcZ8bTz/6Q3XRDbe25OqrUJaplsdqSoCDjoaqkFA4S2qnhmhmxi7AdB4UBVG
OdGruNlD65ukOsJKX/A0VfmiKogCzw==
=4+rl
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64352@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64352
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help