libsigrokdecode: check phase fails

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Howard
  • 宋文武
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 2 years ago
(name . Bug Guix)(address . bug-guix@gnu.org)
ZJytXLfT8mBjFwAg@theoden
I am trying to install pulseview, but libsigrokdecode fails to build, dying at the check phase. It appears to be a dependency-related issue - test programs cannot build do to undefined functions.

```
ld: ./.libs/libsigrokdecode.so: undefined reference to `PyList_Insert'
ld: ./.libs/libsigrokdecode.so: undefined reference to `PyModule_AddObject'
ld: ./.libs/libsigrokdecode.so: undefined reference to `PySys_GetObject'
<<<snip>>>
ld: ./.libs/libsigrokdecode.so: undefined reference to `PyUnicode_AsUTF8String'
ld: ./.libs/libsigrokdecode.so: undefined reference to `Py_IsInitialized'
ld: ./.libs/libsigrokdecode.so: undefined reference to `PyDict_New'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:751: tests/main] Error 1
make: *** [Makefile:1353: check-am] Error 2

Test suite failed, dumping logs.
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check" "-j" "4") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 0.5 seconds
command "make" "check" "-j" "4" failed with status 2
```

Full build log is attached.

I see an open bug at https://issues.guix.gnu.org/63971, but I'm not sure if this is the same issue or not.

Here is my system information:

```
christopher@theoden
-------------------
OS: Guix System x86_64
Host: OptiPlex 9020 00
Kernel: 5.15.112-gnu
Uptime: 35 days, 7 hours, 37 mins
Packages: 93 (guix-system), 191 (guix-user)
Shell: bash 5.1.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: shepherd
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
GPU: Intel HD Graphics
Memory: 5121MiB / 7867MiB
```

--
📛 Christopher Howard
🚀 gemini://gem.librehacker.com

בראשית ברא אלהים את השמים ואת הארץ
宋文武 wrote 2 years ago
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 64340-done@debbugs.gnu.org)
87v8d1w7dn.fsf@envs.net
Christopher Howard <christopher@librehacker.com> writes:

Toggle quote (29 lines)
> I am trying to install pulseview, but libsigrokdecode fails to build,
> dying at the check phase. It appears to be a dependency-related issue
> - test programs cannot build do to undefined functions.
>
> ```
> ld: ./.libs/libsigrokdecode.so: undefined reference to `PyList_Insert'
> ld: ./.libs/libsigrokdecode.so: undefined reference to `PyModule_AddObject'
> ld: ./.libs/libsigrokdecode.so: undefined reference to `PySys_GetObject'
> <<<snip>>>
> ld: ./.libs/libsigrokdecode.so: undefined reference to `PyUnicode_AsUTF8String'
> ld: ./.libs/libsigrokdecode.so: undefined reference to `Py_IsInitialized'
> ld: ./.libs/libsigrokdecode.so: undefined reference to `PyDict_New'
> collect2: error: ld returned 1 exit status
> make[1]: *** [Makefile:751: tests/main] Error 1
> make: *** [Makefile:1353: check-am] Error 2
>
> Test suite failed, dumping logs.
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("check" "-j"
> "4") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 0.5 seconds
> command "make" "check" "-j" "4" failed with status 2
> ```
>
> Full build log is attached.
>
> I see an open bug at <https://issues.guix.gnu.org/63971>, but I'm not sure if this is the same issue or not.
>

Thanks for the report, and I had fixed it by apply update for
libsigrokdecode from 63971.

Closing!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64340@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64340
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help