[PATCH] gnu: Add wasmedge.

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 27 Jun 2023 21:23
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
676b37f167fe09ae7c6834629bd3cc1ad0811a49.1687893815.git.felix.lechner@lease-up.com
This is a project of the Linux Foundation.

* gnu/packages/web.scm (wasmedge): New variable.
---
gnu/packages/web.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3c50864cf4..156a0f0cd7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -156,6 +156,8 @@ (define-module (gnu packages web)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages lisp-xyz)
+ #:use-module (gnu packages llvm)
+ #:use-module (gnu packages logging)
#:use-module (gnu packages lsof)
#:use-module (gnu packages lua)
#:use-module (gnu packages mail)
@@ -1593,6 +1595,42 @@ (define-public wabt
other systems that want to manipulate WebAssembly files.")
(license license:asl2.0)))
+(define-public wasmedge
+ (package
+ (name "wasmedge")
+ (version "0.12.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WasmEdge/WasmEdge")
+ (commit version)))
+ (file-name (git-file-name "WasmEdge" version))
+ (sha256
+ (base32
+ "0h3m60gk02a9ws6x96f1b7wkcihi9r1690akh55qnizg93vrl5m4"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:configure-flags
+ ;; our LLVM version seems to cause: compiler.cpp:4919:3:
+ ;; error: too few arguments to function call, expected 5, have 4
+ #~(list "-DWASMEDGE_BUILD_AOT_RUNTIME=OFF")))
+ (native-inputs (list
+ boost
+ clang
+ lld
+ spdlog))
+ (home-page "https://wasmedge.org/")
+ (synopsis "Cloud Native Computing Foundations's WebAssembly runtime")
+ (description "WasmEdge is a lightweight, high-performance, and extensible
+WebAssembly runtime for cloud native, edge, and decentralized applications.
+It powers serverless apps, embedded functions, microservices, smart contracts,
+and IoT devices.
+
+This is a Linux Foundation project, via the Cloud Native Computing Foundation.")
+ (license license:asl2.0)))
+
(define-public wasm3
(package
(name "wasm3")

base-commit: ac86174e22fcd762893bd4515786b1376af9397b
--
2.40.1
?