[PATCH 0/4] Fixup uwufetch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Juliana Sims
  • Ludovic Courtès
Owner
unassigned
Submitted by
Juliana Sims
Severity
normal
J
J
Juliana Sims wrote on 26 Jun 2023 19:10
(address . guix-patches@gnu.org)(name . Juliana Sims)(address . juli@incana.org)
20230626171043.22853-1-juli@incana.org
Hello,

While doing a periodic check on updates to packages I've submitted to Guix, I noticed that there were some issues with uwufetch - namely, running `guix shell --pure uwufetch` left you with a broken package. This patch series takes care of that and fixes some other minor issues I noticed along the way.

Thanks,
Juli

Juliana Sims (4):
gnu: uwufetch: Fix typo in build phase name.
gnu: uwufetch: Manually create missing include dir.
gnu: uwufetch: Add missing propagated inputs.
gnu: uwufetch: Add supported-systems.

gnu/packages/admin.scm | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)


base-commit: 05a7f7bf6e30ca958a86c3853222d45e075459b0
--
2.40.1
J
J
Juliana Sims wrote on 26 Jun 2023 19:14
[PATCH 1/4] gnu: uwufetch: Fix typo in build phase name.
(address . 64305@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
20230626171407.23641-1-juli@incana.org
* gnu/packages/admin.scm (uwufetch) [arguments]: Fix typo in build phase name.
---
gnu/packages/admin.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a81a3f3414..39d363272b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4020,7 +4020,7 @@ (define-public uwufetch
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
- (add-before 'build 'path-source-paths
+ (add-before 'build 'patch-source-paths
(lambda _
(substitute* "uwufetch.c"
(("(/usr(/local)?)(.*;)" all _ _ rest)
--
2.40.1
J
J
Juliana Sims wrote on 26 Jun 2023 19:14
[PATCH 2/4] gnu: uwufetch: Manually create missing include dir.
(address . 64305@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
20230626171407.23641-2-juli@incana.org
* gnu/packages/admin.scm (uwufetch) [arguments]: Manually create missing
include dir.
---
gnu/packages/admin.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 39d363272b..0af0ef4051 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4024,7 +4024,11 @@ (define-public uwufetch
(lambda _
(substitute* "uwufetch.c"
(("(/usr(/local)?)(.*;)" all _ _ rest)
- (string-append #$output rest))))))))
+ (string-append #$output rest)))))
+ ;; TODO this will be fixed in the next release of uwufetch
+ (add-before 'install 'make-include-dir
+ (lambda _
+ (mkdir-p (string-append #$output "/include")))))))
(inputs (list lshw
;; viu XXX not yet packaged in Guix
xwininfo))
--
2.40.1
J
J
Juliana Sims wrote on 26 Jun 2023 19:14
[PATCH 3/4] gnu: uwufetch: Add missing propagated inputs.
(address . 64305@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
20230626171407.23641-3-juli@incana.org
* gnu/packages/admin.scm (uwufetch) [propagated-inputs]: Add missing
propagated inputs.
---
gnu/packages/admin.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 0af0ef4051..2c87976721 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4029,6 +4029,8 @@ (define-public uwufetch
(add-before 'install 'make-include-dir
(lambda _
(mkdir-p (string-append #$output "/include")))))))
+ (propagated-inputs (list gawk
+ grep))
(inputs (list lshw
;; viu XXX not yet packaged in Guix
xwininfo))
--
2.40.1
J
J
Juliana Sims wrote on 26 Jun 2023 19:14
[PATCH 4/4] gnu: uwufetch: Add supported-systems.
(address . 64305@debbugs.gnu.org)(name . Juliana Sims)(address . juli@incana.org)
20230626171407.23641-4-juli@incana.org
* gnu/packages/admin.scm (uwufetch): Add supported-systems.
---
gnu/packages/admin.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2c87976721..1611b9f0a6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4042,7 +4042,13 @@ (define-public uwufetch
well as a summary of system information. UwUFetch's unique contribution is the
uwu-ification of various words used in the description. For example, Guix
becomes gUwUix.")
- (license license:gpl3+)))
+ (license license:gpl3+)
+ (supported-systems
+ (filter (lambda (sys)
+ (not (member sys (list "i586-gnu"
+ "mips64el-linux"
+ "powerpc-linux"))))
+ %supported-systems))))
(define-public screenfetch
(package
--
2.40.1
J
J
Juliana Sims wrote on 27 Jul 2023 06:03
(address . 64305@debbugs.gnu.org)
TLSFYR.VE3UA2BXEOPQ2@incana.org
Hey,

Pinging this since it's been up a month.

Upon further investigation into the usage of supported-systems, I don't
think the 4th patch is correct and it can therefore be disregarded.

Thanks,
Juli
L
L
Ludovic Courtès wrote on 8 Aug 2023 17:23
Re: bug#64305: [PATCH 0/4] Fixup uwufetch.
(name . Juliana Sims)(address . juli@incana.org)(address . 64305@debbugs.gnu.org)
87h6p9r21j.fsf_-_@gnu.org
Hi!

Finally applied patches #1 and #2, thanks!

Juliana Sims <juli@incana.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/admin.scm (uwufetch) [propagated-inputs]: Add missing
> propagated inputs.

[...]

Toggle quote (3 lines)
> + (propagated-inputs (list gawk
> + grep))

This is somewhat intrusive as installing uwufetch would now pull in
these two packages in the user’s profile.

Could we address the problem differently, for instance by changing a
mere reference to “gawk” to “/gnu/store/…/bin/gawk” in the source?

TIA,
Ludo’.
J
J
Juliana Sims wrote on 10 Aug 2023 04:37
[PATCH] gnu: uwufetch: Add and use missing inputs.
(address . 64305@debbugs.gnu.org)
1b44a2db770f4f2a956c2235ea9cba3f0d1383a9.1691635036.git.juli@incana.org
Hi there,

Oops! I sent that last email wrong!

For Ludovic: this is the same as that other email, but I want to make sure
everything is threaded and catalogued properly.

For everyone else: this patch takes Ludovic's advice and substitutes references
to "grep" and "awk" in the uwufetch source code with references to the
fully-qualified paths of those binaries. It adds them as regular inputs rather
than the propagated inputs the previous version of this patch added them as.

Thanks,
Juli

* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
[phases]: Use the fully-qualified paths of the input gawk and grep.
---
gnu/packages/admin.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@ (define-public uwufetch
(delete 'configure)
(add-before 'build 'patch-source-paths
(lambda _
+ (substitute* "fetch.c"
+ (("grep")
+ #$(file-append grep "/bin/grep"))
+ (("awk")
+ #$(file-append gawk "/bin/awk")))
(substitute* "uwufetch.c"
(("(/usr(/local)?)(.*;)" all _ _ rest)
(string-append #$output rest)))))
@@ -4033,6 +4038,8 @@ (define-public uwufetch
(lambda _
(mkdir-p (string-append #$output "/include")))))))
(inputs (list lshw
+ gawk
+ grep
;; viu XXX not yet packaged in Guix
xwininfo))
(home-page "https://github.com/TheDarkBug/uwufetch")

base-commit: 90e34d25d5e7c14b7f3293a78f3cdad676c0d035
--
2.41.0
L
L
Ludovic Courtès wrote on 12 Aug 2023 22:36
(name . Juliana Sims)(address . juli@incana.org)(address . 64305-done@debbugs.gnu.org)
87leegdmlv.fsf@gnu.org
Hi,

Juliana Sims <juli@incana.org> skribis:

Toggle quote (18 lines)
> Hi there,
>
> Oops! I sent that last email wrong!
>
> For Ludovic: this is the same as that other email, but I want to make sure
> everything is threaded and catalogued properly.
>
> For everyone else: this patch takes Ludovic's advice and substitutes references
> to "grep" and "awk" in the uwufetch source code with references to the
> fully-qualified paths of those binaries. It adds them as regular inputs rather
> than the propagated inputs the previous version of this patch added them as.
>
> Thanks,
> Juli
>
> * gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
> [phases]: Use the fully-qualified paths of the input gawk and grep.

Perfect, thank you!

Ludo’.
Closed
?