[PATCH] gnu: Add xorgxrdp

  • Done
  • quality assurance status badge
Details
One participant
  • Andy Tai
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
Blocked by

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
b14fccf01386e1f4e4fe8da3db5d73e97006f8a3.1687597528.git.atai@atai.org
* gnu/packages/xorg.scm (xorgxrdp): New variable
---
gnu/packages/xorg.scm | 46 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2b26deddc2..eea88b416d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6691,6 +6691,52 @@ (define-public setroot
and can restore previously set wallpapers and options.")
(license license:gpl3+)))
+(define-public xorgxrdp
+ (package
+ (name "xorgxrdp")
+ (version "0.9.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/neutrinolabs/xorgxrdp/releases/download/v"
+ version "/xorgxrdp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m8lvdnhfvwwqrr56difgy3mblplp23x6iy12kl4r8i87ic4rky1"))))
+ (build-system gnu-build-system)
+ (inputs (list check
+ libx11
+ libxfixes
+ libxfont2
+ libxml2
+ libxpm
+ libxrandr
+ libxslt
+ libxt
+ pixman
+ xdpyinfo
+ xorg-server
+ xrdp))
+ (native-inputs (list autoconf
+ automake
+ libtool
+ nasm
+ intltool
+ pkg-config
+ pixman))
+ (arguments
+ (list #:configure-flags #~(list "--enable-strict-locations=yes"
+ (string-append "XRDP_CFLAGS=-I"
+ (assoc-ref %build-inputs
+ "xrdp")
+ "/common"))))
+ (home-page "https://github.com/neutrinolabs/xorgxrdp")
+ (synopsis "Xorg drivers for xrdp")
+ (description
+ "xorgxrdp is a collection of modules to be used with a pre-existing X.Org
+install to make the X server act like X11rdp")
+ (license license:x11)))
+
(define-public xrdp
(package

base-commit: dcca13ed7340f17a33a4c0907c13b64d5da66a8e
--
2.40.1
Andy Tai wrote 2 years ago
[PATCH v2] gnu: Add xorgxrdp
(address . 64262@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
d6348017d695cb7bdca36d23bd6c7023a49063c0.1687670628.git.atai@atai.org
* gnu/packages/xorg.scm (xorgxrdp): New variable
---
gnu/packages/xorg.scm | 46 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6316c515f7..330856d201 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6691,6 +6691,52 @@ (define-public setroot
and can restore previously set wallpapers and options.")
(license license:gpl3+)))
+(define-public xorgxrdp
+ (package
+ (name "xorgxrdp")
+ (version "0.9.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/neutrinolabs/xorgxrdp/releases/download/v"
+ version "/xorgxrdp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m8lvdnhfvwwqrr56difgy3mblplp23x6iy12kl4r8i87ic4rky1"))))
+ (build-system gnu-build-system)
+ (inputs (list check
+ libx11
+ libxfixes
+ libxfont2
+ libxml2
+ libxpm
+ libxrandr
+ libxslt
+ libxt
+ pixman
+ xdpyinfo
+ xorg-server
+ xrdp))
+ (native-inputs (list autoconf
+ automake
+ libtool
+ nasm
+ intltool
+ pkg-config
+ pixman))
+ (arguments
+ (list #:configure-flags #~(list "--enable-strict-locations=yes"
+ (string-append "XRDP_CFLAGS=-I"
+ (assoc-ref %build-inputs
+ "xrdp")
+ "/common"))))
+ (home-page "https://github.com/neutrinolabs/xorgxrdp")
+ (synopsis "Xorg drivers for xrdp")
+ (description
+ "xorgxrdp is a collection of modules to be used with a pre-existing X.Org
+install to make the X server act like X11rdp")
+ (license license:x11)))
+
(define-public xrdp
(package

base-commit: dcca13ed7340f17a33a4c0907c13b64d5da66a8e
prerequisite-patch-id: d62a34522944b00de3673f3e18c5f79e14012e2f
--
2.40.1
Andy Tai wrote 2 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E-duz9p2DSe+-4zxq_hwnHDBYMHfpf9XtVMerE=E5yeHQ@mail.gmail.com
block 64262 by 64261
Andy Tai wrote 2 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E9iMBGRxwoJg8yXFCsfZBc+SWsZGQUGkoDiqJpFiccqdQ@mail.gmail.com
close 64262
thanks
patch merged into 64261
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64262@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64262
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help