Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* gnu/packages/xorg.scm (xorgxrdp): New variable
---
gnu/packages/xorg.scm | 46 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)
Toggle diff (61 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2b26deddc2..eea88b416d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6691,6 +6691,52 @@ (define-public setroot
and can restore previously set wallpapers and options.")
(license license:gpl3+)))
+(define-public xorgxrdp
+ (package
+ (name "xorgxrdp")
+ (version "0.9.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/neutrinolabs/xorgxrdp/releases/download/v"
+ version "/xorgxrdp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m8lvdnhfvwwqrr56difgy3mblplp23x6iy12kl4r8i87ic4rky1"))))
+ (build-system gnu-build-system)
+ (inputs (list check
+ libx11
+ libxfixes
+ libxfont2
+ libxml2
+ libxpm
+ libxrandr
+ libxslt
+ libxt
+ pixman
+ xdpyinfo
+ xorg-server
+ xrdp))
+ (native-inputs (list autoconf
+ automake
+ libtool
+ nasm
+ intltool
+ pkg-config
+ pixman))
+ (arguments
+ (list #:configure-flags #~(list "--enable-strict-locations=yes"
+ (string-append "XRDP_CFLAGS=-I"
+ (assoc-ref %build-inputs
+ "xrdp")
+ "/common"))))
+ (home-page "https://github.com/neutrinolabs/xorgxrdp")
+ (synopsis "Xorg drivers for xrdp")
+ (description
+ "xorgxrdp is a collection of modules to be used with a pre-existing X.Org
+install to make the X server act like X11rdp")
+ (license license:x11)))
+
(define-public xrdp
(package
base-commit: dcca13ed7340f17a33a4c0907c13b64d5da66a8e
--
2.40.1