[PATCH 0/2] gnu: utfcpp: Update to 3.2.3

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Hilton Chain
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 23 Jun 2023 17:33
(address . guix-patches@gnu.org)
cover.1687527788.git.hako@ultrarare.space
This patchset:
* Updates utfcpp to 3.2.3.
* Unbundles its test framework ftest as a new package used in the native-inputs.
* Fixes build issues caused by utfcpp's include path change.

The patchset is a split from both #62473 and #63765 since they have a common
procedure to update utfcpp.

As utfcpp has less dependents, it might be better to get this applied first.

For #63765, there's no change besides "utfcpp update" removal, so I'll keep the
current version before reviews or the QA process.

Reza Housseini (2):
gnu: Add ftest.
gnu: utfcpp: Update to 3.2.3.

gnu/packages/check.scm | 41 ++++++++++++++++++++++++++++++++++++++
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 ++++++++++++-------------
gnu/packages/video.scm | 5 +++++
4 files changed, 60 insertions(+), 15 deletions(-)


base-commit: f25529b08e356f89ca7cecc44295085531a8faba
--
2.40.1
H
H
Hilton Chain wrote on 23 Jun 2023 17:35
[PATCH 1/2] gnu: Add ftest.
(address . 64255@debbugs.gnu.org)
3984f2b4285c7f0a688096f3bd2771b10f898db1.1687527788.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/check.scm (ftest): New variable.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/check.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 87728fefa3..0aa519ad67 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -43,6 +43,8 @@
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,6 +67,7 @@ (define-module (gnu packages check)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -92,6 +95,7 @@ (define-module (gnu packages check)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
@@ -863,6 +867,43 @@ (define-public doctest
has been designed to be fast, light and unintrusive.")
(license license:expat)))
+(define-public ftest
+ ;; There aren't any releases and it looks more like a small side project.
+ ;; It is included for completness to run tests for package utfcpp.
+ (let ((commit "c4ad4af0946b73ce1a40cbc72205d15d196c7e06")
+ (revision "0"))
+ (package
+ (name "ftest")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nemtrif/ftest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jcd76zjhx5f2nsi80hj7gmywgpz1f7vcw8lv5yf7gx0l99dn86x"))))
+ ;; No CMakeLists.txt file provided, only one to run tests
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan
+ #~'(("ftest.h" "include/ftest/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (invoke "cmake" ".")
+ (invoke "make")
+ (invoke "ctest")))))))
+ (native-inputs (list cmake-minimal))
+ (home-page "https://github.com/nemtrif/ftest")
+ (synopsis "C++ testing framework")
+ (description
+ "This package provides a simple and limited unit-test framework for C++.")
+ (license license:boost1.0))))
+
(define-public go-github.com-smartystreets-gunit
(package
(name "go-github.com-smartystreets-gunit")
--
2.40.1
H
H
Hilton Chain wrote on 23 Jun 2023 17:35
[PATCH 2/2] gnu: utfcpp: Update to 3.2.3.
(address . 64255@debbugs.gnu.org)
ba79e406df3d412956bed4b2df5ee77704052d03.1687527788.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/textutils.scm (utfcpp): Update to 3.2.3.
[snippet]: Unbundle ftest.
[arguments]: Remove field.
[native-inputs]: Add ftest.
* gnu/packages/games.scm (warzone2100)<#:phases>: Adjust 'fix-utfcpp-include.
* gnu/packages/video.scm (mkvtoolnix)<#:phases>: Add 'fix-utfcpp-include.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 +++++++++++++--------------
gnu/packages/video.scm | 5 +++++
3 files changed, 19 insertions(+), 15 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 83704dd720..9dbf5a3739 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5510,7 +5510,7 @@ (define-public warzone2100
(lambda _
(substitute* "lib/framework/wzstring.cpp"
(("<utfcpp/source/utf8.h>")
- "<utf8.h>"))))
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'link-tests-with-qt
(lambda _
(substitute* "tests/Makefile.am"
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 51df3748cd..5f7ab7a438 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -25,6 +25,8 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -687,29 +689,26 @@ (define-public catdoc
(define-public utfcpp
(package
(name "utfcpp")
- (version "2.3.5")
+ (version "3.2.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nemtrif/utfcpp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; Unbundle ftest
+ (snippet
+ '(begin
+ (delete-file-recursively "extern")
+ (substitute* (find-files "tests" "\\.cpp")
+ (("\"../extern/ftest/ftest.h\"")
+ "<ftest/ftest.h>"))))
(sha256
(base32
- "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+ "00hzh39iddbc6nxg13813qd6d55g2kccwjf5dr96wykfhway9wbr"))))
(build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (include (string-append out "/include"))
- (doc (string-append out "/share/doc/" ,name)))
- (copy-recursively "source" include)
- (install-file "README.md" doc)
- #t))))))
+ (native-inputs (list ftest))
(home-page "https://github.com/nemtrif/utfcpp")
(synopsis "Portable C++ library for handling UTF-8")
(description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 55eab972b9..43ae3899f9 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1048,6 +1048,11 @@ (define-public mkvtoolnix
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "src/common/strings/utf8.cpp"
+ (("<utf8.h>")
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'patch-relative-file-names
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
--
2.40.1
H
H
Hilton Chain wrote on 3 Aug 2023 09:50
Re: [PATCH 0/8] gnu: python-lief: Update to 0.13.0.
(address . control@debbugs.gnu.org)
87tttg5zu5.wl-hako@ultrarare.space
block 63765 by 64255
thanks
H
H
Hilton Chain wrote on 3 Aug 2023 16:05
[PATCH v2 0/2] gnu: utfcpp: Update to 3.2.3.
(address . 64255@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1691061465.git.hako@ultrarare.space
V1 -> V2: Rebase (and see if QA can pick this up).

All affected packages reported by `guix refresh -l' builds on my system
(x86_64-linux).

Thanks

Reza Housseini (2):
gnu: Add ftest.
gnu: utfcpp: Update to 3.2.3.

gnu/packages/check.scm | 41 ++++++++++++++++++++++++++++++++++++++
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 ++++++++++++-------------
gnu/packages/video.scm | 5 +++++
4 files changed, 60 insertions(+), 15 deletions(-)


base-commit: 23e2ff223c0511317edf236504fb474e3b5ac301
--
2.41.0
H
H
Hilton Chain wrote on 3 Aug 2023 16:06
[PATCH v2 1/2] gnu: Add ftest.
(address . 64255@debbugs.gnu.org)
65f32133382837082ef16d59e61146e375b665b6.1691061465.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/check.scm (ftest): New variable.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/check.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 71dc9eb54b..51aa40f18d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -45,6 +45,8 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +69,7 @@ (define-module (gnu packages check)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -94,6 +97,7 @@ (define-module (gnu packages check)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
@@ -813,6 +817,43 @@ (define-public doctest
has been designed to be fast, light and unintrusive.")
(license license:expat)))
+(define-public ftest
+ ;; There aren't any releases and it looks more like a small side project.
+ ;; It is included for completness to run tests for package utfcpp.
+ (let ((commit "c4ad4af0946b73ce1a40cbc72205d15d196c7e06")
+ (revision "0"))
+ (package
+ (name "ftest")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nemtrif/ftest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jcd76zjhx5f2nsi80hj7gmywgpz1f7vcw8lv5yf7gx0l99dn86x"))))
+ ;; No CMakeLists.txt file provided, only one to run tests
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan
+ #~'(("ftest.h" "include/ftest/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (invoke "cmake" ".")
+ (invoke "make")
+ (invoke "ctest")))))))
+ (native-inputs (list cmake-minimal))
+ (home-page "https://github.com/nemtrif/ftest")
+ (synopsis "C++ testing framework")
+ (description
+ "This package provides a simple and limited unit-test framework for C++.")
+ (license license:boost1.0))))
+
(define-public python-gixy
;; The 0.1.20 release is missing some important fixes.
;; XXX: Commit 'e9008dcbd11f43ccac109b0cf2bf98a94e76b449' breaks tests
--
2.41.0
H
H
Hilton Chain wrote on 3 Aug 2023 16:06
[PATCH v2 2/2] gnu: utfcpp: Update to 3.2.3.
(address . 64255@debbugs.gnu.org)
a187541a551dec9dadd722a2bf081fd9c8d556ff.1691061465.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/textutils.scm (utfcpp): Update to 3.2.3.
[snippet]: Unbundle ftest.
[arguments]: Remove field.
[native-inputs]: Add ftest.
* gnu/packages/games.scm (warzone2100)<#:phases>: Adjust 'fix-utfcpp-include.
* gnu/packages/video.scm (mkvtoolnix)<#:phases>: Add 'fix-utfcpp-include.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 +++++++++++++--------------
gnu/packages/video.scm | 5 +++++
3 files changed, 19 insertions(+), 15 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1573d7de00..82302852f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5573,7 +5573,7 @@ (define-public warzone2100
(lambda _
(substitute* "lib/framework/wzstring.cpp"
(("<utfcpp/source/utf8.h>")
- "<utf8.h>"))))
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'link-tests-with-qt
(lambda _
(substitute* "tests/Makefile.am"
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 4e026fc6f9..5fbfdde284 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -25,6 +25,8 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,29 +692,26 @@ (define-public catdoc
(define-public utfcpp
(package
(name "utfcpp")
- (version "2.3.5")
+ (version "3.2.3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nemtrif/utfcpp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; Unbundle ftest
+ (snippet
+ '(begin
+ (delete-file-recursively "extern")
+ (substitute* (find-files "tests" "\\.cpp")
+ (("\"../extern/ftest/ftest.h\"")
+ "<ftest/ftest.h>"))))
(sha256
(base32
- "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+ "00hzh39iddbc6nxg13813qd6d55g2kccwjf5dr96wykfhway9wbr"))))
(build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (include (string-append out "/include"))
- (doc (string-append out "/share/doc/" ,name)))
- (copy-recursively "source" include)
- (install-file "README.md" doc)
- #t))))))
+ (native-inputs (list ftest))
(home-page "https://github.com/nemtrif/utfcpp")
(synopsis "Portable C++ library for handling UTF-8")
(description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 801c2602e4..f75a528b13 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1050,6 +1050,11 @@ (define-public mkvtoolnix
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "src/common/strings/utf8.cpp"
+ (("<utf8.h>")
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'patch-relative-file-names
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
--
2.41.0
H
H
Hilton Chain wrote on 13 Aug 2023 06:50
[PATCH v3 0/2] gnu: utfcpp: Update to 3.2.4.
(address . 64255@debbugs.gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
cover.1691902040.git.hako@ultrarare.space
V2 -> V3: utfcpp@3.2.4.
V1 -> V2: Rebase (and see if QA can pick this up).

Reza Housseini (2):
gnu: Add ftest.
gnu: utfcpp: Update to 3.2.4.

gnu/packages/check.scm | 41 ++++++++++++++++++++++++++++++++++++++
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 ++++++++++++-------------
gnu/packages/video.scm | 5 +++++
4 files changed, 60 insertions(+), 15 deletions(-)


base-commit: d0a2b422e06aab0cab3a10a47ef378602992577f
--
2.41.0
H
H
Hilton Chain wrote on 13 Aug 2023 06:51
[PATCH v3 1/2] gnu: Add ftest.
(address . 64255@debbugs.gnu.org)
4dac2d0cc77b0fd59b4b17b033c5aced15d84eaf.1691902040.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/check.scm (ftest): New variable.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/check.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (75 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1d70ea9fe0..a3a79ae189 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -45,6 +45,8 @@
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +69,7 @@ (define-module (gnu packages check)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -94,6 +97,7 @@ (define-module (gnu packages check)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
@@ -813,6 +817,43 @@ (define-public doctest
has been designed to be fast, light and unintrusive.")
(license license:expat)))
+(define-public ftest
+ ;; There aren't any releases and it looks more like a small side project.
+ ;; It is included for completness to run tests for package utfcpp.
+ (let ((commit "c4ad4af0946b73ce1a40cbc72205d15d196c7e06")
+ (revision "0"))
+ (package
+ (name "ftest")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nemtrif/ftest")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jcd76zjhx5f2nsi80hj7gmywgpz1f7vcw8lv5yf7gx0l99dn86x"))))
+ ;; No CMakeLists.txt file provided, only one to run tests
+ (build-system copy-build-system)
+ (arguments
+ (list #:install-plan
+ #~'(("ftest.h" "include/ftest/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (invoke "cmake" ".")
+ (invoke "make")
+ (invoke "ctest")))))))
+ (native-inputs (list cmake-minimal))
+ (home-page "https://github.com/nemtrif/ftest")
+ (synopsis "C++ testing framework")
+ (description
+ "This package provides a simple and limited unit-test framework for C++.")
+ (license license:boost1.0))))
+
(define-public python-gixy
;; The 0.1.20 release is missing some important fixes.
;; XXX: Commit 'e9008dcbd11f43ccac109b0cf2bf98a94e76b449' breaks tests
--
2.41.0
H
H
Hilton Chain wrote on 13 Aug 2023 06:51
[PATCH v3 2/2] gnu: utfcpp: Update to 3.2.4.
(address . 64255@debbugs.gnu.org)
c8f4e7fe3cc9b1abedfa31e73f0417878c71ab21.1691902040.git.hako@ultrarare.space
From: Reza Housseini <reza@housseini.me>

* gnu/packages/textutils.scm (utfcpp): Update to 3.2.4.
[snippet]: Unbundle ftest.
[arguments]: Remove field.
[native-inputs]: Add ftest.
* gnu/packages/games.scm (warzone2100)<#:phases>: Adjust 'fix-utfcpp-include.
* gnu/packages/video.scm (mkvtoolnix)<#:phases>: Add 'fix-utfcpp-include.

Co-authored-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/games.scm | 2 +-
gnu/packages/textutils.scm | 27 +++++++++++++--------------
gnu/packages/video.scm | 5 +++++
3 files changed, 19 insertions(+), 15 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bf5c680042..9ba5d4a964 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5573,7 +5573,7 @@ (define-public warzone2100
(lambda _
(substitute* "lib/framework/wzstring.cpp"
(("<utfcpp/source/utf8.h>")
- "<utf8.h>"))))
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'link-tests-with-qt
(lambda _
(substitute* "tests/Makefile.am"
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 4e026fc6f9..508a954254 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -25,6 +25,8 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
+;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,29 +692,26 @@ (define-public catdoc
(define-public utfcpp
(package
(name "utfcpp")
- (version "2.3.5")
+ (version "3.2.4")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/nemtrif/utfcpp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ ;; Unbundle ftest
+ (snippet
+ '(begin
+ (delete-file-recursively "extern")
+ (substitute* (find-files "tests" "\\.cpp")
+ (("\"../extern/ftest/ftest.h\"")
+ "<ftest/ftest.h>"))))
(sha256
(base32
- "1gr98d826z6wa58r1s5i7rz7q2x3r31v7zj0pjjlrc7gfxwklr4s"))))
+ "0p18cbdk57ilbgcgprgqp7fgysb5i0nidczbhc5rnxkiiw4jvxgn"))))
(build-system cmake-build-system)
- (arguments
- `(#:out-of-source? #f
- #:phases
- (modify-phases %standard-phases
- (replace 'install ; no install target
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (include (string-append out "/include"))
- (doc (string-append out "/share/doc/" ,name)))
- (copy-recursively "source" include)
- (install-file "README.md" doc)
- #t))))))
+ (native-inputs (list ftest))
(home-page "https://github.com/nemtrif/utfcpp")
(synopsis "Portable C++ library for handling UTF-8")
(description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7df68e8f53..6355acfd4e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1054,6 +1054,11 @@ (define-public mkvtoolnix
"--enable-precompiled-headers=no")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-utfcpp-include
+ (lambda _
+ (substitute* "src/common/strings/utf8.cpp"
+ (("<utf8.h>")
+ "<utf8cpp/utf8.h>"))))
(add-after 'unpack 'patch-relative-file-names
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
--
2.41.0
A
A
Andreas Enge wrote on 30 Aug 2023 14:57
Green light
(address . 64255@debbugs.gnu.org)
ZO88wYEav5ZwFX1C@jurong
Hello Hilton,

there is a green button from QA, I had a quick look over the first version
of the patches, and they look good to me. Since you have git commit access
now, I let you apply the patches and close the bug!

Andreas
H
H
Hilton Chain wrote on 1 Sep 2023 11:00
(name . Andreas Enge)(address . andreas@enge.fr)(address . 64255-done@debbugs.gnu.org)
875y4ul13q.wl-hako@ultrarare.space
Hi Andreas,

On Wed, 30 Aug 2023 20:57:37 +0800,
Andreas Enge wrote:
Toggle quote (7 lines)
>
> Hello Hilton,
>
> there is a green button from QA, I had a quick look over the first version
> of the patches, and they look good to me. Since you have git commit access
> now, I let you apply the patches and close the bug!

Thank you, pushed it to master.
Closed
?