* gnu/packages/cran.scm (r-mlr): New variable.
---
gnu/packages/cran.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)
Toggle diff (60 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7deebbe72f..0fa8680e9c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35206,6 +35206,53 @@ (define-public r-mhg
\"Discovering Motifs in Ranked Lists of DNA Sequences\" by Eran Eden.")
(license license:gpl2)))
+(define-public r-mlr
+ (package
+ (name "r-mlr")
+ (version "2.19.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr" version))
+ (sha256
+ (base32
+ "00jjhvaqifj6glqsyzixlp56bvlch5smck8kk3klcmwx9pasyllx"))))
+ (properties `((upstream-name . "mlr")))
+ (build-system r-build-system)
+ (inputs (list gdal
+ geos
+ glu
+ gmp
+ gsl
+ jags
+ mpfr
+ openmpi
+ proj
+ udunits))
+ (propagated-inputs (list r-backports
+ r-bbmisc
+ r-checkmate
+ r-data-table
+ r-ggplot2
+ r-parallelmap
+ r-paramhelpers
+ r-stringi
+ r-survival
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://mlr.mlr-org.com")
+ (synopsis "Machine learning in R")
+ (description
+ "Interface to a large number of classification and regression techniques.
+These technics include machine-readable parameter descriptions. There is also
+an experimental extension for survival analysis, clustering and general,
+example-specific cost-sensitive learning. Generic resampling, including
+cross-validation, bootstrapping and subsampling. Hyperparameter tuning with
+modern optimization techniques, for single- and multi-objective problems.
+Filter and wrapper methods for feature selection. Extension of basic learners
+with additional operations common in machine learning, also allowing for easy
+nested resampling. Most operations can be parallelized.")
+ (license license:bsd-2)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.34.1