[PATCH 00/15] *** R package (scriabin) ***

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
cover.1687527674.git.navid.afkhami@mdc-berlin.de
Hi,

An R package + all the dependencies.

Your review is highly appreciated.

Thank you

Navid Afkhami (15):
gnu: Add r-paramhelpers.
gnu: Add r-smoof.
gnu: Add r-parallelmap.
gnu: Add r-mlr.
gnu: Add r-mlrmbo.
gnu: Add r-emoa.
gnu: Add r-diagrammer.
gnu: Add r-tidyft.
gnu: Add r-ggfittext.
gnu: Add r-dunn-test.
gnu: Add r-cellid.
gnu: Add r-dicekriging.
gnu: Add r-nichenetr.
gnu: Add r-fsa.
gnu: Add r-scriabin.

gnu/packages/bioconductor.scm | 44 +++++
gnu/packages/bioinformatics.scm | 111 +++++++++++
gnu/packages/cran.scm | 318 ++++++++++++++++++++++++++++++++
3 files changed, 473 insertions(+)


base-commit: f25529b08e356f89ca7cecc44295085531a8faba
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 01/15] gnu: Add r-paramhelpers.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
9d8c0cec7064590b00d025f4b014c4f92916c8fb.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-paramhelpers): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ba81580258..d9a1914eb0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2408,6 +2408,29 @@ (define-public r-paralleldist
naming conventions as distance methods of existing R packages.")
(license license:gpl2+)))
+(define-public r-paramhelpers
+ (package
+ (name "r-paramhelpers")
+ (version "1.14.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ParamHelpers" version))
+ (sha256
+ (base32
+ "088sl3az4ysq8cyw82brdn9xm5yy7rqskxih462d1m5hi62gyl04"))))
+ (properties `((upstream-name . "ParamHelpers")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-backports r-bbmisc r-checkmate r-fastmatch))
+ (home-page "https://paramhelpers.mlr-org.com")
+ (synopsis
+ "Helpers for parameters in black-box ptimization, tuning and machine learning")
+ (description
+ "Package for parameter description and operations in optimization, tuning and machine learning.
+Parameters can be described (type, constraints, defaults, etc.), combined
+to parameter sets and can in general be programmed on. A useful OptPath
+object (archive) to log function evaluations is also provided.")
+ (license license:bsd-2)))
+
(define-public r-pheatmap
(package
(name "r-pheatmap")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 02/15] gnu: Add r-smoof.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
f59fc6beb800648543047989b16068357edc1f74.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-smoof): New variable.
---
gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d9a1914eb0..3eec62f9c2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8159,6 +8159,34 @@ (define-public r-sm
and density estimation")
(license license:gpl2+)))
+(define-public r-smoof
+ (package
+ (name "r-smoof")
+ (version "1.6.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "smoof" version))
+ (sha256
+ (base32
+ "1cazhnd0m5jjzixaqgqh2h3rsa2sw3k8slj5cmgm8v47aaqn91mg"))))
+ (properties `((upstream-name . "smoof")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbmisc
+ r-checkmate
+ r-ggplot2
+ r-paramhelpers
+ r-rcpp
+ r-rcpparmadillo))
+ (home-page "https://jakobbossek.github.io/smoof/")
+ (synopsis "Single and multi-objective optimization test functions")
+ (description
+ "This tool generates high number of both single- and multi-objective test functions.
+These functions are frequently used for the benchmarking of
+(numerical) optimization algorithms. Moreover, it offers a
+set of convenient functions to generate, plot and work with
+objective functions.")
+ (license license:bsd-2)))
+
(define-public r-smurf
(package
(name "r-smurf")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 03/15] gnu: Add r-parallelmap.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
c3880cce7d7ad82832c46c650ef8d7027be4263d.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-parallelmap): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3eec62f9c2..7deebbe72f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2431,6 +2431,30 @@ (define-public r-paramhelpers
object (archive) to log function evaluations is also provided.")
(license license:bsd-2)))
+(define-public r-parallelmap
+ (package
+ (name "r-parallelmap")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "parallelMap" version))
+ (sha256
+ (base32
+ "1qg7zpz5sd9jp8wzjqahkhipwj1jn192llwg06q4gv9mlcsac261"))))
+ (properties `((upstream-name . "parallelMap")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bbmisc r-checkmate))
+ (home-page "https://parallelmap.mlr-org.com")
+ (synopsis "Unified interface to parallelization back-ends")
+ (description
+ "Unified parallelization framework for multiple back-end.
+This package is designed for internal package and interactive usage.
+The main operation is parallel mapping over lists. Supports local',
+multicore', mpi and BatchJobs mode. Allows tagging of the parallel
+operation with a level name that can be later selected by the user to
+switch on parallel execution for exactly this operation.")
+ (license license:bsd-2)))
+
(define-public r-pheatmap
(package
(name "r-pheatmap")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 04/15] gnu: Add r-mlr.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
fc726da409f9408ef364f3ac61da25917bcfc6bf.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-mlr): New variable.
---
gnu/packages/cran.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7deebbe72f..0fa8680e9c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35206,6 +35206,53 @@ (define-public r-mhg
\"Discovering Motifs in Ranked Lists of DNA Sequences\" by Eran Eden.")
(license license:gpl2)))
+(define-public r-mlr
+ (package
+ (name "r-mlr")
+ (version "2.19.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr" version))
+ (sha256
+ (base32
+ "00jjhvaqifj6glqsyzixlp56bvlch5smck8kk3klcmwx9pasyllx"))))
+ (properties `((upstream-name . "mlr")))
+ (build-system r-build-system)
+ (inputs (list gdal
+ geos
+ glu
+ gmp
+ gsl
+ jags
+ mpfr
+ openmpi
+ proj
+ udunits))
+ (propagated-inputs (list r-backports
+ r-bbmisc
+ r-checkmate
+ r-data-table
+ r-ggplot2
+ r-parallelmap
+ r-paramhelpers
+ r-stringi
+ r-survival
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://mlr.mlr-org.com")
+ (synopsis "Machine learning in R")
+ (description
+ "Interface to a large number of classification and regression techniques.
+These technics include machine-readable parameter descriptions. There is also
+an experimental extension for survival analysis, clustering and general,
+example-specific cost-sensitive learning. Generic resampling, including
+cross-validation, bootstrapping and subsampling. Hyperparameter tuning with
+modern optimization techniques, for single- and multi-objective problems.
+Filter and wrapper methods for feature selection. Extension of basic learners
+with additional operations common in machine learning, also allowing for easy
+nested resampling. Most operations can be parallelized.")
+ (license license:bsd-2)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 05/15] gnu: Add r-mlrmbo.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
a349cb1d14188741b29b9018c1645813aead5989.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-mlrmbo): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0fa8680e9c..4e9ea8b67e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -35253,6 +35253,40 @@ (define-public r-mlr
nested resampling. Most operations can be parallelized.")
(license license:bsd-2)))
+(define-public r-mlrmbo
+ (package
+ (name "r-mlrmbo")
+ (version "1.1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlrMBO" version))
+ (sha256
+ (base32
+ "16fwj7m28g4km7yalqppxmh3lw2jln0z072l6awia38qkdg6xwhc"))))
+ (properties `((upstream-name . "mlrMBO")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-backports
+ r-bbmisc
+ r-checkmate
+ r-data-table
+ r-lhs
+ r-mlr
+ r-parallelmap
+ r-paramhelpers
+ r-smoof))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/mlr-org/mlrMBO")
+ (synopsis "Model-based optimization with mlr")
+ (description
+ "Flexible and comprehensive R toolbox for model-based optimization.
+It implements Efficient Global Optimization Algorithm for single- and
+multi-objective optimization. Supports mixed parameters. The machine
+learning toolbox mlr offers regression learners. Provides various
+infill criteria. Features batch proposal, parallel execution,
+visualization, logging. Modular implementation allows easy customization
+by the user.")
+ (license license:bsd-2)))
+
(define-public r-mlr3measures
(package
(name "r-mlr3measures")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 07/15] gnu: Add r-diagrammer.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
be6e76c20a902bfa96b0c88e761f159eeda4bdd5.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-diagrammer): New variable.
---
gnu/packages/cran.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 34d4749b14..247f9a6f96 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -28898,6 +28898,46 @@ (define-public r-diagram
Francesca Mazzia (2012).")
(license license:gpl2+)))
+(define-public r-diagrammer
+ (package
+ (name "r-diagrammer")
+ (version "1.0.10")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "DiagrammeR" version))
+ (sha256
+ (base32
+ "147q7zgwhd7vc0l134sqkkf6n6s6bznxvcmsrdx2f5df12bsixkj"))))
+ (properties `((upstream-name . "DiagrammeR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-downloader
+ r-dplyr
+ r-glue
+ r-htmltools
+ r-htmlwidgets
+ r-igraph
+ r-magrittr
+ r-purrr
+ r-rcolorbrewer
+ r-readr
+ r-rlang
+ r-rstudioapi
+ r-scales
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-viridis
+ r-visnetwork))
+ (native-inputs (list esbuild))
+ (home-page "https://github.com/rich-iannone/DiagrammeR")
+ (synopsis "Graph/network visualization")
+ (description
+ "DiagrammeR creates, modifies, analyzes, and visualizes network graph diagrams.
+The output can be incorporated into R Markdown documents, integrated
+with Shiny web apps, converted to other graph formats, or exported as
+image files.")
+ (license license:expat)))
+
(define-public r-lim
(package
(name "r-lim")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 06/15] gnu: Add r-emoa.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
67f4837d05f089fd106f71583df0a12ec7f0f12b.1687527674.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-emoa): New variable.
---
gnu/packages/cran.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e9ea8b67e..34d4749b14 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26111,6 +26111,24 @@ (define-public r-showtext
such as Ghostscript is needed to use this package.")
(license license:asl2.0)))
+(define-public r-emoa
+ (package
+ (name "r-emoa")
+ (version "0.5-0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "emoa" version))
+ (sha256
+ (base32
+ "0fr4ia3hkv8c7wkl64a51s6ynldppc812ynwldvbwy25dhlbvs6r"))))
+ (properties `((upstream-name . "emoa")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/web/packages/emoa/")
+ (synopsis "Evolutionary multiobjective optimization algorithms")
+ (description
+ "Building blocks for the design and analysis of multiobjective optimization algorithms.")
+ (license license:gpl2)))
+
(define-public r-emojifont
(package
(name "r-emojifont")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 08/15] gnu: Add r-tidyft.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
60983004638ee8e33e4429614b5288fdca7256d7.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-tidyft): New variable.
---
gnu/packages/cran.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 247f9a6f96..9938d07dd9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3005,6 +3005,29 @@ (define-public r-vegan
data types as well.")
(license license:gpl2+)))
+(define-public r-tidyft
+ (package
+ (name "r-tidyft")
+ (version "0.5.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyft" version))
+ (sha256
+ (base32
+ "00qcsr2sx8fwyil384vgppx0q72qjrkj7h5nv4mdxdi8f9h6ph2r"))))
+ (properties `((upstream-name . "tidyft")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table r-fst r-stringr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hope-data-science/tidyft")
+ (synopsis "Fast and memory efficient data operations in tidy syntax")
+ (description "Tidyft is an extension of data.table.
+It uses modifiification by reference whenever possible.
+This toolkit is designed for big data analysis in
+high-performance desktop or laptop computers. The syntax
+of the package is similar or identical to tidyverse.")
+ (license license:expat)))
+
(define-public r-tidyverse
(package
(name "r-tidyverse")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 09/15] gnu: Add r-ggfittext.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
2d18fe91a165af42582d19bc109122c14513f48e.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-ggfittext): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9938d07dd9..bb09a8d774 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -722,6 +722,26 @@ (define-public r-ggalt
text annotations.")
(license license:agpl3)))
+(define-public r-ggfittext
+ (package
+ (name "r-ggfittext")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggfittext" version))
+ (sha256
+ (base32
+ "06xfv552nhw13wc8dixyqhhmw5zh8hphrabw090nzb33cpfwzin8"))))
+ (properties `((upstream-name . "ggfittext")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-gridtext r-shades r-stringi))
+ (native-inputs (list r-knitr))
+ (home-page "https://wilkox.org/ggfittext/")
+ (synopsis "Ggfittext is a ggplot2 extension for fitting text into boxes")
+ (description
+ "Ggfittext is a ggplot2 extension for fitting text into boxes.")
+ (license license:gpl2)))
+
(define-public r-glmpca
(package
(name "r-glmpca")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 10/15] gnu: Add r-dunn-test.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
e92f0ae53216d1a154324b98da86719e8291ab5c.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-dunn-test): New variable.
---
gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb09a8d774..2873c3ce10 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27314,6 +27314,31 @@ (define-public r-dummies
classes into dummy/indicator variables.")
(license license:gpl2+)))
+(define-public r-dunn-test
+ (package
+ (name "r-dunn-test")
+ (version "1.3.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "dunn.test" version))
+ (sha256
+ (base32
+ "0lqwvyl3pyygfc73nf81gzw3zl3w43r7ki0yw2dgrzhkpb2iji4a"))))
+ (properties `((upstream-name . "dunn.test")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=dunn.test")
+ (synopsis "Dunn's test of multiple comparisons using rank sums")
+ (description
+ "Dunn's test computes stochastic dominance & reports pairwise comparisons.
+This is done following a Kruskal-Wallis test (Kruskal and Wallis, 1952).
+It employs Dunn's z-test-statistic approximations for rank statistics,
+conducting k(k-1)/2 comparisons. The null hypothesis assumes that the
+probability of a randomly selected value from the first group being
+larger than one from the second group is one half, similar to the
+Wilcoxon-Mann-Whitney test. Dunn's test serves as a test for median
+difference and takes into account tied ranks.")
+ (license license:gpl2)))
+
(define-public r-acrm
(package
(name "r-acrm")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 11/15] gnu: Add r-cellid.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
136afa3705c111fa1e341c41b9ef84edf22a1fcf.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-cellid): New variable.
---
gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 00701c4463..78cab7171b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1436,6 +1436,50 @@ (define-public r-celldex
single-cell data or deconvolution of bulk RNA-seq.")
(license license:gpl3)))
+(define-public r-cellid
+ (package
+ (name "r-cellid")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CelliD" version))
+ (sha256
+ (base32
+ "0vigvqjrlqbi5kviaj8qvyq3v8afgbc5pjrz7zmx2ckf4hdp0g03"))))
+ (properties `((upstream-name . "CelliD")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-data-table
+ r-biocparallel
+ r-fastmatch
+ r-fgsea
+ r-ggplot2
+ r-glue
+ r-irlba
+ r-matrix
+ r-matrixstats
+ r-pbapply
+ r-rcpp
+ r-rcpparmadillo
+ r-reticulate
+ r-rtsne
+ r-seurat
+ r-stringr
+ r-tictoc
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-umap))
+ (native-inputs (list r-knitr r-scater))
+ (home-page "https://bioconductor.org/packages/CelliD")
+ (synopsis
+ "Single cell gene signature extraction using multiple correspondence analysis")
+ (description
+ "CelliD is a clustering-free method for extracting per-cell gene signatures from scRNA-seq.
+CelliD allows unbiased cell identity recognition across different donors,
+tissues-of-origin, model organisms and single-cell omics protocols. The
+package can also be used to explore functional pathways enrichment in
+single cell data.")
+ (license license:gpl3)))
+
(define-public r-champdata
(package
(name "r-champdata")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 12/15] gnu: Add r-dicekriging.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
ccf1914b289c273e80a2ae6bdddfd4c4956f41ae.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-dicekriging): New variable.
---
gnu/packages/cran.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2873c3ce10..2f53c2f70d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -33926,6 +33926,23 @@ (define-public r-dicedesign
Design} (SFD) and to test their quality.")
(license license:gpl3)))
+(define-public r-dicekriging
+ (package
+ (name "r-dicekriging")
+ (version "1.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "DiceKriging" version))
+ (sha256
+ (base32
+ "0jfb2li6b93fkwgjkr4jwxnvv7zb0aqk9lkf2mnv2awzh0r16pdb"))))
+ (properties `((upstream-name . "DiceKriging")))
+ (build-system r-build-system)
+ (home-page "https://dicekrigingclub.github.io/www/")
+ (synopsis "Kriging Methods for Computer Experiments")
+ (description "Estimation, validation and prediction of kriging models.")
+ (license license:gpl2+)))
+
(define-public r-dials
(package
(name "r-dials")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 13/15] gnu: Add r-nichenetr.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
a4bee2ae7f4b458aab94cde210c3da1521bdfa2c.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-nichenetr): New variable.
---
gnu/packages/bioinformatics.scm | 57 +++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87e7c33b90..9de0470f7e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14800,6 +14800,63 @@ (define-public r-liana
interaction inference from scRNA-seq data.")
(license license:gpl3))))
+(define-public r-nichenetr
+ (let ((commit "cc3bcedfd6271df2e8ca85c8b771f7faa914cd3d")
+ (revision "1"))
+ (package
+ (name "r-nichenetr")
+ (version (git-version "1.1.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/saeyslab/nichenetr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jxkrk7cpwx0lbbgjrd885jxahdgk9ysfqp2drq22g486k6p2s9y"))))
+ (properties `((upstream-name . "nichenetr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-caret
+ r-catools
+ r-circlize
+ r-complexheatmap
+ r-cowplot
+ r-data-table
+ r-diagrammer
+ r-dicekriging
+ r-dplyr
+ r-e1071
+ r-emoa
+ r-fdrtool
+ r-ggplot2
+ r-ggpubr
+ r-hmisc
+ r-igraph
+ r-limma
+ r-magrittr
+ r-matrix
+ r-mlrmbo
+ r-parallelmap
+ r-purrr
+ r-randomforest
+ r-readr
+ r-rocr
+ r-seurat
+ r-tibble
+ r-tidyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/saeyslab/nichenetr")
+ (synopsis "The R implementation of the NicheNet method")
+ (description
+ "The goal of NicheNet is to study intercellular communication from a computational perspective.
+NicheNet uses human or mouse gene expression data of interacting cells
+as input and combines this with a prior model that integrates existing
+knowledge on ligand-to-target signaling paths. This allows to predict
+ligand-receptor interactions that might drive gene expression changes
+in cells of interest.")
+ (license license:gpl3))))
+
(define-public r-circus
(package
(name "r-circus")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 14/15] gnu: Add r-fsa.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
92d0d93079865f7bf08fdf91dead62588355c193.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-fsa): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2f53c2f70d..054c7c6f96 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11319,6 +11319,25 @@ (define-public r-dosnow
using the @code{snow} package.")
(license license:gpl2)))
+(define-public r-fsa
+ (package
+ (name "r-fsa")
+ (version "0.9.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "FSA" version))
+ (sha256
+ (base32
+ "0m63pik6bcqsbzizq8zjzilr2pxjl8b64ivdqzdnz09gmck73r5h"))))
+ (properties `((upstream-name . "FSA")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-car r-dunn-test r-lmtest r-plotrix r-withr))
+ (home-page "https://fishr-core-team.github.io/FSA/")
+ (synopsis "Simple fisheries stock assessment methods")
+ (description
+ "This package provides a variety of simple fish stock assessment methods.")
+ (license license:gpl2+)))
+
(define-public r-fstcore
(package
(name "r-fstcore")
--
2.34.1
Navid Afkhami wrote 2 years ago
[PATCH 15/15] gnu: Add r-scriabin.
(address . 64250@debbugs.gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
f5b907ea49fd87aa10eccd118d6ace53febc2e86.1687527675.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-scriabin): New variable.
---
gnu/packages/bioinformatics.scm | 54 +++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9de0470f7e..ca24263c79 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9866,6 +9866,60 @@ (define-public r-sccustomize
visualization and analysis of single-cell data using R.")
(license license:gpl3+))))
+(define-public r-scriabin
+ (let ((commit "313d15e9150413e6bcad0947215da3a09c0257f5")
+ (revision "1"))
+ (package
+ (name "r-scriabin")
+ (version (git-version "0.0.0.9000" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BlishLab/scriabin")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0k8khwcr3a281pa33h6l3wdk5igyqc4xknydiazk7qyf5w25g9zg"))))
+ (properties `((upstream-name . "scriabin")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ade4
+ r-cellid
+ r-circlize
+ r-clipr
+ r-complexheatmap
+ r-complexheatmap
+ r-cowplot
+ r-dplyr
+ r-factoextra
+ r-fsa
+ r-genefilter
+ r-ggalluvial
+ r-ggfittext
+ r-ggplot2
+ r-ggsci
+ r-limma
+ r-magrittr
+ r-matrix
+ r-matrixstats
+ r-networkd3
+ r-nichenetr
+ r-pbapply
+ r-qlcmatrix
+ r-scales
+ r-scater
+ r-seurat
+ r-tibble
+ r-tidyft
+ r-wgcna))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/BlishLab/scriabin")
+ (synopsis "Single-cell resolved interaction analysis through binning")
+ (description
+ "Scriabin aims to provide a comprehensive view of cell-cell communication (CCC).
+It achieves this without requiring subsampling or aggregation.")
+ (license license:expat))))
+
(define-public r-markdownhelpers
(let ((commit "793372d28ebed607cc1d35f909a1caedb2b41ffe")
(revision "1"))
--
2.34.1
Ricardo Wurmus wrote 2 years ago
[PATCH 00/15] *** R package (scriabin) ***
(address . 64250-done@debbugs.gnu.org)
87r0ppto21.fsf@elephly.net
My apologies for the delay.

Since r-diagrammer contains a lot of minified JavaScript without a way
for us to build it fully from source it has been moved to guix-science
(where we already had version 1.0.9). As a consequence r-nichenetr and
r-scriabin were also moved to guix-science.

Everything else has been pushed to the Guix master branch with minor
changes to formatting and descriptions.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64250@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64250
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help