[PATCH] gnu: Add wasi-libc.

  • Open
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • Jonathan Brielmaier
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 21 Jun 2023 20:37
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
d3eb8a055c41869d1714d562a1bdccb37a08d9ae.1687372549.git.felix.lechner@lease-up.com
* gnu/packages/wasi.scm: New file.
* gnu/packages/wasi.scm (wasi-libc): New variable.
---

The lint run shows this message but as far as I can tell it's bogus:

gnu/packages/wasi.scm:31:12: warning: no valid tags found for wasi-libc

gnu/local.mk | 1 +
gnu/packages/wasi.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
2 files changed, 62 insertions(+)
create mode 100644 gnu/packages/wasi.scm

Toggle diff (83 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 1b59cc522b..5e9fec6e2f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -636,6 +636,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/vpn.scm \
%D%/packages/vulkan.scm \
%D%/packages/w3m.scm \
+ %D%/packages/wasi.scm \
%D%/packages/wdiff.scm \
%D%/packages/weather.scm \
%D%/packages/web.scm \
diff --git a/gnu/packages/wasi.scm b/gnu/packages/wasi.scm
new file mode 100644
index 0000000000..8d5439c415
--- /dev/null
+++ b/gnu/packages/wasi.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages wasi)
+ #:use-module (gnu packages llvm)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public wasi-libc
+ (package
+ (name "wasi-libc")
+ (version "20")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/wasi-libc")
+ (commit (string-append "wasi-sdk-" version))
+ (recursive? #t)))
+ (file-name (git-file-name "wasi-sdk" version))
+ (sha256
+ (base32
+ "0knm5ch499dksmv1k0kh7356pjd9n1gjn0p3vp9bw57mn478zp8z"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (setenv "INSTALL_DIR" #$output))))))
+ (native-inputs (list
+ clang))
+ (home-page "https://github.com/WebAssembly/wasi-libc")
+ (synopsis "WASI libc implementation for WebAssembly")
+ (description "WASI Libc is a libc for WebAssembly programs built on top
+of WASI system calls. It provides a wide array of POSIX-compatible C APIs,
+including support for standard I/O, file I/O, filesystem manipulation, memory
+management, time, string, environment variables, program startup, and many
+other APIs.")
+ ;; triple-licensed under MIT/Expat and Apache 2.0 (either with or without
+ ;; the LLVM exception)
+ (license license:expat)))

base-commit: 1a0ff5cd83d3257efcab64740a1322de51fbc4a1
--
2.40.1
J
?